Announcement

Collapse
No announcement yet.

Catalyst Control Center not working

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    Originally posted by Spooky View Post
    @kmolazz
    Do you get some error messages from rpmbuild process like "file not found"?
    Spooky
    Hi,
    thanks for your help.
    I don't get any "file not found" error. I get this:
    Code:
    /var/tmp/rpm-tmp.40429: line 27: autoreconf: command not found
    error: Bad exit status from /var/tmp/rpm-tmp.40429 (%build)
    
    RPM build errors:
        Bad exit status from /var/tmp/rpm-tmp.40429 (%build)
    No files or directories are created inside "/var/tmp/xorg-x11-libX11-7.2-build/"

    Also, i wasn't able to rpmbuild logged just as a user (lots of "permission denied" errors).. had to change to su.

    Comment


    • #17
      @kmolazz

      Code:
      /var/tmp/rpm-tmp.40429: line 27: autoreconf: command not found
      This is the answer for your problem. "command not found" is comparable to "file not found". In this case "autoconf" is missing. I believe that you need some additional tools to build a rpm file.

      Look at line 12 ("# usedforbuild aaa_base acl ...") in "/usr/src/packages/SPECS/xorg-x11-libX11.spec" please, which other packages are required. The simplest way to add missing packages is YaST.

      Spooky

      Comment


      • #18
        Originally posted by Spooky View Post
        @kmolazz

        Code:
        /var/tmp/rpm-tmp.40429: line 27: autoreconf: command not found
        This is the answer for your problem. "command not found" is comparable to "file not found". In this case "autoconf" is missing. I believe that you need some additional tools to build a rpm file.

        Look at line 12 ("# usedforbuild aaa_base acl ...") in "/usr/src/packages/SPECS/xorg-x11-libX11.spec" please, which other packages are required. The simplest way to add missing packages is YaST.

        Spooky

        ...it's works now, had some others packages missing. Many thanks

        Is there any way i can change the amdcccle "shortcut"
        i have on kmenu to make it run without having to do it on console? I tried to change the command to what i use on console but it doesn't work...

        Comment


        • #19

          Comment


          • #20
            @kmolazz

            Insert this

            Code:
            #!/bin/bash
            export LD_PRELOAD=/home/spooky/libX11.so.6
            /usr/bin/amdcccle
            into a new script file like "/home/spooky/bin/amdcccle.sh". Replace "spooky" with the user name that you have at your system.

            Don't forget to make amdcccle.sh executable.

            Code:
            chmod 755 /home/spooky/bin/amdcccle.sh
            Change the shortcut property 'command' from amdcccle to "/home/spooky/bin/amdcccle.sh", then it should work.

            Spooky

            Comment


            • #21
              Thanks again, it's working now with the script.

              One last thing though, i can't change any anti-aliasing or anisotropic filtering setting on the control panel... they're all grayed out. I do have 3D because i can play all games I've tried so far so it's a bit weird


              regards,
              Carlos

              Comment


              • #22
                @kmolazz

                You must activate the checkbox "Override ... " first before you can use the scrollbar. It's possible that you must run amdcccle as root, because amdcccle makes some changes in /etc/ati/amdpcsdb and /etc/X11/xorg.conf.

                Spooky

                Comment


                • #23
                  Originally posted by Spooky View Post
                  @kmolazz

                  You must activate the checkbox "Override ... " first before you can use the scrollbar. It's possible that you must run amdcccle as root, because amdcccle makes some changes in /etc/ati/amdpcsdb and /etc/X11/xorg.conf.

                  Spooky

                  The checkbox it self is grayed out... that's what i don't get. I'd also noticed it changes the xorg.conf file as it took out the settings i had introduced to get rid of the "watermark corruption" i was having.. lol, i'll just refrain from using it.

                  thanks for your help

                  Comment


                  • #24
                    I tried this on fedora fc8 and it didn't work. I get this msg:
                    $ LD_PRELOAD=~/libX11.so.6 amdcccle
                    amdcccle: cannot connect to X server :0.0

                    Any ideas?

                    Comment


                    • #25
                      Thanks a lot for the useful hints...I had the same problem here, too...Catalyst Control Center refused to start...it failed with the error mentioned before:

                      amdcccle: xcb_xlib.c:50: xcb_xlib_unlock: Zusicherung »c->xlib.lock« nicht erfüllt.
                      Abgebrochen

                      I'm using Fedora Core 8 (werewolf) and the workaround for suse linux didn't fit for me...so here is what I did:

                      -after fiddling around for some time with the libX11 source package which also refused to compile (various errors) I decided to give the following solution a shot:

                      -downloaded libX11-1.0.3-8.fc7 RPM for i386 (old release of libX11 for fc7, no xcb support included) from:
                      http://hany.sk/~hany/RPM/f-7-i386/li....fc7.i386.html

                      -extracted libX11.so.6.2.0 from this package to a location like ~

                      -started amdcccle from a shell with:
                      LD_PRELOAD=./libX11.so.6.2.0 amdcccle

                      got ya!

                      So Catalyst Control Center is working now, besides that it is just a piece of f*g crap and should be considered alpha 0.2 ^^

                      so far, hope that helps the other fedora users out there...

                      Comment


                      • #26
                        @gbuster: tnx for the link problem solved

                        Comment


                        • #27
                          Originally posted by Snake View Post
                          Hey, what a clever workaround Tried that, seems to work perfectly.

                          For those running Gentoo here is a quick HOWTO:
                          1. Determine your currently installed libX11 version:
                            $ emerge -pv libX11

                          2. Build the same libX11 without xcb support, e.g.:
                            $ USE="-xcb" ebuild /usr/portage/x11-libs/libX11/libX11-1.1.2-r1.ebuild install

                          3. Copy the "non-xcb" libX11 to some "safe" place, e.g.:
                            $ cp /var/tmp/portage/x11-libs/libX11-1.1.2-r1/image/usr/lib64/libX11.so.* ~

                          4. Run amdcccle
                            $ LD_PRELOAD=~/libX11.so.6 amdcccle

                          You may have to adjust the paths as needed, but I think you get the general idea.

                          But, this bug should still be fixed for the next version. "Ceterum censeo Carthaginem esse delendam"
                          Awesome. I'm using Fedora Core 8, and all I needed to do was link to the library from my old Gentoo stage 4 tarball!

                          Comment

                          Working...
                          X