Announcement

Collapse
No announcement yet.

ATI Rage Mobility M3 on FC6

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • ATI Rage Mobility M3 on FC6

    I am trying to get native resolution (1400x1050) working with FC6 on an Inspiron 4000.

    When I installed FC6, I could really only read one third of the screen, with fuzzy lines and repeating images on the right. I was able to get the resolution a little better so I could read about two thirds of the screen.

    I had this same issue with FC3, but fixed it by simply going with Generic LCD and setting the resolution to the one that I wanted. I tried this several times and it didn't work with FC6. I also tried various edits to my xorg.conf, but couldn't get the right resolution.

    My first goal is to just get 1400x1050 working, the second one is to get the fancy 'eye candy' effects working.

    I also tried installing fglrx from Livna, but that didn't help. This, of course, after removing the i586 kernel, adding the i686 kernel, etc... Had to restore grub.conf....

    I have also done some pretty extensive Googling, but can't seem to figure out what I need to do to make this work. I am sure that there is a guide somewhere.

    I would appreciate any help on this. I would really like to get FC6 working.

    Thanks,

    David.

  • #2
    David,

    Welcome to the forums. First off what modifications had you tried to the xorg.conf? What resolution are you at now?

    The Livna / official fglrx drivers will not work with the ATI Rage Mobility M3. Your only choice is to use the open-source Xorg drivers.
    Michael Larabel
    http://www.michaellarabel.com/

    Comment


    • #3
      Michael,

      Thanks for the quick response. My most basic edits to xorg.conf were to add 1400x1050 to the line with the list of available resolutions. I never did change the device name line that includes the resolution.

      I was kind of taking shots in the dark.

      What would a good strategy be to make it work?

      Thanks,

      David.

      Originally posted by Michael View Post
      David,

      Welcome to the forums. First off what modifications had you tried to the xorg.conf? What resolution are you at now?

      The Livna / official fglrx drivers will not work with the ATI Rage Mobility M3. Your only choice is to use the open-source Xorg drivers.

      Comment


      • #4
        Have you tried using system-config-display?
        Michael Larabel
        http://www.michaellarabel.com/

        Comment


        • #5
          No. I am not sure how to do what you are suggesting.

          Comment


          • #6
            Go to

            System > Administration > Display

            and try setting up everything in there.
            Michael Larabel
            http://www.michaellarabel.com/

            Comment


            • #7
              That is what worked for me on FC3, but doesn't work on FC6.

              I was able to use the System>Administration to go from 800x600 to 1024x768, but when I try to go beyond that, it doesn't do anything.

              I can go in and select Generic LCD 1400x1050 and then select a resolution setting of 1400x1050, but when I log out and log back in again, it is back at 1024x768. Same thing with a reboot.

              David.

              Comment


              • #8
                Since you're using the included open-source display drivers, you may want to file a bug (or see if one exists) on the RedHat / Fedora BugZilla then.
                Michael Larabel
                http://www.michaellarabel.com/

                Comment


                • #9
                  David, after you change the resolution in system-config-display (System->Adminstration->Display), do you get a dialog saying that you should restart X for the changes to take effect or not? If you don't it probably means that you've still got the xorg.conf configured by aticonfig. Just replace the /etc/X11/xorg.conf with /etc/X11/xorg.conf.original-0, and then try using system-config-display to set your resolution, this time you should get a dialog that looks like this:
                  http://amenzix.bro.ro/files/phroronix2.html

                  Comment


                  • #10
                    Thanks for the suggestion amenzix. I got my native resolution working, but I am not exactly sure what I did.

                    I tried using the generic VGA driver through the GUI, and then when I tried to restart X, X failed to start. After trying the backup xorg.conf, which also failed, X tried to do an autodetect. When it came up, it was showing the config display dialog. I selected the generic LCD, 1400 x 1050, selected the same display resolution, got the dialog to restart X, and it came up in 1400 x 1050.

                    I am definitely saving a copy of my xorg.conf!!!

                    David.

                    Comment

                    Working...
                    X