Announcement

Collapse
No announcement yet.

Xlib: extension "XFree86-DRI" missing on display ":0.0" with fglrx + xgl + beryl

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Xlib: extension "XFree86-DRI" missing on display ":0.0" with fglrx + xgl + beryl

    Hello, i have now another problem with fglrx+glx+beryl

    yesterday all my ati was ok
    today i install glx and beryl

    Now i do a glxinfo | grep render and i get:
    glxinfo | grep render
    Xlib: extension "XFree86-DRI" missing on display ":0.0".
    direct rendering: No
    GLX_ATI_pixel_format_float, GLX_ATI_render_texture
    OpenGL renderer string: RADEON 9600 Generic
    I haven't got any error en xorg.log

    my xorg.conf is:
    # Xorg configuration created by system-config-display

    Section "ServerLayout"
    Identifier "single head configuration"
    Screen 0 "Screen0" 0 0
    InputDevice "Keyboard0" "CoreKeyboard"
    EndSection

    Section "Module"
    Load "dbe"
    Load "extmod"
    Load "fbdevhw"
    Load "glx"
    Load "record"
    Load "freetype"
    Load "type1"
    Load "dri"
    EndSection

    Section "ServerFlags"
    Option "AIGLX" "off"
    EndSection

    Section "InputDevice"
    Identifier "Keyboard0"
    Driver "kbd"
    Option "XkbModel" "pc105"
    Option "XkbLayout" "es"
    EndSection

    Section "Monitor"

    ### Comment all HorizSync and VertSync values to use DDC:
    ### Comment all HorizSync and VertSync values to use DDC:
    ### Comment all HorizSync and VertSync values to use DDC:
    ### Comment all HorizSync and VertSync values to use DDC:
    Identifier "Monitor0"
    VendorName "Monitor Vendor"
    ModelName "Monitor 1280x1024"
    ### Comment all HorizSync and VertSync values to use DDC:
    HorizSync 30.0 - 71.0
    VertRefresh 50.0 - 160.0
    Option "dpms"
    EndSection

    Section "Device"
    Identifier "Videocard0"
    Driver "fglrx"
    VendorName "Videocard vendor"
    BoardName "ATI Technologies Inc X1900"
    Option "VideoOverlay" "on"
    EndSection

    Section "Screen"
    Identifier "Screen0"
    Device "Videocard0"
    Monitor "Monitor0"
    DefaultDepth 24
    SubSection "Display"
    Viewport 0 0
    Depth 24
    Modes "1280x1024" "1280x960" "1280x800" "1152x864" "1152x768" "1024x768" "800x600" "640x480"
    EndSubSection
    EndSection

    Section "DRI"
    Group 0
    Mode 0666
    EndSection

    Section "Extensions"
    Option "Composite" "False"
    EndSection

    I dont know how to fix "Xlib: extension "XFree86-DRI" missing on display ":0.0"."
    I use xorg

    Can anybody help me?

    Thank u!
    BerMeJo
    Last edited by BerMeJo; 11-10-2006, 04:04 PM.

  • #2
    Did you try reinstalling the fglrx drivers? What repo did you use for Beryl and XGL?
    Michael Larabel
    http://www.michaellarabel.com/

    Comment


    • #3
      Hello

      about repositories:

      fedora-xgl
      [fedora-xgl]
      name=Fedora 5 - $basearch - Base Xgl repository
      baseurl=
      http://fedoraxgl.tuxfamily.org/repository/5/$basearch
      http://users.telenet.be/quenta/5/$basearch
      gpgcheck=0
      enabled=0
      #gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-AL-CAPCOM

      [fedora-xgl-source]
      name=Fedora Xgl tmp testing repository
      baseurl=
      http://fedoraxgl.tuxfamily.org/repository/5/SRPMS
      http://users.telenet.be/quenta/repository/5/SRPMS
      gpgcheck=1
      enabled=0
      #gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-AL-CAPCOM

      beryl-repo
      [beryl]
      name=Beryl for Fedora Core $releasever - $basearch
      baseurl=http://wilsonet.com/packages/beryl/fc$releasever-$basearch/
      enabled=1
      gpgcheck=0

      I reinstall drivers of ati livna

      Im using xorg, why ask for xfree??

      THank u!
      BerMeJo

      Comment


      • #4
        Try reinstalling the drivers or altering your configuration file, that's what it sounds like from the information provided.
        Michael Larabel
        http://www.michaellarabel.com/

        Comment


        • #5
          ok i reinstall everything

          ati livna ok and working

          Now, i install compiz

          rpm -e compiz 2> /dev/null
          yum clean all
          yum --enablerepo=fedora-xgl glitz-glx libsvg libsvg-cairo xorg-x11-server-Xgl xgl-hardware-list compiz

          gnome-xgl-switch --enable-xgl --auto

          [BerMeJo@BerMeJo-Neon ~]$ glxgears
          Xlib: extension "XFree86-DRI" missing on display ":0.0".
          12464 frames in 5.0 seconds = 2477.066 FPS


          Same problem, what can i do?
          u can see my xorg.conf in post in top, no errors in xorg.conf


          BerMeJo

          Comment


          • #6
            Did you try building the RPMs with the official installer as opposed to Livna?
            Michael Larabel
            http://www.michaellarabel.com/

            Comment


            • #7
              Sorry i dont understand u!
              Can u explain a bit?

              Thank u


              Originally posted by Michael View Post
              Did you try building the RPMs with the official installer as opposed to Livna?

              Comment


              • #8
                If you have all the proper development tools installed, you can go to www.ati.com and download the 8.30.3 ATI Linux display driver package. You can then run the installer with the --buildpkg Fedora/FC6 argument and it will automatically build the RPMs for you.
                Michael Larabel
                http://www.michaellarabel.com/

                Comment


                • #9
                  but i prefer to have livna becose this https://www.redhat.com/archives/fedo.../msg01565.html

                  U cant have compiz and livna driver??

                  Thank u
                  BerMeJo

                  Comment


                  • #10
                    Compiz with XGL should work. Did you try reinstalling Livna RPMs?
                    Michael Larabel
                    http://www.michaellarabel.com/

                    Comment

                    Working...
                    X