Announcement

Collapse
No announcement yet.

8.42 driver No GLXFBConfig for default depth

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • 8.42 driver No GLXFBConfig for default depth

    Running Gutsy here. Upgraded to the new driver fine. One question I have. Should I uninstall xserver-xgl? When I do I no longer get compiz working and I get the error.

    Fatal: No GLXFBConfig for default depth, this isn't going to work.

    I tried setting the resolution to 16 but then I get the xorg thingy asking me if I want to reconfigure. Tried running from git compiling myself. Tried removing everything and reinstalling the Ubuntu compiz. Tried using Trevino's build script.

    Now I'm back to running with xgl installed. Any ideas or is this normal.

    BTW:
    fglrxinfo
    display: :0.0 screen: 0
    OpenGL vendor string: ATI Technologies Inc.
    OpenGL renderer string: ATI Mobility Radeon X1300
    OpenGL version string: 2.0.6958 Release

    Section "Extensions"
    Option "Composite" "1"
    EndSection

    Section "ServerFlags"
    Option "AIGLX" "on"
    EndSection

  • #2
    Found the solution as soon as I posted this.
    I needed to whitelist fglrx in
    /etc/xdg/compiz/compiz-manager

    That fixed things.

    Comment


    • #3
      i use opensuse and i have the still problem:

      florin@florinsam-laptop:/etc/xdg> compiz
      compiz: Trying '/usr/$LIB/libIndirectGL.so.1'
      compiz (core) - Fatal: No GLXFBConfig for default depth, this isn't going to work.
      compiz (core) - Error: Failed to manage screen: 0
      compiz (core) - Fatal: No manageable screens found on display :0.0

      any ideeas?


      i don`t have /etc/xdg/compiz-manager. any ideeas?

      Comment


      • #4
        The same here...

        I also use OpenSuse 10.3 and got as well this error:

        Code:
        LIBGL_ALWAYS_INDIRECT=true compiz --replace
        compiz: Trying '/usr/$LIB/libIndirectGL.so.1'
        compiz (core) - Fatal: No GLXFBConfig for default depth, this isn't going to work.
        compiz (core) - Error: Failed to manage screen: 0
        compiz (core) - Fatal: No manageable screens found on display :0.0
        I adjusted /usr/bin/compiz-manager (!) to whitelist fglrx but it doesn't help.

        I put
        Code:
          Option         "AddARGBGLXVisuals" "True"
          Option         "DisableGLXRootClipping" "True"
          Option         "RenderAccel" "True"
        under the Screen section in xorg.conf (like it is recommended on many sites to avoid this problem).

        System: - Compiz 0.6.2 (0.5.2 did not work as well)
        - Ati Mobility Radeon X600

        ------
        fglrxinfo:
        Code:
        display: :0.0  screen: 0
        OpenGL vendor string: ATI Technologies Inc.
        OpenGL renderer string: ATI MOBILITY RADEON X600
        OpenGL version string: 2.0.6958 Release
        ------
        No errors in xorg.log
        Code:
        cat /var/log/Xorg.0.log | grep "EE"
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
        (II) Loading extension MIT-SCREEN-SAVER
        ------
        Some warnings during initiation of AIGLX:
        Code:
        cat /var/log/Xorg.0.log | grep "AIGLX"
        (**) Option "AIGLX" "on"
        (**) AIGLX enabled
        (WW) AIGLX: 3D driver claims to not support visual 0x23
        (WW) AIGLX: 3D driver claims to not support visual 0x24
        (WW) AIGLX: 3D driver claims to not support visual 0x25
        (WW) AIGLX: 3D driver claims to not support visual 0x26
        (WW) AIGLX: 3D driver claims to not support visual 0x27
        (WW) AIGLX: 3D driver claims to not support visual 0x28
        (WW) AIGLX: 3D driver claims to not support visual 0x29
        (WW) AIGLX: 3D driver claims to not support visual 0x2a
        (WW) AIGLX: 3D driver claims to not support visual 0x2b
        (WW) AIGLX: 3D driver claims to not support visual 0x2c
        (WW) AIGLX: 3D driver claims to not support visual 0x2d
        (WW) AIGLX: 3D driver claims to not support visual 0x2e
        (WW) AIGLX: 3D driver claims to not support visual 0x2f
        (WW) AIGLX: 3D driver claims to not support visual 0x30
        (WW) AIGLX: 3D driver claims to not support visual 0x31
        (WW) AIGLX: 3D driver claims to not support visual 0x32
        (WW) AIGLX: 3D driver claims to not support visual 0x33
        (WW) AIGLX: 3D driver claims to not support visual 0x34
        (WW) AIGLX: 3D driver claims to not support visual 0x35
        (WW) AIGLX: 3D driver claims to not support visual 0x36
        (WW) AIGLX: 3D driver claims to not support visual 0x37
        (WW) AIGLX: 3D driver claims to not support visual 0x38
        (WW) AIGLX: 3D driver claims to not support visual 0x39
        (WW) AIGLX: 3D driver claims to not support visual 0x3a
        (WW) AIGLX: 3D driver claims to not support visual 0x3b
        (WW) AIGLX: 3D driver claims to not support visual 0x3c
        (WW) AIGLX: 3D driver claims to not support visual 0x3d
        (WW) AIGLX: 3D driver claims to not support visual 0x3e
        (WW) AIGLX: 3D driver claims to not support visual 0x3f
        (WW) AIGLX: 3D driver claims to not support visual 0x40
        (WW) AIGLX: 3D driver claims to not support visual 0x41
        (WW) AIGLX: 3D driver claims to not support visual 0x42
        (WW) AIGLX: 3D driver claims to not support visual 0x43
        (WW) AIGLX: 3D driver claims to not support visual 0x44
        (WW) AIGLX: 3D driver claims to not support visual 0x45
        (WW) AIGLX: 3D driver claims to not support visual 0x46
        (WW) AIGLX: 3D driver claims to not support visual 0x47
        (WW) AIGLX: 3D driver claims to not support visual 0x48
        (WW) AIGLX: 3D driver claims to not support visual 0x49
        (WW) AIGLX: 3D driver claims to not support visual 0x4a
        (WW) AIGLX: 3D driver claims to not support visual 0x4b
        (WW) AIGLX: 3D driver claims to not support visual 0x4c
        (WW) AIGLX: 3D driver claims to not support visual 0x4d
        (WW) AIGLX: 3D driver claims to not support visual 0x4e
        (WW) AIGLX: 3D driver claims to not support visual 0x4f
        (WW) AIGLX: 3D driver claims to not support visual 0x50
        (WW) AIGLX: 3D driver claims to not support visual 0x51
        (WW) AIGLX: 3D driver claims to not support visual 0x52
        (WW) AIGLX: 3D driver claims to not support visual 0x53
        (WW) AIGLX: 3D driver claims to not support visual 0x54
        (WW) AIGLX: 3D driver claims to not support visual 0x55
        (WW) AIGLX: 3D driver claims to not support visual 0x56
        (WW) AIGLX: 3D driver claims to not support visual 0x57
        (WW) AIGLX: 3D driver claims to not support visual 0x58
        (WW) AIGLX: 3D driver claims to not support visual 0x59
        (WW) AIGLX: 3D driver claims to not support visual 0x5a
        (WW) AIGLX: 3D driver claims to not support visual 0x5b
        (WW) AIGLX: 3D driver claims to not support visual 0x5c
        (WW) AIGLX: 3D driver claims to not support visual 0x5d
        (WW) AIGLX: 3D driver claims to not support visual 0x5e
        (WW) AIGLX: 3D driver claims to not support visual 0x5f
        (WW) AIGLX: 3D driver claims to not support visual 0x60
        (WW) AIGLX: 3D driver claims to not support visual 0x61
        (WW) AIGLX: 3D driver claims to not support visual 0x62
        (WW) AIGLX: 3D driver claims to not support visual 0x63
        (WW) AIGLX: 3D driver claims to not support visual 0x64
        (WW) AIGLX: 3D driver claims to not support visual 0x65
        (WW) AIGLX: 3D driver claims to not support visual 0x66
        (WW) AIGLX: 3D driver claims to not support visual 0x67
        (WW) AIGLX: 3D driver claims to not support visual 0x68
        (WW) AIGLX: 3D driver claims to not support visual 0x69
        (WW) AIGLX: 3D driver claims to not support visual 0x6a
        (WW) AIGLX: 3D driver claims to not support visual 0x6b
        (WW) AIGLX: 3D driver claims to not support visual 0x6c
        (WW) AIGLX: 3D driver claims to not support visual 0x6d
        (WW) AIGLX: 3D driver claims to not support visual 0x6e
        (WW) AIGLX: 3D driver claims to not support visual 0x6f
        (WW) AIGLX: 3D driver claims to not support visual 0x70
        (WW) AIGLX: 3D driver claims to not support visual 0x71
        (WW) AIGLX: 3D driver claims to not support visual 0x72
        (II) AIGLX: Loaded and initialized /usr/lib/dri/fglrx_dri.so
        ----------
        glxinfo
        Code:
        name of display: :0.0
        display: :0  screen: 0
        direct rendering:
        Yes
        ----------
        DRI enabled:
        Code:
        grep DRI /var/log/Xorg.0.log
        (II) Loading extension XFree86-DRI
        (**) fglrx(0): Option "NoDRI" "no"
        (**) fglrx(0): NoDRI = NO
        (II) Loading extension ATIFGLRXDRI
        (II) fglrx(0): doing DRIScreenInit
        (II) fglrx(0): DRIScreenInit done
        (II) fglrx(0): DRI initialization successfull!
        (II) fglrx(0): [DRI] installation complete
        (II) GLX: Initialized DRI GL provider for screen 0
        -----------
        My xorg.conf
        Code:
        # /.../
        *snip*
        Section "Module"
          Load         "dbe"
          Load         "type1"
          Load         "freetype"
          Load         "extmod"
          Load         "glx"
          Load         "dri"
        EndSection
        
        Section "ServerFlags"
          Option       "AllowMouseOpenFail" "on"
          Option       "IgnoreABI" "on"
        EndSection
        
        *snip*
        
        Section "Monitor"
          Option       "CalcAlgorithm" "XServerPool"
          DisplaySize  331 207
          HorizSync    30-66
          Identifier   "Monitor[0]"
          ModelName    "NC8230"
          Option       "DPMS"
          VendorName   "HITACHI"
          VertRefresh  50-65
          UseModes     "Modes[0]"
        EndSection
        
        
        Section "Modes"
          Identifier   "Modes[0]"
        EndSection
        
        
        Section "Device"
          BoardName    "Radeon Mobility X600 (M24) 3150 (PCIE)"
          BusID        "1:0:0"
          Driver       "fglrx"
          Identifier   "Device[0]"
          #Option       "NoDDC"
          Option       "UseInternalAGPGART" "no"
          Option       "no_accel" "no"
          Option       "no_dri" "no"
          Option       "mtrr" "off"
          Option       "ScreenOverlap" "0"
          Option       "GammaCorrectionI" "0x00000000"
          Option       "GammaCorrectionII" "0x00000000"
          Option       "Capabilities" "0x00000000"
          Option       "CapabilitiesEx" "0x00000000"
          Option       "VideoOverlay" "on"
          Option       "OpenGLOverlay" "off"
          Option       "CenterMode" "off"
          Option       "PseudoColorVisuals" "off"
          Option       "Stereo" "off"
          Option       "StereoSyncEnable" "1"
          Option       "FSAAEnable" "no"
          Option       "FSAAScale" "1"
          Option       "FSAADisableGamma" "no"
          Option       "FSAACustomizeMSPos" "no"
          Option       "FSAAMSPosX0" "0.000000"
          Option       "FSAAMSPosY0" "0.000000"
          Option       "FSAAMSPosX1" "0.000000"
          Option       "FSAAMSPosY1" "0.000000"
          Option       "FSAAMSPosX2" "0.000000"
          Option       "FSAAMSPosY2" "0.000000"
          Option       "FSAAMSPosX3" "0.000000"
          Option       "FSAAMSPosY3" "0.000000"
          Option       "FSAAMSPosX4" "0.000000"
          Option       "FSAAMSPosY4" "0.000000"
          Option       "FSAAMSPosX5" "0.000000"
          Option       "FSAAMSPosY5" "0.000000"
          Option       "UseFastTLS" "0"
          Option       "BlockSignalsOnLock" "on"
          Option       "ForceGenericCPU" "no"
          Option       "KernelModuleParm" "locked-userpages=0"
          VendorName   "ATI"
        EndSection
        
        
        Section "Screen"
          Option         "AddARGBGLXVisuals" "True"
          Option         "DisableGLXRootClipping" "True"
          Option         "RenderAccel" "True"
          DefaultDepth 24
          SubSection "Display"
            Depth      15
            Modes      "1680x1050" 
          EndSubSection
          SubSection "Display"
            Depth      16
            Modes      "1680x1050" 
          EndSubSection
          SubSection "Display"
            Depth      24
            Modes      "1680x1050" 
          EndSubSection
          SubSection "Display"
            Depth      8
            Modes      "1680x1050" 
          EndSubSection
          Device       "Device[0]"
          Identifier   "Screen[0]"
          Monitor      "Monitor[0]"
        EndSection
        
        
        Section "ServerLayout"
          Identifier   "Layout[all]"
          InputDevice  "Keyboard[0]" "CoreKeyboard"
          InputDevice  "Mouse[1]" "CorePointer"
          InputDevice  "Mouse[3]" "SendCoreEvents"
          Screen       "Screen[0]"
          Option       "AIGLX" "on"
        EndSection
        
        Section "Extensions"
         Option       "Composite" "on"
        EndSection
        
        
        Section "DRI"
            Group      "video"
            Mode       0660
        EndSection
        Could anyone help?
        Thanks!

        Comment


        • #5
          Originally posted by zkyez View Post
          i use opensuse and i have the still problem:

          florin@florinsam-laptop:/etc/xdg> compiz
          compiz: Trying '/usr/$LIB/libIndirectGL.so.1'
          compiz (core) - Fatal: No GLXFBConfig for default depth, this isn't going to work.
          compiz (core) - Error: Failed to manage screen: 0
          compiz (core) - Fatal: No manageable screens found on display :0.0

          any ideeas?


          i don`t have /etc/xdg/compiz-manager. any ideeas?
          I changed /usr/bin/compiz-manager; added fglrx to the whitelist and removed all ati related things in the blacklist.

          But to no avail. I still get the same error in openSUSE 10.3 amd64. I think this is related to 64bit :/

          Comment


          • #6
            i have 32 bit and it`s the same:

            florin@florinsam-laptop:/etc/modprobe.d> compiz --replace
            compiz: Trying '/usr/$LIB/libIndirectGL.so.1'
            compiz (core) - Fatal: No GLXFBConfig for default depth, this isn't going to work.
            compiz (core) - Error: Failed to manage screen: 0
            compiz (core) - Fatal: No manageable screens found on display :0.0

            florinsam-laptop:~ # glxinfo |grep -i direct
            direct rendering: Yes

            florinsam-laptop:~ # glxinfo |grep -i pixmap
            GLX_ARB_multisample, GLX_EXT_import_context, GLX_EXT_texture_from_pixmap,
            GLX_SGIX_visual_select_group, GLX_EXT_texture_from_pixmap

            running fusion-icon i get:

            florin@florinsam-laptop:/etc/modprobe.d> fusion-icon
            * Detected Session: gnome
            * Searching for installed applications...
            * No GLX_EXT_texture_from_pixmap with direct rendering context
            ... present with indirect rendering, exporting: LIBGL_ALWAYS_INDIRECT=1

            Comment


            • #7
              $LIB looks a bit crazy in that output...

              Comment


              • #8
                Alas... back to 40.4 again... XGL didn't even want to run properly with 42 :/

                What is it with openSUSE and ATI?? Amdcccle doesn't want to run properly (also with hack in /etc/profile etc) and now the new drivers runs on Ubuntu but just wont budge on suse :?

                Comment


                • #9
                  Hi, I finally managed to run compiz (-fusion) on opensuse 10.3 version 0.6.2 by following this howto:
                  http://dev.compiz-fusion.org/~cybero...-the-hard-way/
                  In my case (Mobility Radeon, X600, 1gb ram, 2.13 ghz i686), like the howto's author, I experience a not usable compiz with artefacts in google-earth, mplayer not usable and slow effects (yes, also firefox/konqueror-scrolling). I will disable aiglx and composite and wait for the next release... (as usual).

                  Comment


                  • #10
                    Originally posted by Beno View Post
                    Hi, I finally managed to run compiz (-fusion) on opensuse 10.3 version 0.6.2 by following this howto:
                    http://dev.compiz-fusion.org/~cybero...-the-hard-way/
                    In my case (Mobility Radeon, X600, 1gb ram, 2.13 ghz i686), like the howto's author, I experience a not usable compiz with artefacts in google-earth, mplayer not usable and slow effects (yes, also firefox/konqueror-scrolling). I will disable aiglx and composite and wait for the next release... (as usual).
                    openSUSE 10.3 x86_64, followed the instructions, also renamed /usr/lib64/libInd....so.1 --> no succes

                    Compiz now segfaults.

                    Comment


                    • #11
                      Originally posted by Beno View Post
                      Hi, I finally managed to run compiz (-fusion) on opensuse 10.3 version 0.6.2 by following this howto:
                      http://dev.compiz-fusion.org/~cybero...-the-hard-way/
                      In my case (Mobility Radeon, X600, 1gb ram, 2.13 ghz i686), like the howto's author, I experience a not usable compiz with artefacts in google-earth, mplayer not usable and slow effects (yes, also firefox/konqueror-scrolling). I will disable aiglx and composite and wait for the next release... (as usual).
                      I have OpenSuSE 10.3 x86_64.
                      I had same problem with compiz:
                      ...
                      compiz (core) - Fatal: No GLXFBConfig for default
                      ...
                      and fgl_glxgears hasn't works.

                      But this solution help me )
                      First i delete rpm package for 10.3 AMD64.
                      Then install driver without package generation - and now i have fgl_glxgears works properly. Looks like some errors in fglrx rpm package for OpenSuSE10.3

                      Then i make: mv /usr/lib64/libIndirectGL.so.1 /usr/lib64/libIndirectGL.so.1.old
                      and now compiz works for me. But it's slow, buggy and completely unusable especially for video and OpenGL application. And kicker stand without redraw.

                      Maybe it because without libIndirectGL.so.1 only GLX_EXT_texture_from_pixmap used and no power of AIGLX?

                      Now i have disabled Composite and AIGLX.. and wait for normal solution from OpenSuSE developers or AMD new driver..

                      Comment


                      • #12
                        Same problem here.

                        My system:

                        openSUSE 10.3 (x86-64)
                        Ati Radeon 9600
                        flgrx is in whitelist in /usr/bin/compiz-manager

                        glxinfo | grep -i direct
                        Code:
                        direct rendering: Yes
                        cat /var/log/Xorg.0.log | grep GLX
                        Code:
                        (**) Option "AIGLX" "on"
                        (**) AIGLX enabled
                        (II) Loading extension GLX
                        (WW) AIGLX: 3D driver claims to not support visual 0x23
                        (WW) AIGLX: 3D driver claims to not support visual 0x24
                        ...
                        ...
                        ...
                        (WW) AIGLX: 3D driver claims to not support visual 0x6f
                        (WW) AIGLX: 3D driver claims to not support visual 0x70
                        (WW) AIGLX: 3D driver claims to not support visual 0x71
                        (WW) AIGLX: 3D driver claims to not support visual 0x72
                        (II) AIGLX: Loaded and initialized /usr/lib64/dri/fglrx_dri.so
                        (II) GLX: Initialized DRI GL provider for screen 0



                        Here my xorg.conf
                        Code:
                        # /.../
                        # SaX generated X11 config file
                        # Created on: 2007-10-23T22:10:51+0200.
                        #
                        # Version: 8.1
                        # Contact: Marcus Schaefer <sax@suse.de>, 2005
                        # Contact: SaX-User list <https://lists.berlios.de/mailman/listinfo/sax-users>
                        #
                        # Automatically generated by [ISaX] (8.1)
                        # PLEASE DO NOT EDIT THIS FILE!
                        #
                        
                        Section "ServerLayout"
                        	Identifier     "Layout[all]"
                        	Screen      0  "aticonfig-Screen[0]" 0 0
                        	InputDevice    "Keyboard[0]" "CoreKeyboard"
                        	InputDevice    "Mouse[1]" "CorePointer"
                        	Option	    "Clone" "off"
                        	Option	    "Xinerama" "off"
                        	Option       "AIGLX" "on"
                        EndSection
                        
                        Section "Files"
                        	InputDevices   "/dev/gpmdata"
                        	InputDevices   "/dev/input/mice"
                        	FontPath     "/usr/share/fonts/misc:unscaled"
                        	FontPath     "/usr/share/fonts/local"
                        	FontPath     "/usr/share/fonts/75dpi:unscaled"
                        	FontPath     "/usr/share/fonts/100dpi:unscaled"
                        	FontPath     "/usr/share/fonts/Type1"
                        	FontPath     "/usr/share/fonts/URW"
                        	FontPath     "/usr/share/fonts/Speedo"
                        	FontPath     "/usr/share/fonts/PEX"
                        	FontPath     "/usr/share/fonts/cyrillic"
                        	FontPath     "/usr/share/fonts/latin2/misc:unscaled"
                        	FontPath     "/usr/share/fonts/latin2/75dpi:unscaled"
                        	FontPath     "/usr/share/fonts/latin2/100dpi:unscaled"
                        	FontPath     "/usr/share/fonts/latin2/Type1"
                        	FontPath     "/usr/share/fonts/latin7/75dpi:unscaled"
                        	FontPath     "/usr/share/fonts/baekmuk:unscaled"
                        	FontPath     "/usr/share/fonts/japanese:unscaled"
                        	FontPath     "/usr/share/fonts/kwintv"
                        	FontPath     "/usr/share/fonts/truetype"
                        	FontPath     "/usr/share/fonts/uni:unscaled"
                        	FontPath     "/usr/share/fonts/CID"
                        	FontPath     "/usr/share/fonts/ucs/misc:unscaled"
                        	FontPath     "/usr/share/fonts/ucs/75dpi:unscaled"
                        	FontPath     "/usr/share/fonts/ucs/100dpi:unscaled"
                        	FontPath     "/usr/share/fonts/hellas/misc:unscaled"
                        	FontPath     "/usr/share/fonts/hellas/75dpi:unscaled"
                        	FontPath     "/usr/share/fonts/hellas/100dpi:unscaled"
                        	FontPath     "/usr/share/fonts/hellas/Type1"
                        	FontPath     "/usr/share/fonts/misc/sgi:unscaled"
                        	FontPath     "/usr/share/fonts/xtest"
                        	FontPath     "/opt/kde3/share/fonts"
                        EndSection
                        
                        Section "Module"
                        	Load  "dbe"
                        	Load  "type1"
                        	Load  "freetype"
                        	Load  "extmod"
                        	Load  "glx"
                        #	Load  "dri"
                        EndSection
                        
                        Section "ServerFlags"
                        	Option	    "AllowMouseOpenFail" "on"
                        	Option	    "IgnoreABI" "on"
                        	Option	    "AIGLX" "true"
                        EndSection
                        
                        Section "InputDevice"
                        	Identifier  "Keyboard[0]"
                        	Driver      "kbd"
                        	Option	    "Protocol" "Standard"
                        	Option	    "XkbLayout" "de"
                        	Option	    "XkbModel" "microsoftpro"
                        	Option	    "XkbRules" "xfree86"
                        	Option	    "XkbVariant" "nodeadkeys"
                        EndSection
                        
                        Section "InputDevice"
                        	Identifier  "Mouse[1]"
                        	Driver      "mouse"
                        	Option	    "Buttons" "11"
                        	Option	    "Device" "/dev/input/mice"
                        	Option	    "Name" "Cherry USB Mouse"
                        	Option	    "Protocol" "explorerps/2"
                        	Option	    "Vendor" "Sysp"
                        	Option	    "ZAxisMapping" "4 5"
                        EndSection
                        
                        Section "Modes"
                        	Identifier     "Modes[0]"
                        	ModeLine     "1280x1024" 108.0 1280 1328 1440 1688 1024 1025 1028 1066 +hsync +vsync
                        EndSection
                        
                        Section "Monitor"
                        	Identifier   "aticonfig-Monitor[0]"
                        	Option	    "VendorName" "ATI Proprietary Driver"
                        	Option	    "ModelName" "Generic Autodetecting Monitor"
                        	Option	    "DPMS" "true"
                        EndSection
                        
                        Section "Device"
                        	Identifier  "aticonfig-Device[0]"
                        	Driver      "fglrx"
                        	Option	    "VideoOverlay" "on"
                        	Option	    "OpenGLOverlay" "off"
                        	Option       "XAANoOffscreenPixmaps" "true"
                        	Option       "DRI" "true"
                        EndSection
                        
                        Section "Screen"
                        	Identifier "aticonfig-Screen[0]"
                        	Device     "aticonfig-Device[0]"
                        	Monitor    "aticonfig-Monitor[0]"
                        	DefaultDepth     24
                        	SubSection "Display"
                        		Viewport   0 0
                        		Depth     24
                        	EndSubSection
                        EndSection
                        
                        Section "DRI"
                        
                        #	Group        "video"
                        #	Mode         0660
                        EndSection
                        
                        Section "Extensions"
                        	Option	    "DAMAGE" "true"
                        	Option	    "Composite" "true"
                        EndSection

                        fusion-icon
                        Code:
                         * Detected Session: kde
                         * Searching for installed applications...
                         * No GLX_EXT_texture_from_pixmap with direct rendering context
                         ... present with indirect rendering, exporting: LIBGL_ALWAYS_INDIRECT=1
                         * Setting option Indirect Rendering to True
                         * Using the GTK Interface
                         * KWin is already running
                         * Setting window manager to Compiz
                         ... executing: compiz --replace --sm-disable --ignore-desktop-hints ccp --indirect-rendering
                        compiz: Trying '/usr/$LIB/libIndirectGL.so.1'
                        compiz (core) - Fatal: No GLXFBConfig for default depth, this isn't going to work.
                        compiz (core) - Error: Failed to manage screen: 0
                        compiz (core) - Fatal: No manageable screens found on display :0.0
                        and after export LIBGL_ALWAYS_INDIRECT=1
                        Code:
                         * Detected Session: kde
                         * Searching for installed applications...
                         * Using the GTK Interface
                         * KWin is already running
                         * Setting window manager to Compiz
                         ... executing: compiz --replace --sm-disable --ignore-desktop-hints ccp --indirect-rendering
                        compiz: Trying '/usr/$LIB/libIndirectGL.so.1'
                        compiz (core) - Fatal: No GLXFBConfig for default depth, this isn't going to work.
                        compiz (core) - Error: Failed to manage screen: 0
                        compiz (core) - Fatal: No manageable screens found on display :0.0
                         * Setting option Indirect Rendering to False
                         ... executing: compiz --replace --sm-disable --ignore-desktop-hints ccp
                        compiz: Trying '/usr/$LIB/libIndirectGL.so.1'
                        compiz (core) - Fatal: No GLXFBConfig for default depth, this isn't going to work.
                        compiz (core) - Error: Failed to manage screen: 0
                        compiz (core) - Fatal: No manageable screens found on display :0.0
                        i have no idea how to make it word... someone else?

                        Comment


                        • #13
                          Got it!

                          I had the same problem mentioned here but after hours of trying I got it working. I followed these instructions:

                          http://dev.compiz-fusion.org/~cybero...-the-hard-way/

                          The only thing I needed to change is:

                          Instead of:
                          mv /usr/lib/libIndirectGL.so.1 /usr/lib/libIndirectGL.so.1.old

                          I needed to do:
                          mv /usr/lib64/libIndirectGL.so.1 /usr/lib64/libIndirectGL.so.1.old

                          Then compiz-manager and worked fine!

                          I hope it helps

                          David.

                          Comment


                          • #14
                            great, that made it work!!

                            thanks a lot!

                            Comment


                            • #15
                              Hi, i'm using Fedora 7, with latest updates and kernel, + 8.42 fglrx from livna, I can't use compiz with AIGLX, XGL works though. Problem when running compiz or beryl is they start, but then display messes up and everything gets out of order, colors change, pixels positions change, etc. Ican't even find out where the menu item fro disabling is.

                              I have the following warning when running beryl: beryl: No GLXFBConfig for default depth, falling back on visinfo.

                              Anyone can help? I should use AIGLX, XGL puts sth out which is needed for me

                              Comment

                              Working...
                              X