Announcement

Collapse
No announcement yet.

8.42 driver No GLXFBConfig for default depth

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    Originally posted by klaus View Post
    Hi, i'm using Fedora 7, with latest updates and kernel, + 8.42 fglrx from livna, I can't use compiz with AIGLX, XGL works though. Problem when running compiz or beryl is they start, but then display messes up and everything gets out of order, colors change, pixels positions change, etc. Ican't even find out where the menu item fro disabling is.
    You maybe want to create a new thread since I think it will be difficult for other find your post inside this thread.

    Anyways I experienced something similar on openSUSE but I run this:

    aticonfig –ovt Xv

    And that fixed the display. The display didn't refreshed but the previous line fixed it.

    I hope that helps.

    David.

    Comment


    • #17
      Originally posted by klaus View Post
      Hi, i'm using Fedora 7, with latest updates and kernel, + 8.42 fglrx from livna, I can't use compiz with AIGLX, XGL works though. Problem when running compiz or beryl is they start, but then display messes up and everything gets out of order, colors change, pixels positions change, etc. Ican't even find out where the menu item fro disabling is.

      I have the following warning when running beryl: beryl: No GLXFBConfig for default depth, falling back on visinfo.

      Anyone can help? I should use AIGLX, XGL puts sth out which is needed for me
      I can start beryl from terminal in Fedora 7 (only way to start it so far) but then there are no borders on my windows. But if I open the beryl settings manager and toggle window decoration off and on again then it works. Only problems is that I need to have to leave the terminal window open for it to work, scrolling is really slow and I cant watch movies

      Comment


      • #18
        Originally posted by shaker View Post
        I can start beryl from terminal in Fedora 7 (only way to start it so far) but then there are no borders on my windows. But if I open the beryl settings manager and toggle window decoration off and on again then it works. Only problems is that I need to have to leave the terminal window open for it to work, scrolling is really slow and I cant watch movies
        You can start beryl from the beryl-manager (select windows manager), where you can also activate the windows borders (select windows decorator -> emerald).

        Comment


        • #19
          U have 3 ways of doin' it:

          1) use beryl-manager as mentioned above, it will take care of beryl initialization when logging in
          2) use "beryl --replace &" on a terminal, that ensures u won't lose beryl when closing terminal
          3) bad idea: create an executable in ~/.kde/Autostart/ whatever u name it, type these:

          #! /bin/sh
          beryl &


          I checked the aticonfig -ovt Xv, but still my display is messed up, when using beryl, this is driving me crazy, any suggestions is appreciated

          Comment


          • #20
            my results on opensuse 10.3 64 bit with 8.42:

            following cyberorg's tut helped. im on 64 bit opensuse, so i had to move the /usr/lib64/libIndirect lib to get stuff to work. also, DONT INSTALL THE RPM! it doesnt work. i couldnt get aiglx to work with it, and neither would fgl_glxgears.

            amdcccle still wont work for me. also, the aiglx sucks. the cube works great, but some stuff just lags horribly.

            also ccsm wont be redrawn properly with aiglx on. i.e. mouseovers on buttons dont change state and i cant scroll and such. sometimes it wont even load anything but the frame of the window.

            also scrolling in anything but gtk is slow.

            Comment


            • #21
              same problem..

              hi

              im runnin opensuse 10.3 x64 xorg 7.2 ati x1600 i tried the repository drivers..xorg wont start with no display found...no chance startin it...radeon driver the same...the only way gettin a direct rendering:yes for me is to compile the drivers from ati by myself and setting in xorg.conf "fglrx"...

              everything wokrs fine except compiz...
              when renaming libIndirect i get a white screen...

              maybe fyi:
              -----------------------------
              xorg.conf parts
              -----------------------------
              Section "Module"
              Load "dbe"
              Load "type1"
              Load "freetype"
              Load "extmod"
              Load "glx"
              Load "DRI"
              EndSection

              Section "ServerFlags"
              Option "AllowMouseOpenFail" "on"
              Option "IgnoreABI" "on"
              Option "AIGLX" "true"
              EndSection

              Section "Device"
              Identifier "aticonfig-Device[0]"
              Driver "fglrx"
              Option "no_accel" "no"
              Option "no_dri" "no"
              Option "mtrr" "off"
              Option "DesktopSetup" "Horizontal, Reverse"
              Option "ScreenOverlap" "0"
              Option "GammaCorrectionI" "0x06419064"
              Option "GammaCorrectionII" "0x06419064"
              Option "Capabilities" "0x00000000"
              Option "CapabilitiesEx" "0x00000000"
              Option "VideoOverlay" "on"
              Option "OpenGLOverlay" "off"
              Option "CenterMode" "off"
              Option "PseudoColorVisuals" "off"
              Option "Stereo" "off"
              Option "StereoSyncEnable" "1"
              Option "FSAAEnable" "no"
              Option "FSAAScale" "1"
              Option "FSAADisableGamma" "no"
              Option "FSAACustomizeMSPos" "no"
              Option "FSAAMSPosX0" "-20.000000"
              Option "FSAAMSPosY0" "0.000000"
              Option "FSAAMSPosX1" "-20.000000"
              Option "FSAAMSPosY1" "0.000000"
              Option "FSAAMSPosX2" "-20.000000"
              Option "FSAAMSPosY2" "0.000000"
              Option "FSAAMSPosX3" "-20.000000"
              Option "FSAAMSPosY3" "0.000000"
              Option "FSAAMSPosX4" "-20.000000"
              Option "FSAAMSPosY4" "0.000000"
              Option "FSAAMSPosX5" "-20.000000"
              Option "FSAAMSPosY5" "0.000000"
              Option "UseFastTLS" "0"
              Option "BlockSignalsOnLock" "on"
              Option "UseInternalAGPGART" "no"
              Option "ForceGenericCPU" "no"
              Option "DRI" "true"
              EndSection

              Section "DRI"
              Group "video"
              Mode 0666
              EndSection

              Section "Extensions"
              Option "Composite" "True"
              EndSection
              -----------------------------
              glxinfo parts
              -----------------------------
              name of display: :0.0
              display: :0 screen: 0
              direct rendering: Yes
              server glx vendor string: SGI
              server glx version string: 1.2
              server glx extensions:
              GLX_ARB_multisample, GLX_EXT_visual_info, GLX_EXT_visual_rating,
              GLX_EXT_import_context, GLX_EXT_texture_from_pixmap, GLX_OML_swap_method,
              GLX_SGI_make_current_read, GLX_SGIS_multisample, GLX_SGIX_hyperpipe,
              GLX_SGIX_swap_barrier, GLX_SGIX_fbconfig, GLX_MESA_copy_sub_buffer
              client glx vendor string: SGI
              client glx version string: 1.4
              client glx extensions:
              GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_EXT_import_context,
              GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_MESA_allocate_memory,......................... ...............
              ----------------------------
              fglrxinfo
              ----------------------------
              display: :0.0 screen: 0
              OpenGL vendor string: ATI Technologies Inc.
              OpenGL renderer string: Radeon X1600 Series
              OpenGL version string: 2.0.6958 Release
              ----------------------------
              glxgears 4591 Frames
              ----------------------------
              compiz: Trying '/usr/$LIB/libIndirectGL.so.1'
              compiz (core) - Fatal: No GLXFBConfig for default depth, this isn't going to work.
              compiz (core) - Error: Failed to manage screen: 0
              compiz (core) - Fatal: No manageable screens found on display :0.0
              as said renaming file(s) gives me a white screen...

              ---------------------------------------------
              now my system runs nice but no compiz..with an cheap intel card you get it better,,,
              but with those cards you cant play etqw or sthg....
              i just want that nice cube to work...if anyone got a solution or just a try i try it
              thx in advance
              Last edited by r0tt; 11-09-2007, 07:08 AM.

              Comment

              Working...
              X