Announcement

Collapse
No announcement yet.

8.42 driver No GLXFBConfig for default depth

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #11
    Originally posted by Beno View Post
    Hi, I finally managed to run compiz (-fusion) on opensuse 10.3 version 0.6.2 by following this howto:
    http://dev.compiz-fusion.org/~cybero...-the-hard-way/
    In my case (Mobility Radeon, X600, 1gb ram, 2.13 ghz i686), like the howto's author, I experience a not usable compiz with artefacts in google-earth, mplayer not usable and slow effects (yes, also firefox/konqueror-scrolling). I will disable aiglx and composite and wait for the next release... (as usual).
    I have OpenSuSE 10.3 x86_64.
    I had same problem with compiz:
    ...
    compiz (core) - Fatal: No GLXFBConfig for default
    ...
    and fgl_glxgears hasn't works.

    But this solution help me )
    First i delete rpm package for 10.3 AMD64.
    Then install driver without package generation - and now i have fgl_glxgears works properly. Looks like some errors in fglrx rpm package for OpenSuSE10.3

    Then i make: mv /usr/lib64/libIndirectGL.so.1 /usr/lib64/libIndirectGL.so.1.old
    and now compiz works for me. But it's slow, buggy and completely unusable especially for video and OpenGL application. And kicker stand without redraw.

    Maybe it because without libIndirectGL.so.1 only GLX_EXT_texture_from_pixmap used and no power of AIGLX?

    Now i have disabled Composite and AIGLX.. and wait for normal solution from OpenSuSE developers or AMD new driver..

    Comment


    • #12
      Same problem here.

      My system:

      openSUSE 10.3 (x86-64)
      Ati Radeon 9600
      flgrx is in whitelist in /usr/bin/compiz-manager

      glxinfo | grep -i direct
      Code:
      direct rendering: Yes
      cat /var/log/Xorg.0.log | grep GLX
      Code:
      (**) Option "AIGLX" "on"
      (**) AIGLX enabled
      (II) Loading extension GLX
      (WW) AIGLX: 3D driver claims to not support visual 0x23
      (WW) AIGLX: 3D driver claims to not support visual 0x24
      ...
      ...
      ...
      (WW) AIGLX: 3D driver claims to not support visual 0x6f
      (WW) AIGLX: 3D driver claims to not support visual 0x70
      (WW) AIGLX: 3D driver claims to not support visual 0x71
      (WW) AIGLX: 3D driver claims to not support visual 0x72
      (II) AIGLX: Loaded and initialized /usr/lib64/dri/fglrx_dri.so
      (II) GLX: Initialized DRI GL provider for screen 0



      Here my xorg.conf
      Code:
      # /.../
      # SaX generated X11 config file
      # Created on: 2007-10-23T22:10:51+0200.
      #
      # Version: 8.1
      # Contact: Marcus Schaefer <sax@suse.de>, 2005
      # Contact: SaX-User list <https://lists.berlios.de/mailman/listinfo/sax-users>
      #
      # Automatically generated by [ISaX] (8.1)
      # PLEASE DO NOT EDIT THIS FILE!
      #
      
      Section "ServerLayout"
      	Identifier     "Layout[all]"
      	Screen      0  "aticonfig-Screen[0]" 0 0
      	InputDevice    "Keyboard[0]" "CoreKeyboard"
      	InputDevice    "Mouse[1]" "CorePointer"
      	Option	    "Clone" "off"
      	Option	    "Xinerama" "off"
      	Option       "AIGLX" "on"
      EndSection
      
      Section "Files"
      	InputDevices   "/dev/gpmdata"
      	InputDevices   "/dev/input/mice"
      	FontPath     "/usr/share/fonts/misc:unscaled"
      	FontPath     "/usr/share/fonts/local"
      	FontPath     "/usr/share/fonts/75dpi:unscaled"
      	FontPath     "/usr/share/fonts/100dpi:unscaled"
      	FontPath     "/usr/share/fonts/Type1"
      	FontPath     "/usr/share/fonts/URW"
      	FontPath     "/usr/share/fonts/Speedo"
      	FontPath     "/usr/share/fonts/PEX"
      	FontPath     "/usr/share/fonts/cyrillic"
      	FontPath     "/usr/share/fonts/latin2/misc:unscaled"
      	FontPath     "/usr/share/fonts/latin2/75dpi:unscaled"
      	FontPath     "/usr/share/fonts/latin2/100dpi:unscaled"
      	FontPath     "/usr/share/fonts/latin2/Type1"
      	FontPath     "/usr/share/fonts/latin7/75dpi:unscaled"
      	FontPath     "/usr/share/fonts/baekmuk:unscaled"
      	FontPath     "/usr/share/fonts/japanese:unscaled"
      	FontPath     "/usr/share/fonts/kwintv"
      	FontPath     "/usr/share/fonts/truetype"
      	FontPath     "/usr/share/fonts/uni:unscaled"
      	FontPath     "/usr/share/fonts/CID"
      	FontPath     "/usr/share/fonts/ucs/misc:unscaled"
      	FontPath     "/usr/share/fonts/ucs/75dpi:unscaled"
      	FontPath     "/usr/share/fonts/ucs/100dpi:unscaled"
      	FontPath     "/usr/share/fonts/hellas/misc:unscaled"
      	FontPath     "/usr/share/fonts/hellas/75dpi:unscaled"
      	FontPath     "/usr/share/fonts/hellas/100dpi:unscaled"
      	FontPath     "/usr/share/fonts/hellas/Type1"
      	FontPath     "/usr/share/fonts/misc/sgi:unscaled"
      	FontPath     "/usr/share/fonts/xtest"
      	FontPath     "/opt/kde3/share/fonts"
      EndSection
      
      Section "Module"
      	Load  "dbe"
      	Load  "type1"
      	Load  "freetype"
      	Load  "extmod"
      	Load  "glx"
      #	Load  "dri"
      EndSection
      
      Section "ServerFlags"
      	Option	    "AllowMouseOpenFail" "on"
      	Option	    "IgnoreABI" "on"
      	Option	    "AIGLX" "true"
      EndSection
      
      Section "InputDevice"
      	Identifier  "Keyboard[0]"
      	Driver      "kbd"
      	Option	    "Protocol" "Standard"
      	Option	    "XkbLayout" "de"
      	Option	    "XkbModel" "microsoftpro"
      	Option	    "XkbRules" "xfree86"
      	Option	    "XkbVariant" "nodeadkeys"
      EndSection
      
      Section "InputDevice"
      	Identifier  "Mouse[1]"
      	Driver      "mouse"
      	Option	    "Buttons" "11"
      	Option	    "Device" "/dev/input/mice"
      	Option	    "Name" "Cherry USB Mouse"
      	Option	    "Protocol" "explorerps/2"
      	Option	    "Vendor" "Sysp"
      	Option	    "ZAxisMapping" "4 5"
      EndSection
      
      Section "Modes"
      	Identifier     "Modes[0]"
      	ModeLine     "1280x1024" 108.0 1280 1328 1440 1688 1024 1025 1028 1066 +hsync +vsync
      EndSection
      
      Section "Monitor"
      	Identifier   "aticonfig-Monitor[0]"
      	Option	    "VendorName" "ATI Proprietary Driver"
      	Option	    "ModelName" "Generic Autodetecting Monitor"
      	Option	    "DPMS" "true"
      EndSection
      
      Section "Device"
      	Identifier  "aticonfig-Device[0]"
      	Driver      "fglrx"
      	Option	    "VideoOverlay" "on"
      	Option	    "OpenGLOverlay" "off"
      	Option       "XAANoOffscreenPixmaps" "true"
      	Option       "DRI" "true"
      EndSection
      
      Section "Screen"
      	Identifier "aticonfig-Screen[0]"
      	Device     "aticonfig-Device[0]"
      	Monitor    "aticonfig-Monitor[0]"
      	DefaultDepth     24
      	SubSection "Display"
      		Viewport   0 0
      		Depth     24
      	EndSubSection
      EndSection
      
      Section "DRI"
      
      #	Group        "video"
      #	Mode         0660
      EndSection
      
      Section "Extensions"
      	Option	    "DAMAGE" "true"
      	Option	    "Composite" "true"
      EndSection

      fusion-icon
      Code:
       * Detected Session: kde
       * Searching for installed applications...
       * No GLX_EXT_texture_from_pixmap with direct rendering context
       ... present with indirect rendering, exporting: LIBGL_ALWAYS_INDIRECT=1
       * Setting option Indirect Rendering to True
       * Using the GTK Interface
       * KWin is already running
       * Setting window manager to Compiz
       ... executing: compiz --replace --sm-disable --ignore-desktop-hints ccp --indirect-rendering
      compiz: Trying '/usr/$LIB/libIndirectGL.so.1'
      compiz (core) - Fatal: No GLXFBConfig for default depth, this isn't going to work.
      compiz (core) - Error: Failed to manage screen: 0
      compiz (core) - Fatal: No manageable screens found on display :0.0
      and after export LIBGL_ALWAYS_INDIRECT=1
      Code:
       * Detected Session: kde
       * Searching for installed applications...
       * Using the GTK Interface
       * KWin is already running
       * Setting window manager to Compiz
       ... executing: compiz --replace --sm-disable --ignore-desktop-hints ccp --indirect-rendering
      compiz: Trying '/usr/$LIB/libIndirectGL.so.1'
      compiz (core) - Fatal: No GLXFBConfig for default depth, this isn't going to work.
      compiz (core) - Error: Failed to manage screen: 0
      compiz (core) - Fatal: No manageable screens found on display :0.0
       * Setting option Indirect Rendering to False
       ... executing: compiz --replace --sm-disable --ignore-desktop-hints ccp
      compiz: Trying '/usr/$LIB/libIndirectGL.so.1'
      compiz (core) - Fatal: No GLXFBConfig for default depth, this isn't going to work.
      compiz (core) - Error: Failed to manage screen: 0
      compiz (core) - Fatal: No manageable screens found on display :0.0
      i have no idea how to make it word... someone else?

      Comment


      • #13
        Got it!

        I had the same problem mentioned here but after hours of trying I got it working. I followed these instructions:

        http://dev.compiz-fusion.org/~cybero...-the-hard-way/

        The only thing I needed to change is:

        Instead of:
        mv /usr/lib/libIndirectGL.so.1 /usr/lib/libIndirectGL.so.1.old

        I needed to do:
        mv /usr/lib64/libIndirectGL.so.1 /usr/lib64/libIndirectGL.so.1.old

        Then compiz-manager and worked fine!

        I hope it helps

        David.

        Comment


        • #14
          great, that made it work!!

          thanks a lot!

          Comment


          • #15
            Hi, i'm using Fedora 7, with latest updates and kernel, + 8.42 fglrx from livna, I can't use compiz with AIGLX, XGL works though. Problem when running compiz or beryl is they start, but then display messes up and everything gets out of order, colors change, pixels positions change, etc. Ican't even find out where the menu item fro disabling is.

            I have the following warning when running beryl: beryl: No GLXFBConfig for default depth, falling back on visinfo.

            Anyone can help? I should use AIGLX, XGL puts sth out which is needed for me

            Comment


            • #16
              Originally posted by klaus View Post
              Hi, i'm using Fedora 7, with latest updates and kernel, + 8.42 fglrx from livna, I can't use compiz with AIGLX, XGL works though. Problem when running compiz or beryl is they start, but then display messes up and everything gets out of order, colors change, pixels positions change, etc. Ican't even find out where the menu item fro disabling is.
              You maybe want to create a new thread since I think it will be difficult for other find your post inside this thread.

              Anyways I experienced something similar on openSUSE but I run this:

              aticonfig –ovt Xv

              And that fixed the display. The display didn't refreshed but the previous line fixed it.

              I hope that helps.

              David.

              Comment


              • #17
                Originally posted by klaus View Post
                Hi, i'm using Fedora 7, with latest updates and kernel, + 8.42 fglrx from livna, I can't use compiz with AIGLX, XGL works though. Problem when running compiz or beryl is they start, but then display messes up and everything gets out of order, colors change, pixels positions change, etc. Ican't even find out where the menu item fro disabling is.

                I have the following warning when running beryl: beryl: No GLXFBConfig for default depth, falling back on visinfo.

                Anyone can help? I should use AIGLX, XGL puts sth out which is needed for me
                I can start beryl from terminal in Fedora 7 (only way to start it so far) but then there are no borders on my windows. But if I open the beryl settings manager and toggle window decoration off and on again then it works. Only problems is that I need to have to leave the terminal window open for it to work, scrolling is really slow and I cant watch movies

                Comment


                • #18
                  Originally posted by shaker View Post
                  I can start beryl from terminal in Fedora 7 (only way to start it so far) but then there are no borders on my windows. But if I open the beryl settings manager and toggle window decoration off and on again then it works. Only problems is that I need to have to leave the terminal window open for it to work, scrolling is really slow and I cant watch movies
                  You can start beryl from the beryl-manager (select windows manager), where you can also activate the windows borders (select windows decorator -> emerald).

                  Comment


                  • #19
                    U have 3 ways of doin' it:

                    1) use beryl-manager as mentioned above, it will take care of beryl initialization when logging in
                    2) use "beryl --replace &" on a terminal, that ensures u won't lose beryl when closing terminal
                    3) bad idea: create an executable in ~/.kde/Autostart/ whatever u name it, type these:

                    #! /bin/sh
                    beryl &


                    I checked the aticonfig -ovt Xv, but still my display is messed up, when using beryl, this is driving me crazy, any suggestions is appreciated

                    Comment


                    • #20
                      my results on opensuse 10.3 64 bit with 8.42:

                      following cyberorg's tut helped. im on 64 bit opensuse, so i had to move the /usr/lib64/libIndirect lib to get stuff to work. also, DONT INSTALL THE RPM! it doesnt work. i couldnt get aiglx to work with it, and neither would fgl_glxgears.

                      amdcccle still wont work for me. also, the aiglx sucks. the cube works great, but some stuff just lags horribly.

                      also ccsm wont be redrawn properly with aiglx on. i.e. mouseovers on buttons dont change state and i cant scroll and such. sometimes it wont even load anything but the frame of the window.

                      also scrolling in anything but gtk is slow.

                      Comment

                      Working...
                      X