Announcement

Collapse
No announcement yet.

AMD fglrx 8.42.3 - When will the baby mature ? - Experiences ..

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #51
    Originally posted by NobeyamaGP View Post
    AMD Athlon 64 3000+
    ATi Radeon 9600XT Pro
    Kubuntu 7.10

    I installed the driver and everything was working great the first day.

    Then, a few days later, I decided to up my monitor's refresh rate up to 75Hz. I started getting odd garbled signal down in the lower right corner of the screen. Two bands of crap about half an inch wide and about the same distance apart, but they showed only rarely and a quick logout and login fixed it. Then I noticed i was getting some odd noise on certain websites, the main page of this forum was one of the worst, that looked like small blinking green or yellow pixels.

    I decided that it might have something to do with Composite or AIGLX and since I don't have Compiz or Bryl installed anymore I turned these options off in my xorg.conf file. Saved, logged out, and restarted X, and every thing looked fine again. Then the next day it reappeared, so I decided to change the refresh rate back to 60Hz and see if that helped. I tried changing it back in CCC. The program acted like the refresh rate had changed, but the screen never blanked and the issues were still there, also I could restart CCC later and it still reported refresh at 75Hz. Tried Kubuntu's monitor settings, same deal as CCC. I looked up the Horiz. and Vert. rates off of the manufacturer's website and added them manually to xorg.conf. Restarted X and CCC said 60Hz again.

    So basically, when I turn on the computer in the morning the monitor is set to 75Hz and I can't change it to anything else, however, a quick space added to xorg.conf, saved, removed again, and saved again, after restarting X again, monitor is automatically back at 60Hz and no noise on sites like this forum for the rest of the day. Very peculiar.

    Otherwise, much better experience than previous versions of fglrx.
    A little update. I have discovered that simply logging out, restarting X, and logging back in of a morning fixes the refresh issue. No xorg.conf editing required.

    Comment


    • #52
      mouse not affected

      Just registered to reply; those bands are visible on my screen as well. It affects that lower right corner of my screen, though the mouse pointer actually moves over those bands. I'm using an ATI All-in-Wonder 9800 Pro on Gutsy.

      Comment


      • #53
        Not perfect for sure but otherwise a good set of drivers. Much faster in opengl but in game gamma setting does NOT work. Had to disable vertex shaders in Wow also. Fair trade for the nice speed boost. Nice to have the improved ccc as well.

        AMD x2 @ 2.9 x850pro 1gig Ocz ubuntu 7.10 is my sys specs.

        Comment


        • #54
          Originally posted by Jethro View Post
          Not perfect for sure but otherwise a good set of drivers. Much faster in opengl but in game gamma setting does NOT work. Had to disable vertex shaders in Wow also. Fair trade for the nice speed boost. Nice to have the improved ccc as well.

          AMD x2 @ 2.9 x850pro 1gig Ocz ubuntu 7.10 is my sys specs.
          Can you tell me how you disable Vertex Shaders in the Config.wtf file? And also, did it fix the login screen and sprite texture rendering issue?

          Comment


          • #55
            Originally posted by astor84 View Post
            Can you tell me how you disable Vertex Shaders in the Config.wtf file? And also, did it fix the login screen and sprite texture rendering issue?

            SET M2UseShaders "0"

            Comment


            • #56
              those creepy bands

              Originally posted by geopgeop View Post
              Just registered to reply; those bands are visible on my screen as well. It affects that lower right corner of my screen, though the mouse pointer actually moves over those bands. I'm using an ATI All-in-Wonder 9800 Pro on Gutsy.
              get those bands too. But listen to this. I start CCC and click cancel and wolla the bands are gone.

              Comment


              • #57
                Regarding the LR corner (and mouse) corruption i had that too. As i was told by another user on this forum: make sure you have these lines in your /etc/X11/xorg.conf:
                Code:
                Option "HWCursor" "On"
                Option "XAANoOffscreenPixmaps" "true"
                Option "RenderAccel" "true"
                Option "AllowGLXWithComposite" "true"
                Option "OpenGLOverlay" "off"
                Option "VideoOverlay" "on"
                Option "CapabilitiesEx" "0x00000000"
                Option "no_accel" "no"
                Option "mtrr" "off"
                Option "KernelModuleParm" "locked-userpages=0"
                Option "BlockSignalsOnLock" "on"
                Option "UseFastTLS" "0"
                I had most of them and adding the few i was missing completely solved.

                Comment

                Working...
                X