Announcement

Collapse
No announcement yet.

(23.07.) AMD Catalyst™ OpenGL 4.3 Beta Driver

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • (23.07.) AMD Catalyst™ OpenGL 4.3 Beta Driver

    (23.07.) AMD Catalyst™ OpenGL 4.3 Beta Driver

    Highlights of the AMD Catalyst™ OpenGL 4.3 Beta Driver:

    Full support for OpenGL 4.3
    Resolved Issues:

    Enduro Technology on AMD + AMD Ubuntu platforms - Source Engine games hang when running on the High Performance ASIC
    Maya 2011-2013 – Various visual corruptions issues have been resolved
    Maya 2011-2013 – Mesh/Polygons selection performance has been improved
    Unigine Heaven – Intermittent Crashes have been resolved
    Unigine Heaven – Performance has been improved up to 11% on single GPU configurations
    Left 4 Dead 2 – Visual corruption issues have been resolved

    http://support.amd.com/us/kbarticles...etaDriver.aspx

    Also, I am hearing a new regular driver (Catalyst 13.7) is scheduled for July, the 31th.

  • #2
    How to install on kernel 3.10.2 (64-bit)?

    I cannot install it on kernel 3.10.2 on Debian 64-bit with or without the 3.10 kernel patch (which works with fglrx 13.6 and kernel 3.10.2 just fine).
    The same bad exit status error when building the kernel module in both cases.

    So, is there a patch anywhere (or any install method) for this 13.15 and kernel 3.10?

    PS. My specific issue concerns kernel 3.10 and above, 3.9 and lower should not be affected by this.

    I got the patch from here:

    https://github.com/kolasa/fglrx-13.101

    Comment


    • #3
      Originally posted by gradinaruvasile View Post
      I cannot install it on kernel 3.10.2 on Debian 64-bit with or without the 3.10 kernel patch (which works with fglrx 13.6 and kernel 3.10.2 just fine).
      The same bad exit status error when building the kernel module in both cases.

      So, is there a patch anywhere (or any install method) for this 13.15 and kernel 3.10?

      PS. My specific issue concerns kernel 3.10 and above, 3.9 and lower should not be affected by this.

      I got the patch from here:

      https://github.com/kolasa/fglrx-13.101
      Far as i know it only supports kernel 3.8 its a waiting game when using Bleeding edge Software and proprietary Drivers

      Comment


      • #4
        Originally posted by gradinaruvasile View Post
        I cannot install it on kernel 3.10.2 on Debian 64-bit with or without the 3.10 kernel patch (which works with fglrx 13.6 and kernel 3.10.2 just fine).
        The same bad exit status error when building the kernel module in both cases.

        So, is there a patch anywhere (or any install method) for this 13.15 and kernel 3.10?

        PS. My specific issue concerns kernel 3.10 and above, 3.9 and lower should not be affected by this.

        I got the patch from here:

        https://github.com/kolasa/fglrx-13.101
        I had no problems to apply the patch manually. I mean, by visual meld. Code is pretty simple to merge. But lines are not same so automated patch without looking won't work.

        Comment


        • #5
          It didn't fixed the Source based games lag...

          It's just a little less on CS:Source, but in Left4Dead2... it's unplayable...
          And in source i have to manually limit the FPS to 85 for example to almost loose the lag...

          I'm using Lenovo G570 laptop with Radeon 6370M 1 GB GPU and intel HD2000 ( AMD Muxless)

          So still not usable...

          For christ, are the Nvidia developers just better at writing code than the AMD ones ?

          Comment


          • #6
            Did they finally fix the problem with serious sam3 ?

            The flickering of semi transparent textures?

            Comment


            • #7
              Originally posted by Gps4l View Post
              Did they finally fix the problem with serious sam3 ?

              The flickering of semi transparent textures?
              Yes, it's perfect now!

              Comment


              • #8
                Is the laptop backlight issue fixed? I'm still on 13.1, it's been broken in all betas and stable since then...

                Comment


                • #9
                  OpenGL 4.3 or 4.2?

                  Can someone from AMD or elsewhere tell me why glxinfo reports:
                  Code:
                  OpenGL vendor string: Advanced Micro Devices, Inc.
                  OpenGL renderer string: ATI Radeon HD 5800 Series 
                  OpenGL core profile version string: 4.3.12414 Core Profile Context 13.15.100.1
                  OpenGL core profile shading language version string: 4.30
                  OpenGL core profile context flags: (none)
                  OpenGL core profile profile mask: core profile
                  While Catalyst Control Center reports:
                  Code:
                  4.2.12414 Compatibility Profile Context 13.15.100.1
                  2D is not better here still laggy on KDE 4.11 RC with Raster 2D at Kwin, with Native is even worse...
                  R600s performance is way better even with my 3.7 updated stock opensuse 12.3 kernel but with Mesa 9.2 git.

                  Comment


                  • #10
                    Originally posted by [Knuckles] View Post
                    Is the laptop backlight issue fixed? I'm still on 13.1, it's been broken in all betas and stable since then...
                    To answer my own question, just tried it, still broken. Never again amd, never again )

                    Comment


                    • #11
                      Awesome driver

                      Hello.

                      I've got a huge performance boost with this driver. Check the reports here: http://steamcommunity.com/app/221410...3980896723122/

                      Comment


                      • #12
                        Originally posted by Rholk View Post
                        I had no problems to apply the patch manually. I mean, by visual meld. Code is pretty simple to merge. But lines are not same so automated patch without looking won't work.
                        Can you post the changed files pls?

                        Comment


                        • #13
                          l4d2 performance is identical here (not even 1fps difference with timedemo benches).
                          linux 3.4.54 with radeon 7870

                          I did notice everything seems darker and the brightness adjustment does _NOT_ work in l4d2.
                          Last edited by Soul_keeper; 07-24-2013, 01:09 AM.

                          Comment


                          • #14
                            Originally posted by Soul_keeper View Post
                            l4d2 performance is identical here (not even 1fps difference with timedemo benches).
                            linux 3.4.54 with radeon 7870

                            I did notice everything seems darker and the brightness adjustment does _NOT_ work in l4d2.
                            For my laptop, i need to disable vary-bright feature for my debian to take control on brightness.

                            djdoo => Yes i have same problem too... my control center even report different info. I think it is the /etc/ati/amdpcsdb file who get not updateded... Trust only glxinfo.


                            For graphic performance, on synthetic test it is much better. But much games are still totally unplayable with my mobility 5650 (I start to think it is my cg which is complete crap...)

                            Comment


                            • #15
                              Works great with my 6950. I get improved framerate in most games.

                              Haven't tested if anything is broken in the mediasenter yet. Will do so later.

                              Kind regards
                              Brut.

                              Comment

                              Working...
                              X