No announcement yet.

compiz-fusion (on Ubuntu/Gutsy) and 8.42

  • Filter
  • Time
  • Show
Clear All
new posts

  • compiz-fusion (on Ubuntu/Gutsy) and 8.42

    Hi all,

    Got the new driver compiled and all, but there's unusable display corruption when using desktop effects.
    Maybe it's using the wrong path?

    I'm just not sure...

  • #2
    Do you have fglrx in your driver whitelist in /usr/bin/compiz ?
    Michael Larabel


    • #3
      Have you whitelisted fglrx in /usr/bin/compiz on Line ~50?


      • #4
        Yes, I have.
        WHITELIST="nvidia intel ati radeon i810 fglrx"


        • #5
          Is 3D working properly for you? Does "fglrxinfo" show that fglrx is used over mesa?


          • #6
            Did you do a clean install of Gutsy or a dist-upgrade? In your xorg.conf do you have Composite and AIGLX enabled?
            Michael Larabel


            • #7
              3D is working properly:

              display: :0.0 screen: 0
              OpenGL vendor string: ATI Technologies Inc.
              OpenGL renderer string: ATI Mobility Radeon X1400
              OpenGL version string: 2.0.6958 Release

              It's a clean install of Gutsy. The old modules (8.41) were removed and the new ones were installed with module-assistant.

              I don't have composite and aiglx *disabled* - that is to say, the ServerFlags and Extensions sections are empty. compiz seems to start up just fine:

              cameron@vienna:~$ compiz
              Checking for Xgl: not present.
              Detected PCI ID for VGA: 01:00.0 0300: 1002:7145 (prog-if 00 [VGA])
              Checking for texture_from_pixmap: not present.
              Trying again with indirect rendering:
              Checking for texture_from_pixmap: present.
              Checking for non power of two support: present.
              Checking for Composite extension: present.
              Comparing resolution (1440x900) to maximum 3D texture size (4096): Passed.
              Checking for nVidia: not present.
              Checking for FBConfig: present.
              Checking for Xgl: not present.
              Starting emerald
              /usr/bin/compiz.real (video) - Warn: No 8 bit GLX pixmap format, disabling YV12 image format


              • #8
                Just to know, is anyone else experiencing this or am I alone?


                • #9
                  Many people are experencing problems with compiz generally...we still have to understand if this is related to the new AIGLX implementation, to Compiz itself or to an unfortunate marriage


                  • #10
                    wow, i'm actually a bit envious. b/c you at least have the driver installed correctly

                    i always get MESA with the 8.42 driver even on a fresh squeaky clean install of gutsy. oddly enough the 8.40 driver worked fine using the exact same guide. anyway. if you have any ideas on THAT problem, i would love to know. sorry for changing topic.

                    anyway, i know compiz part of the system now, but when i used it with XGL i manually installed it and got some extra options. might help you. here:s the code:

                    sudo apt-get install compizconfig-settings-manager compiz compiz-core compiz-fusion-plugins-main compiz-fusion-plugins-extra compiz-gnome compiz-plugins libcompizconfig-backend-gconf libcompizconfig0
                    Last edited by b4sakenxx; 10-26-2007, 01:36 AM.


                    • #11
                      i also have a mobility x1400.
                      after a few tries i got it working.

                      on a fresh install of gutsy, after i installed and configured the ati driver. i checked my xorg.conf and found composite = 0 and no AIGLX section. when i added the AIGLX section it screwed the driver up.

                      try setting composite to 1 and removing the AIGLX section. and you said you have the whitelisting done, so that should be it.

                      this worked for me. hope it helps.


                      • #12
                        I removed the AIGLX section and get the same issue as before. You're saying that you had this exact issue with a clean install, took out the AIGLX section and now things are working?


                        • #13
                          I'm missing the title bars on windows in Kubuntu
                          Anyone with ideas on how to fix this?


                          • #14
                            Originally posted by sastraxi View Post
                            I removed the AIGLX section and get the same issue as before. You're saying that you had this exact issue with a clean install, took out the AIGLX section and now things are working?
                            Yep. It's really weird actually. Its actually random though I think. On previous installs, I had to manually set Composite to 1 and remove the AIGLX section b/c it caused graphic corruption and on boot would make me reconfigure my display.

                            Last night however, I was curious if the drivers finally released on the ATI site were any different. So I restored my xorg.conf from a backup, downloaded and installed the drivers from the site and neither the AIGLX section nor the composite section are in my xorg.conf and compiz is working fine. Minus the firefox stuff and flickering video.

                            You might try removing the driver all together. restoring your xorg.conf. And then reinstalling. I backtracked so many times -_-


                            • #15
                              Hmm. I think I might just do a clean install in a couple days; try out the KDE4 release candidate and such in the process. Thanks for your insights.