Announcement

Collapse
No announcement yet.

AMD 8.42.3 Driver Released -- The Baby Is Born!

Collapse
This topic is closed.
X
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #41
    Installation worked flawless for me on Ubuntu Gutsy. Whitelisted fglrx in /usr/bin/compiz on line 54 (someone asked how to do it previously).

    Performance is not really good. Worse than the opensource ati driver (like kirý said). Did I miss enabling some options in xorg.conf?

    Greetings...

    Comment


    • #42
      Originally posted by lucien View Post
      Installation worked flawless for me on Ubuntu Gutsy. Whitelisted fglrx in /usr/bin/compiz on line 54 (someone asked how to do it previously).

      Performance is not really good. Worse than the opensource ati driver (like kirý said). Did I miss enabling some options in xorg.conf?

      Greetings...
      What hardware are you using? What's your xorg.conf look like?
      Michael Larabel
      http://www.michaellarabel.com/

      Comment


      • #43
        * Installing fglrx module
        * ati tree 'lib' -> 'lib32' on system
        install: cannot stat `/var/tmp/paludis/x11-drivers/ati-drivers-8.42.3/work/arch/x86_64/usr/X11R6/lib/libGL.so.1.2': No such file or directory
        install: cannot stat `/var/tmp/paludis/x11-drivers/ati-drivers-8.42.3/work/arch/x86_64/usr/X11R6/lib/modules/dri/fglrx_dri.so': No such file or directory
        * ati tree 'lib64' -> 'lib64' on system
        install: cannot stat `common/etc/ati/fglrxprofiles.csv': No such file or directory
        install: cannot stat `common/etc/ati/fglrxrc': No such file or directory
        arghhhhhhhhhhhhhhhhhh!!!!!!!!!!!!!!!!!!!

        now no apps are starting because of the libgl.s0.1.2 not being there... how could i fix this?! if i cannot fix it i cannot use the driver...
        for me the driver can be called 8.42.3 the baby is born... dead!!!!!!!!!

        Comment


        • #44
          Originally posted by SteviOS View Post
          I need some help with Compiz.
          I installed the new driver with
          Code:
          sudo ./ati-driver-installer-8.42.3-x86.x86_64.run
          Then added (compiz)
          Code:
          # Driver whitelist
          WHITELIST="fglrx nvidia intel ati radeon i810"
          and (xorg.conf)
          Code:
          Section "Module"
          	Load		"glx"
          EndSection
          
          Section "Extensions"
          	Option "Composite" "1"
          EndSection
          
          Section "ServerFlags"
          	Option "AIGLX" "on"
          EndSection
          I'm running Gutsy with ATI Mobility Radeon X1400. When I try to enable Compiz there's a white-screen.
          Code:
           fglrxinfo
          display: :0.0  screen: 0
          OpenGL vendor string: Mesa project: www.mesa3d.org
          OpenGL renderer string: Mesa GLX Indirect
          OpenGL version string: 1.4 (2.1 Mesa 7.0.1)
          You've got Mesa there instead of ATI. You should be getting something similar to this:

          Code:
          display: 0:0 screen: 0
          OpenGL vendor string: ATI Technolgies Inc.
          OpenGL rendered string: ATI Mobility Radeon X1400
          OpenGL version string: 2.0.6958 release
          Try installing it manually via method 2 found here:
          (uninstall all previous instances of fglrx first, but don't reboot till you finish the manual install)

          http://wiki.cchtml.com/index.php/Ubu...allation_Guide

          Comment


          • #45
            What kills me is that compiz-fusion is running at a usable speed -- just completely graphically corrupted.

            Oh yeah, and et:qw crashed the X server after about 20 seconds into the game.

            Wish I was more impressed, but...

            Comment


            • #46
              Originally posted by Michael View Post
              That's a known issue on the part of the package maintainer for Ubuntu Gutsy Gibbon. A new packaging script for Ubuntu is available and I'll see if I still have it in my inbox.
              I get the same error in Ubuntu Feisty... (so, clearly this is a general Ubuntu problem).

              Comment


              • #47
                Originally posted by aoanla View Post
                I get the same error in Ubuntu Feisty... (so, clearly this is a general Ubuntu problem).
                Oops, yeah, didn't mean to say "Gutsy Gibbon" in my previous post.
                Michael Larabel
                http://www.michaellarabel.com/

                Comment


                • #48
                  Any clue which options I should activate in my "Xorg.conf" config file in order to enable Compiz via AIGLX? When running
                  compiz.real --indirect-rendering --replace I'm getting a message telling me that the composite extension is not enabled on my system.

                  Also, when I installed it (on Gutsy), it seems the package did not create a necessary symbolic link (ie. in /usr/lib libGL.so.1 was not found, but libGL.so.1.2 was, so I created a symbolic pointing from libGL.so.1 to libGL.so.1.2 and it did the trick).

                  Comment


                  • #49
                    Originally posted by givemesugarr View Post
                    arghhhhhhhhhhhhhhhhhh!!!!!!!!!!!!!!!!!!!

                    now no apps are starting because of the libgl.s0.1.2 not being there... how could i fix this?! if i cannot fix it i cannot use the driver...
                    for me the driver can be called 8.42.3 the baby is born... dead!!!!!!!!!
                    https://www.inullable.com/svn/overla...s/ati-drivers/

                    Comment


                    • #50
                      EDIT: If you have the Composite extension disabled in your xorg.conf in /etc/X11/xorg.conf, make sure you re-enable it.
                      ok, thanks for the composite extension tip, i didn't read the post first.

                      Comment

                      Working...
                      X