Announcement

Collapse
No announcement yet.

AMD 8.42.3 Driver Released -- The Baby Is Born!

Collapse
This topic is closed.
X
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #31
    Originally posted by Michael View Post
    (This codename came from all of the discussion in this Phoronix Forums thread: http://www.phoronix.com/forums/showthread.php?t=5422)
    "The Baby is Born". Wow, it seems some of us just became godfathers (I hope it's the correct term in english) of a GFX-Card driver

    Comment


    • #32
      Is there a patch for 2.6.23??? Please post a link as far as possible.

      Comment


      • #33
        Originally posted by daniel of sarnia View Post
        damn it, I just installed it on Ubuntu 7.04 and Quake4 now freezes after playing for about 30 seconds... FUCK

        Please some one tell me that if I upgrade to gutsy the it wont crash.

        Oh can some one help me out and tell me where the file to weight list the driver for compiz is, please
        Well make sure everything is proper by running glxinfo and glxgears. (and make sure you don't have Mesa running by accident).

        As for gutsy, I haven't tested it, though I will in the next couple days.
        EDIT: If you have the Composite extension disabled in your xorg.conf in /etc/X11/xorg.conf, make sure you re-enable it.

        EDIT2: Compiz is now successfully running without a hitch. AIGLX is here to stay, and it's stable on my setup. The only thing I need to fix is my conky window which is now out of alignment for some odd reason. Nothing a little config file tweaking can't fix.
        Last edited by Uchikoma; 10-23-2007, 02:26 PM.

        Comment


        • #34
          Originally posted by Uchikoma View Post
          Well make sure everything is proper by running glxinfo and glxgears. (and make sure you don't have Mesa running by accident).

          As for gutsy, I haven't tested it, though I will in the next couple days.
          EDIT: If you have the Composite extension disabled in your xorg.conf in /etc/X11/xorg.conf, make sure you re-enable it.

          8.42.3 Tested on Slackware 12 + Compiz Fusion + Radeon 9600.

          1) AIGLX is a TOTAL DELUSION. The fps is less than XGL. Firefox scrolling seems like a 286 dir command (on dos).
          Radeon open source driver is better!

          2) Xmame in opengl mode is worst than with radeon open source driver.

          Why did we wait for so much time?
          Why did we believe to ATI?
          Why -I- bought an ATI card?
          Last edited by kirý; 10-23-2007, 02:33 PM.

          Comment


          • #35
            "The Baby is Born". Wow, it seems some of us just became godfathers (I hope it's the correct term in english) of a GFX-Card driver
            The baby is MINE! lol

            Comment


            • #36
              Well, package building fails on x86_64 Ubuntu Gutsy.

              Generating package: Ubuntu/gutsy
              Package build failed!
              Package build utility output:
              ...
              find: usr/X11R6/lib: No such file or directory
              ...
              cp: cannot stat `./usr/X11R6/lib/modules/dri': No such file or directory
              dh_install: command returned error code 256
              make: *** [binary] Error 1

              Seems to be missing the usr/X11R6/lib directory; there's only a usr/X11R6/lib64 directory. Anyone get this thing to build on an x86_64 system under Gutsy?

              Comment


              • #37
                I need some help with Compiz.
                I installed the new driver with
                Code:
                sudo ./ati-driver-installer-8.42.3-x86.x86_64.run
                Then added (compiz)
                Code:
                # Driver whitelist
                WHITELIST="fglrx nvidia intel ati radeon i810"
                and (xorg.conf)
                Code:
                Section "Module"
                	Load		"glx"
                EndSection
                
                Section "Extensions"
                	Option "Composite" "1"
                EndSection
                
                Section "ServerFlags"
                	Option "AIGLX" "on"
                EndSection
                I'm running Gutsy with ATI Mobility Radeon X1400. When I try to enable Compiz there's a white-screen.
                Code:
                 fglrxinfo
                display: :0.0  screen: 0
                OpenGL vendor string: Mesa project: www.mesa3d.org
                OpenGL renderer string: Mesa GLX Indirect
                OpenGL version string: 1.4 (2.1 Mesa 7.0.1)

                Comment


                • #38
                  I take it you're using Ubuntu? use --buildpkg Ubuntu/7.10 and not running the driver from its GUI installer.

                  Make sure to block fglrx in the restricted drivers too.
                  Michael Larabel
                  http://www.michaellarabel.com/

                  Comment


                  • #39
                    Originally posted by psychos View Post
                    Well, package building fails on x86_64 Ubuntu Gutsy.

                    Generating package: Ubuntu/gutsy
                    Package build failed!
                    Package build utility output:
                    ...
                    find: usr/X11R6/lib: No such file or directory
                    ...
                    cp: cannot stat `./usr/X11R6/lib/modules/dri': No such file or directory
                    dh_install: command returned error code 256
                    make: *** [binary] Error 1

                    Seems to be missing the usr/X11R6/lib directory; there's only a usr/X11R6/lib64 directory. Anyone get this thing to build on an x86_64 system under Gutsy?
                    That's a known issue on the part of the package maintainer for Ubuntu Gutsy Gibbon. A new packaging script for Ubuntu is available and I'll see if I still have it in my inbox.
                    Michael Larabel
                    http://www.michaellarabel.com/

                    Comment


                    • #40
                      Originally posted by cantas View Post
                      The buildpkg feature does not work in gutsy.


                      cp: cannot stat `./usr/X11R6/lib/modules/dri': No such file or directory
                      dh_install: command returned error code 256
                      make: *** [binary] Error 1
                      Buildpkg worked fine on my 32bit system. I haven't tested the driver yet because I am at school.
                      I used ssh to do buildpkg and install.

                      Comment

                      Working...
                      X