Announcement

Collapse
No announcement yet.

AMD 8.42.3 Driver Released -- The Baby Is Born!

Collapse
This topic is closed.
X
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Hi does anyone know if there is a workaround for the black screen bug in Gutsy yet. I built the drivers ok on a amd64 but on restart the x server crashes to a black screen ! Now this is reported in the bug tracker for Gutsy, has anyone managed to fix it ? any help would be very useful.

    Cheers

    Comment


    • Thansk for the help.
      I just needed to add fglrx to the white list of drivers

      But as many reported my compiz effects are slow, much slower than with the radaeon driver

      I have not had time to test the 3D rendering yet.

      Comment


      • Originally posted by makoto42 View Post
        What distro/kernel and ATI device are you using? I too concur that the SLUB problem is gone for my Mobility FireGL v5200, but I cannot get Xorg to run on resume no matter what I try. Text mode is fine, but kinda defeats the point....
        I'm using gentoo with suspend2 patched kernel. Maybe you are missing a certain config line in xorg.conf. I will post it soon.

        Comment


        • Originally posted by drystan1 View Post
          Hi does anyone know if there is a workaround for the black screen bug in Gutsy yet. I built the drivers ok on a amd64 but on restart the x server crashes to a black screen ! Now this is reported in the bug tracker for Gutsy, has anyone managed to fix it ? any help would be very useful.

          Cheers
          Hi. I have the same problem on debian testing/lenny. I have a mobility 9700. The same thing appears with fglrx 8.40. I resolve installing fglrx 8.38

          Sorry for my bad english...

          Comment


          • Originally posted by hluk View Post
            For me screen corruptions disappeared after putting the lines below into xorg.conf's device section (where my current fglrx 8.42.3 driver was).

            Code:
            Option	    "KernelModuleParm" "locked-userpages=0"
            This seems to work for me.
            I didn't have those screen corruptions since 7 or 8h running time.
            Although to be sure it is solved, of course I have to see if it comes back the next days.

            Just make sure, that the kernel module is unloaded before the x server starts again after you put that option in xorg.conf, or better: restart.

            Comment


            • Am I the only one who has the problem with X beeing killed with compiz start? - The same with 0.3.6, 0.5.2, 0.5.5 on Kubuntu 7.04 Feisty Fawn with Xorg 7.2. X server is killed just after emerald start and I don't have X logs because X server restarts with KDM login screen and logs are overwritten.

              Comment


              • let's try the driver to see whether it works or not
                i have waited AIGLX support for a long time

                Comment


                • Originally posted by xeros View Post
                  Am I the only one who has the problem with X beeing killed with compiz start? - The same with 0.3.6, 0.5.2, 0.5.5 on Kubuntu 7.04 Feisty Fawn with Xorg 7.2. X server is killed just after emerald start and I don't have X logs because X server restarts with KDM login screen and logs are overwritten.
                  Have you try Beryl?
                  With beryl I have no problem (compiz won't work for me)...
                  Last edited by kimba; 10-26-2007, 06:21 AM.

                  Comment


                  • Originally posted by Berniyh View Post
                    This seems to work for me.
                    I didn't have those screen corruptions since 7 or 8h running time.
                    Although to be sure it is solved, of course I have to see if it comes back the next days.

                    Just make sure, that the kernel module is unloaded before the x server starts again after you put that option in xorg.conf, or better: restart.
                    I knew it.

                    Now the screen corruption came back, so that isn't the solution either, but it might help a little bit.

                    Comment


                    • For some reason, Compiz (the one in Feisty) performed miserably. Beryl is ok for me, too, though I only use it when I want to zoom in on Flash videos. But the new driver seems to perform well, and I haven't noticed any major bugs yet. Installation was a bit difficult in Feisty, as I'm not used to Ubuntu, having preferred Fedora since FC2.
                      Of course, the Firefox scrolling business seems to be an issue across the board. It's so unresponsive that I'll simply not use either Compiz or Beryl. The same goes for window resizing with wobble and pop-up window previews. That is, Beryl and the like seem to perform too badly with an x800xl, amd64 3000+ and 2 gb of RAM.
                      But in any case, this version of the driver seems to me to be a really good one. I haven't read all of this thread, but it looks like a lot of people have had trouble with installing it, and I suppose many have blamed ATI/AMD when it didn't work properly or at all.

                      Comment

                      Working...
                      X