Announcement

Collapse
No announcement yet.

AMD 8.42.3 Driver Released -- The Baby Is Born!

Collapse
This topic is closed.
X
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #46
    Originally posted by Michael View Post
    That's a known issue on the part of the package maintainer for Ubuntu Gutsy Gibbon. A new packaging script for Ubuntu is available and I'll see if I still have it in my inbox.
    I get the same error in Ubuntu Feisty... (so, clearly this is a general Ubuntu problem).

    Comment


    • #47
      Originally posted by aoanla View Post
      I get the same error in Ubuntu Feisty... (so, clearly this is a general Ubuntu problem).
      Oops, yeah, didn't mean to say "Gutsy Gibbon" in my previous post.
      Michael Larabel
      http://www.michaellarabel.com/

      Comment


      • #48
        Any clue which options I should activate in my "Xorg.conf" config file in order to enable Compiz via AIGLX? When running
        compiz.real --indirect-rendering --replace I'm getting a message telling me that the composite extension is not enabled on my system.

        Also, when I installed it (on Gutsy), it seems the package did not create a necessary symbolic link (ie. in /usr/lib libGL.so.1 was not found, but libGL.so.1.2 was, so I created a symbolic pointing from libGL.so.1 to libGL.so.1.2 and it did the trick).

        Comment


        • #49
          Originally posted by givemesugarr View Post
          arghhhhhhhhhhhhhhhhhh!!!!!!!!!!!!!!!!!!!

          now no apps are starting because of the libgl.s0.1.2 not being there... how could i fix this?! if i cannot fix it i cannot use the driver...
          for me the driver can be called 8.42.3 the baby is born... dead!!!!!!!!!
          https://www.inullable.com/svn/overla...s/ati-drivers/

          Comment


          • #50
            EDIT: If you have the Composite extension disabled in your xorg.conf in /etc/X11/xorg.conf, make sure you re-enable it.
            ok, thanks for the composite extension tip, i didn't read the post first.

            Comment


            • #51
              Originally posted by zmaster View Post
              Any clue which options I should activate in my "Xorg.conf" config file in order to enable Compiz via AIGLX? When running
              compiz.real --indirect-rendering --replace I'm getting a message telling me that the composite extension is not enabled on my system.

              Also, when I installed it (on Gutsy), it seems the package did not create a necessary symbolic link (ie. in /usr/lib libGL.so.1 was not found, but libGL.so.1.2 was, so I created a symbolic pointing from libGL.so.1 to libGL.so.1.2 and it did the trick).
              sudo gedit /etc/X11/xorg.conf
              in the section "Extensions" set Composite to yes, or remove the entire section entirely.

              Restart X. (ctrl+alt+backspace)

              EDIT: Haha, you beat me to it -_-
              Hope it works for you ^^;

              Comment


              • #52
                Originally posted by Michael View Post
                What hardware are you using? What's your xorg.conf look like?
                I have a X800 XT. The only thing I did in my xorg.conf was switching from ati to fglrx.

                Code:
                # xorg.conf (xorg X Window System server configuration file)
                #
                # This file was generated by dexconf, the Debian X Configuration tool, using
                # values from the debconf database.
                #
                # Edit this file with caution, and see the xorg.conf manual page.
                # (Type "man xorg.conf" at the shell prompt.)
                #
                # This file is automatically updated on xserver-xorg package upgrades *only*
                # if it has not been modified since the last upgrade of the xserver-xorg
                # package.
                #
                # If you have edited this file but would like it to be automatically updated
                # again, run the following command:
                #   sudo dpkg-reconfigure -phigh xserver-xorg
                
                Section "Files"
                EndSection
                
                Section "InputDevice"
                	Identifier	"Generic Keyboard"
                	Driver		"kbd"
                	Option		"CoreKeyboard"
                	Option		"XkbRules"	"xorg"
                	Option		"XkbModel"	"pc105"
                	Option		"XkbLayout"	"de"
                	Option		"XkbOptions"	"lv3:ralt_switch"
                EndSection
                
                Section "InputDevice"
                	Identifier	"Configured Mouse"
                	Driver		"mouse"
                	Option		"CorePointer"
                	Option		"Device"		"/dev/input/mice"
                	Option		"Protocol"		"ImPS/2"
                	Option		"ZAxisMapping"		"4 5"
                	Option		"Emulate3Buttons"	"true"
                EndSection
                
                Section "InputDevice"
                	Driver		"wacom"
                	Identifier	"stylus"
                	Option		"Device"	"/dev/input/wacom"
                	Option		"Type"		"stylus"
                	Option		"ForceDevice"	"ISDV4"		# Tablet PC ONLY
                EndSection
                
                Section "InputDevice"
                	Driver		"wacom"
                	Identifier	"eraser"
                	Option		"Device"	"/dev/input/wacom"
                	Option		"Type"		"eraser"
                	Option		"ForceDevice"	"ISDV4"		# Tablet PC ONLY
                EndSection
                
                Section "InputDevice"
                	Driver		"wacom"
                	Identifier	"cursor"
                	Option		"Device"	"/dev/input/wacom"
                	Option		"Type"		"cursor"
                	Option		"ForceDevice"	"ISDV4"		# Tablet PC ONLY
                EndSection
                
                Section "Device"
                	Identifier	"ATI Technologies Inc R423 5F57 [Radeon X800XT (PCIE)]"
                	Driver		"fglrx"
                	BusID		"PCI:3:0:0"
                EndSection
                
                Section "Monitor"
                	Identifier	"SyncMaster"
                	Option		"DPMS"
                EndSection
                
                Section "Screen"
                	Identifier	"Default Screen"
                	Device		"ATI Technologies Inc R423 5F57 [Radeon X800XT (PCIE)]"
                	Monitor		"SyncMaster"
                	DefaultDepth	24
                	SubSection "Display"
                		Modes		"1400x1050" "1280x1024" "1280x960" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
                	EndSubSection
                EndSection
                
                Section "ServerLayout"
                	Identifier	"Default Layout"
                	Screen		"Default Screen"
                	InputDevice	"Generic Keyboard"
                	InputDevice	"Configured Mouse"
                
                # Uncomment if you have a wacom tablet
                #	InputDevice     "stylus"	"SendCoreEvents"
                #	InputDevice     "cursor"	"SendCoreEvents"
                #	InputDevice     "eraser"	"SendCoreEvents"
                EndSection

                Comment


                • #53
                  Originally posted by givemesugarr View Post
                  arghhhhhhhhhhhhhhhhhh!!!!!!!!!!!!!!!!!!!

                  now no apps are starting because of the libgl.s0.1.2 not being there... how could i fix this?! if i cannot fix it i cannot use the driver...
                  for me the driver can be called 8.42.3 the baby is born... dead!!!!!!!!!
                  https://www.inullable.com/svn/overla...s/ati-drivers/

                  Comment


                  • #54
                    I can't run compiz
                    mikko@gentoo ~ $ compiz --replace
                    compiz (core) - Fatal: GLX_EXT_texture_from_pixmap is missing
                    compiz (core) - Error: Failed to manage screen: 0
                    compiz (core) - Fatal: No manageable screens found on display :0
                    I enabled "composite" and AIGLX in xorg.conf.

                    DRI is enabled too:
                    mikko@gentoo ~ $ fglrxinfo
                    display: :0.0 screen: 0
                    OpenGL vendor string: ATI Technologies Inc.
                    OpenGL renderer string: ATI Mobility Radeon X1400
                    OpenGL version string: 2.0.6958 Release
                    I tried following this howto (I run Gentoo amd64): http://gentoo-wiki.com/HOWTO_XGL/Tro...map_is_missing

                    LD_LIBRARY_PATH=/usr/lib compiz --replace gconf &

                    LD_PRELOAD=/usr/lib/opengl/xorg-x11/lib/libGL.so compiz --replace gconf
                    both give me the same output...

                    What am I missing?

                    Comment


                    • #55
                      Hi,
                      the new driver is great, but I don't seem to have X-Video support. Is there any way to enable it?

                      Code:
                      $ xvinfo 
                      X-Video Extension version 2.2
                      screen #0
                       no adaptors present
                      Code:
                      $ fglrxinfo 
                      display: :0.0  screen: 0
                      OpenGL vendor string: ATI Technologies Inc.
                      OpenGL renderer string: ATI MOBILITY RADEON X700
                      OpenGL version string: 1.4 (2.0.6958 Release)
                      Distribution is Ubuntu 7.10.

                      Comment


                      • #56
                        Originally posted by slacker View Post
                        I can't run compiz


                        I enabled "composite" and AIGLX in xorg.conf.

                        DRI is enabled too:


                        I tried following this howto (I run Gentoo amd64): http://gentoo-wiki.com/HOWTO_XGL/Tro...map_is_missing



                        both give me the same output...

                        What am I missing?
                        You didn't follow all of the guide it seems. Did you look for where the mesa files are? Once you do:

                        LD_LIBRARY_PATH=[path to mesa goes here] compiz --replace gconf &

                        Or so it seems. Try that out.

                        Hi,
                        the new driver is great, but I don't seem to have X-Video support. Is there any way to enable it?

                        Code:

                        $ xvinfo
                        X-Video Extension version 2.2
                        screen #0
                        no adaptors present

                        Code:

                        $ fglrxinfo
                        display: :0.0 screen: 0
                        OpenGL vendor string: ATI Technologies Inc.
                        OpenGL renderer string: ATI MOBILITY RADEON X700
                        OpenGL version string: 1.4 (2.0.6958 Release)

                        Distribution is Ubuntu 7.10.
                        Code:
                        sudo aticonfig --overlay-type=Xv
                        Then restart X and see if that works.

                        Comment


                        • #57
                          You need to enable Option "TexturedVideo" "True" for X-Video
                          Michael Larabel
                          http://www.michaellarabel.com/

                          Comment


                          • #58
                            I get the same error as SteviOS(fglrxinfo reports Mesa)
                            I used the GUI installation for the driver.

                            So I tried what Michael mentioned(using the package builder), and here is what I get: ( I'm on Mandriva2008)

                            Code:
                            [ahmad@localhost Desktop]$ ./ati-driver-installer-8.42.3-x86.x86_64.run --buildpkg Mandriva/2008
                            Created directory fglrx-install.Yy8033
                            Verifying archive integrity... All good.
                            Uncompressing ATI Proprietary Linux Driver-8.42.3....................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................
                            ==================================================
                             ATI Technologies Linux Driver Installer/Packager 
                            ==================================================
                            Generating package: Mandriva/2008
                            Package build failed!
                            Package build utility output:
                            error: file /home/ahmad/tmp/ati.oo8119/SOURCES/ati-driver-installer-8.42.3-x86.x86_64.run missing: No such file or directory
                            Removing temporary directory: fglrx-install.Yy8033
                            [ahmad@localhost Desktop]$
                            Last edited by Extreme Coder; 10-23-2007, 02:59 PM.

                            Comment


                            • #59
                              Okay so after a lot of use, I can report essentially no problems...except one.

                              - glxgears tends to flicker a bit. Whether this applies to games I don't know as I don't have et:qw on hand to try (and I'm at work).

                              Anyone else have that problem?
                              ...and glxgears runs at 2250 FPS roughly on an ati x1400. 800ish FPS on powersaving mode.

                              Comment


                              • #60
                                Originally posted by Uchikoma View Post
                                LD_LIBRARY_PATH=[path to mesa goes here] compiz --replace gconf &

                                Or so it seems. Try that out.

                                mikko@gentoo ~ $ locate libGL.so
                                /usr/lib64/opengl/xorg-x11/lib/libGL.so.1
                                /usr/lib64/opengl/xorg-x11/lib/libGL.so.1.2
                                /usr/lib64/opengl/xorg-x11/lib/libGL.so
                                /usr/lib64/opengl/ati/lib/libGL.so.1.2
                                /usr/lib64/opengl/ati/lib/FGL.renamed.libGL.so.1.2
                                /usr/lib64/opengl/ati/lib/libGL.so.1
                                /usr/lib64/opengl/ati/lib/libGL.so
                                /usr/lib64/xorg/FGL.renamed.libGL.so.1.2
                                /usr/lib64/xorg/libGL.so.1.2
                                /usr/lib64/xorg/libGL.so
                                /usr/lib64/xorg/libGL.so.1
                                /usr/lib64/libGL.so
                                /usr/lib64/libGL.so.1
                                /usr/lib32/xorg/libGL.so.1.2
                                /usr/lib32/xorg/libGL.so
                                /usr/lib32/xorg/libGL.so.1
                                /usr/lib32/opengl/xorg-x11/lib/libGL.so.1.2
                                /usr/lib32/opengl/xorg-x11/lib/libGL.so
                                /usr/lib32/opengl/xorg-x11/lib/libGL.so.1
                                /usr/lib32/opengl/xorg-x11/lib/libGL.so.1.2.bak
                                /usr/lib32/opengl/ati/lib/FGL.renamed.libGL.so.1.2
                                /usr/lib32/libGL.so.1
                                which one is the right one?

                                Comment

                                Working...
                                X