Announcement

Collapse
No announcement yet.

AMD 8.42.3 Driver Released -- The Baby Is Born!

Collapse
This topic is closed.
X
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Just been experimenting with this driver on a V5250 (pci id hacked).

    Not good
    - 2nd screen will only run at 1024 x 768 instead of 1600x1200
    - blank screen after suspend

    8.35 appears to work better.

    Big disappointment. Best not get my hopes up too much for 8.43

    If anyone does get a good mobile config up and running (even without Xgl/AIGLX) I'd be interested, but I've now gone back to 8.35. Not perfect but best so far... (on laptop)

    Comment


    • No suspend on kUbuntu 7.10 with new driver

      Overall a very good release,
      OpenGL apps are way more faster.

      Compiz working BUT no video when Compiz is enabled.
      Compiz doesn't feel very fast, although the fps benchmark shows different.

      Also with kernel 2.6.22 suspend and Hibernating doesn't work, I had to revert to kernel 2.6.20 (SUSPEND working !!!).
      It has something to do with SLUB and/or SLAB ??? don't have a clue.

      SO now I'm using kUbuntu 7.10 with 2.6.20 kernel and 8.42.3 fglrx driver.

      Off topic: with kubuntu 7.10 for the first time my broadcom wifi chipset works without ndiswrapper, but it also has some problems with suspend, so I guess I will revert this back to ndiswrapper too

      SYSTEM: Fujitsu-Siemens Amilo 3667G, Mobile X700, AMD Turion

      Comment


      • Well, I installed 8.42.3. I don't really care about the desktop effects as much as I care about having smooth video playback, which I was hoping that this driver would improve, removing tearing, etc. Before installing this driver, OpenGL was providing smooth video playback. Now OpenGL video playback is worse than using X11 Video, which is still worse than OpenGL. Anyone have any suggestions on how to get the OpenGL playback to what it was before? glxgears does report a 5-fold increase in performance from 8.37 at the very least, which is what I was using before.

        fglrxinfo
        display: :0.0 screen: 0
        OpenGL vendor string: ATI Technologies Inc.
        OpenGL renderer string: Radeon X1600 Series
        OpenGL version string: 2.0.6958 Release

        glxinfo
        name of display: :0.0
        display: :0 screen: 0
        direct rendering: Yes
        server glx vendor string: SGI
        server glx version string: 1.2
        server glx extensions:
        GLX_ARB_multisample, GLX_EXT_import_context, GLX_EXT_texture_from_pixmap,
        GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_OML_swap_method,
        GLX_SGIS_multisample, GLX_SGIX_fbconfig, GLX_SGIX_visual_select_group
        client glx vendor string: SGI
        client glx version string: 1.4
        client glx extensions:
        GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_EXT_import_context,
        GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_MESA_allocate_memory,
        GLX_MESA_copy_sub_buffer, GLX_MESA_swap_control,
        GLX_MESA_swap_frame_usage, GLX_OML_swap_method, GLX_OML_sync_control,
        GLX_SGI_make_current_read, GLX_SGI_swap_control, GLX_SGI_video_sync,
        GLX_SGIS_multisample, GLX_SGIX_fbconfig, GLX_SGIX_pbuffer,
        GLX_SGIX_visual_select_group, GLX_EXT_texture_from_pixmap
        GLX version: 1.2
        GLX extensions:
        GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_EXT_import_context,
        GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_OML_swap_method,
        GLX_SGIS_multisample, GLX_SGIX_fbconfig, GLX_SGIX_visual_select_group
        OpenGL vendor string: ATI Technologies Inc.
        OpenGL renderer string: Radeon X1600 Series
        OpenGL version string: 2.0.6958 Release
        OpenGL extensions:
        GL_ARB_depth_texture, GL_ARB_draw_buffers, GL_ARB_fragment_program,
        GL_ARB_fragment_shader, GL_ARB_multisample, GL_ARB_multitexture,
        GL_ARB_occlusion_query, GL_ARB_point_parameters, GL_ARB_point_sprite,
        GL_ARB_shader_objects, GL_ARB_shading_language_100, GL_ARB_shadow,
        GL_ARB_shadow_ambient, GL_ARB_texture_border_clamp,
        GL_ARB_texture_compression, GL_ARB_texture_cube_map,
        GL_ARB_texture_env_add, GL_ARB_texture_env_combine,
        GL_ARB_texture_env_crossbar, GL_ARB_texture_env_dot3,
        GL_ARB_texture_float, GL_ARB_texture_mirrored_repeat,
        GL_ARB_texture_rectangle, GL_ARB_transpose_matrix,
        GL_ARB_vertex_buffer_object, GL_ARB_vertex_program, GL_ARB_vertex_shader,
        GL_ARB_window_pos, GL_ATI_draw_buffers, GL_ATI_envmap_bumpmap,
        GL_ATI_fragment_shader, GL_ATI_meminfo, GL_ATI_separate_stencil,
        GL_ATI_texture_compression_3dc, GL_ATI_texture_env_combine3,
        GL_ATI_texture_float, GL_EXT_bgra, GL_EXT_blend_color,
        GL_EXT_blend_func_separate, GL_EXT_blend_minmax, GL_EXT_blend_subtract,
        GL_EXT_compiled_vertex_array, GL_EXT_copy_texture,
        GL_EXT_draw_range_elements, GL_EXT_fog_coord, GL_EXT_framebuffer_object,
        GL_EXT_framebuffer_object, GL_EXT_gpu_program_parameters,
        GL_EXT_multi_draw_arrays, GL_EXT_packed_depth_stencil,
        GL_EXT_packed_pixels, GL_EXT_point_parameters, GL_EXT_rescale_normal,
        GL_EXT_secondary_color, GL_EXT_separate_specular_color,
        GL_EXT_shadow_funcs, GL_EXT_stencil_wrap, GL_EXT_subtexture,
        GL_EXT_texgen_reflection, GL_EXT_texture3D,
        GL_EXT_texture_compression_s3tc, GL_EXT_texture_cube_map,
        GL_EXT_texture_edge_clamp, GL_EXT_texture_env_add,
        GL_EXT_texture_env_combine, GL_EXT_texture_env_dot3,
        GL_EXT_texture_filter_anisotropic, GL_EXT_texture_lod_bias,
        GL_EXT_texture_mirror_clamp, GL_EXT_texture_object,
        GL_EXT_texture_rectangle, GL_EXT_texture_sRGB, GL_EXT_vertex_array,
        GL_KTX_buffer_region, GL_NV_blend_square, GL_NV_texgen_reflection,
        GL_SGIS_generate_mipmap, GL_SGIS_texture_edge_clamp, GL_SGIS_texture_lod,
        GL_WIN_swap_hint, WGL_EXT_swap_control
        Then the table after this.

        Here are the relevent parts of xorg.conf

        Section "Module"
        Load "fglx"
        Load "glx"
        EndSection

        Section "DRI"
        Mode 0666
        EndSection

        Section "Extensions"
        Option "Composite" "Disable"
        EndSection
        Section "ServerFlags"
        #Option "AIGLX" "on"
        #Option "AIGLX" "off"
        Option "TexturedVideo" "True"
        EndSection

        Comment


        • On my 1900XT in dual screen, when i try to switch the cube, i return on logon screen.

          Comment


          • I reached step 6 on this page http://ubuntuforums.org/showthread.php?t=575843 after I tried
            sudo m-a build,install fglrx-kernel
            I recieved the following error
            using gusty and 8.42 along with the fglrx-8.42-ubuntu+debian-2.tar.bz2 patch on my 9600xt
            <CODE>dh_testroot
            rm -f configure-stamp
            rm -f fglrx.ko fglrx.mod.c *.o libfglrx_ip.a
            rm -f .version .*.o.flags .*.o.d .*.o.cmd .*.ko.cmd
            rm -rf .tmp_versions
            rm -rf patch
            dh_clean
            rm /usr/src/modules/fglrx/debian/control
            rm /usr/src/modules/fglrx/debian/dirs
            if [ -f /usr/src/modules/fglrx/debian/control.template ]; then \
            cat /usr/src/modules/fglrx/debian/control.template > /usr/src/modules/fglrx/debian/control; \
            fi
            if [ -f /usr/src/modules/fglrx/debian/postinst ]; then \
            mv /usr/src/modules/fglrx/debian/postinst /usr/src/modules/fglrx/debian/fglrx-kernel-2.6.22-14-rt.postinst; \
            fi
            dh_testdir
            touch configure-stamp
            dh_testdir
            /usr/bin/make -C /usr/src/linux SUBDIRS=/usr/src/modules/fglrx modules
            make[1]: Entering directory `/usr/src/linux-headers-2.6.22-14-rt'
            CC [M] /usr/src/modules/fglrx/firegl_public.o
            /usr/src/modules/fglrx/firegl_public.c:365: warning: initialization from incompatible pointer type
            /usr/src/modules/fglrx/firegl_public.c:366: warning: initialization from incompatible pointer type
            /usr/src/modules/fglrx/firegl_public.c: In function ‘fglrx_pci_suspend’:
            /usr/src/modules/fglrx/firegl_public.c:799: warning: passing argument 1 of ‘firegl_pci_save_state’ from incompatible pointer type
            /usr/src/modules/fglrx/firegl_public.c: In function ‘fglrx_pci_resume’:
            /usr/src/modules/fglrx/firegl_public.c:841: warning: passing argument 1 of ‘firegl_pci_restore_state’ from incompatible pointer type
            /usr/src/modules/fglrx/firegl_public.c: In function ‘__ke_pci_find_device’:
            /usr/src/modules/fglrx/firegl_public.c:2019: warning: ‘pci_find_device’ is deprecated (declared at include/linux/pci.h:477)
            /usr/src/modules/fglrx/firegl_public.c: In function ‘__ke_request_irq’:
            /usr/src/modules/fglrx/firegl_public.c:2962: warning: ‘deprecated_irq_flag’ is deprecated (declared at include/linux/interrupt.h:68)
            /usr/src/modules/fglrx/firegl_public.c:2962: warning: passing argument 2 of ‘request_irq’ from incompatible pointer type
            /usr/src/modules/fglrx/firegl_public.c: At top level:
            /usr/src/modules/fglrx/firegl_public.c:5439: warning: ‘kmem_cache_t’ is deprecated
            LD [M] /usr/src/modules/fglrx/fglrx.o
            Building modules, stage 2.
            MODPOST 1 modules
            WARNING: could not find /usr/src/modules/fglrx/.libfglrx_ip.a.GCC4.cmd for /usr/src/modules/fglrx/libfglrx_ip.a.GCC4
            FATAL: modpost: GPL-incompatible module fglrx.ko uses GPL-only symbol '__rcu_read_lock'
            make[2]: *** [__modpost] Error 1
            make[1]: *** [modules] Error 2
            make[1]: Leaving directory `/usr/src/linux-headers-2.6.22-14-rt'
            make: *** [build] Error 2</CODE>
            Last edited by mrplow; 10-24-2007, 08:21 PM.

            Comment


            • Originally posted by JCTWeb
              Any ideas why I keep losing this symlink?

              /lib/modules/2.6.22-14-generic/volatile/fglrx.ko

              Everytime I reboot, it's gone and I have to re-create the link. It's driving me insane.
              Originally posted by Septor View Post
              Hint: volatile

              That stuff is generated by the linux-kernel-restricted package... remove that package if you aren't using any restricted drivers. The symlink in the wiki is totally unnecessary if you run "depmod -ae" and add fglrx to /etc/defaults/linux-kernel-restricted-modules (as per the wiki).
              Just to be clear...
              "depmod -ae"
              Will prevent me from having to create the symlink at all? I guess the wiki just makes it overkill ?

              Comment


              • Originally posted by spotman View Post
                This is strange, I have the exact opposite behavior. I find that with desktop effects on, scrolling is terrible, while if desktop effects are off, scrolling is very snappy.

                I wonder what the differences in your configuration are.
                In my xorg.conf i only have the entry Driver 'fglrx' in the device section. Composite and AIGLX options sections i had removed completely. It's activated by default i think.

                Originally posted by Phlogiston View Post
                No I'm not sure. Which effects do you exactly mean? The effects plugin of compiz-fusion or what?
                desktop effects i mean the options in "visual effects" settings. (none, normal, extra and custom)

                As I said, compiz fusion running fine under gutsy with the new aiglx feature without xgl. The worst thing is that video and games flicker too much.

                Comment


                • Got the new driver installed on my gutsy 64bit yesterday and all the fancy effects working and so on. But all the effects lag a lot (besides the cube), and also when watching Mplayer video and sound is not in sync. Also Firefox lags a lot. Anything i can do? or is it just to wait for new updates and drivers.

                  PS. specs are amd64 4200+, ATI X1800XT, 1 GB DDR2 (so there should be enough juice)

                  Comment


                  • I have a HP nx6325 laptop with AMD Turion x2 1.6 GHZ ,1GB of RAM ,and a ATI Radeon Mobility Xpress 1150 video card .I would like to know if compiz fusion will work with the new 8.42 driver,and if it will run good on my system

                    Comment


                    • I'm running Ubuntu 7.10 64-bit with a Sapphire X1650XT card, 256 MB RAM on card. OpenGL screensavers with 8.42.3 have artifacts along the bottom half of the screen. Wolfenstein Enemy Territory (not Quake Wars) still runs but like 8.41, the brightness control does not change the brightness at all. Still tearing with AVI or most other videos. The only improvements I've noticed is that AIGLX works, and HD videos play much better, neither of which have any compelling use to me.

                      I'm going back to 8.40.4, it simply works better for my needs.
                      Last edited by redboar; 10-24-2007, 07:45 PM.

                      Comment

                      Working...
                      X