Announcement

Collapse
No announcement yet.

AMD 8.42.3 Driver Released -- The Baby Is Born!

Collapse
This topic is closed.
X
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • @Crunchy

    Seems to be Xserver 1.4 related, right?

    Comment


    • Originally posted by lgoral View Post
      Ok guys, I'm still having problems running compiz, even after trying all the solutions provided here.

      I'm running Debian sid with Xpress 200M, xorg 7.3, compiz 0.5.2. I'm getting the same GLX_EXT_texture_from_pixmap problem many people here seem to have:

      Code:
      compiz --replace
      GLX_EXT_texture_from_pixmap is not available with direct rendering.
      GLX_EXT_texture_from_pixmap is not available with indirect rendering. Aborting!
      The proposed solutions using LD_PRELOAD and LIBGL_ALWAYS_INDIRECT don't do a thing. Looking at /usr/bin/compiz, I see that it's a wrapper script for compiz.real. It first greps glxinfo for GLX_EXT_texture_from_bitmap and checks if it return at least three lines - no idea why! Checking glxinfo manually shows me that GLX_EXT_texture_from_pixmap occurs only twice. Anyway, if the above fails, the script exports LIBGL_ALWAYS_INDIRECT=true and tries again. If neither check succeeds, it exits with the above errors.

      Now the fun part. I tried manually exporting LIBGL_ALWAYS_INDIRECT=true and running compiz.real directly. This gives me a seg fault. Moreover, after LIBGL_ALWAYS_INDIRECT=true glxinfo produces the following instead of the expect result:

      Code:
      export LIBGL_ALWAYS_INDIRECT=true
      glxinfo
      name of display: :0.0
      X Error of failed request:  GLXBadContext
        Major opcode of failed request:  162 (GLX)
        Minor opcode of failed request:  5 (X_GLXMakeCurrent)
        Serial number of failed request:  16
        Current serial number in output stream:  16
      Any ideas?
      mine was working fine until i upgraded to xserver 1.4, since then my results are like yours.

      i will downgrade to xserver 1.3 and see what happen.

      by the way i'm usin gentoo.

      Comment


      • Finally

        Light at the end of the tunnel!

        Comment


        • Originally posted by InfiniteZero View Post
          I have ATI Mobility Radeon X1300. I am using Debian sid. I have installed fglrx driver 8.42.3. Compiz version is 0.5.2 and Xorg is 7.3....
          Do you have 64bit kernel? Cause it seems that it's only problem x86_64 fglrx

          Comment


          • Well, I loaded up 8.42 on my 9700 Pro and while the performance was greatly improved my long-term complaint is still not addressed. There are artifacts when FSAA is enabled in OpenGL applications. 8.42 has different patterns, the artifact blocks are much bigger (hinting to why the performance is increased, internally the driver uses larger tile slices) and they are in different places. However, they are still there. I now also get watermark in the corner. (though it doesn't show up with Ksnapshot). If this is possibly some kind of settings issue, I'd like to know what might cause it (or how to clear out all settings from previous drivers, as the driver no longer uses the options in /etc/X11/xorg.conf exclusively). Anyway... this is a picture of my issue: http://img136.imageshack.us/my.php?i...apshot2kt5.png

            It is an OpenInventor file being viewed in ivview. I can provide the .iv for testing, OpenInventor is an open source scientific visualization tool and part of nearly every major distribution. Source is here: ftp://oss.sgi.com/projects/inventor/download

            On Debian or Ubuntu:
            apt-get install inventor-clients

            Michael, if you could mention this to your ATI developer friends I'd love to get to the bottom of why the ATI driver has always had artifacts with this program. Possibly this would also point to much more minor artifacting when FSAA is enabled in many games. I'm using Debian Etch (stock except for fglrx, so 2.6.18-5-686, X.org 7.1.0-19)

            Comment


            • Originally posted by SteviOS View Post
              Still mesa instead of ati
              Code:
              fglrxinfo
              display: :0.0  screen: 0
              OpenGL vendor string: Mesa project: www.mesa3d.org
              OpenGL renderer string: Mesa GLX Indirect
              OpenGL version string: 1.4 (2.1 Mesa 7.0.1)
              Any ideas?
              Finally I got it working on my Toshiba Satellite Pro A100 (ATI Mobility Radeon X1400). In a few words:
              • I did a clean install of Gutsy
              • Installed the driver manually via method 2 (--buildpkg Ubuntu/7.10 / !blocked fglrx in restricted drivers!)
              • Added the fglrx to compiz whitelist
              Thx ATI. I realized some bugs but I think it's a great driver compared to those I had to use before 8.41.X.

              Comment


              • i'm wondering is this new driver works with 2.6.22.9

                Comment


                • Originally posted by gummybearx View Post
                  yea, im curious of how they got their setups working so flawlessly, to say the least.

                  maybe its the years of configging x servers for their living that makes them so good at it...^^

                  but seriously, a writeup for howtos for different distros would be fantabulastic.
                  They never said that compiz runs with decent scrollings, and without flickering while playing videos.

                  Comment


                  • Serious issues with 8.42.3

                    Hi,

                    My OS is Ubuntu Gutsy 7.10 and hardware is Lenovo Thinkpad T60 (wide screen) with dual head configuration. Graphics adapter is Mobility Radeon X1400.

                    I'm succesfully running compiz-fusion and truecombat (as well as other gl software) with the new drivers.

                    However there are a few irritating things:

                    1. Poor compiz performance when Mozilla software (thunderbird / firefox) has focus. If such software is visible but without focus, rotating the cube or expo works flawlessly. I'm not sure whether this is a compiz issue, but this doesn't happen on nvidia hardware and nvidia proprietary driver.

                    2. Crashes! I'm not sure if dualhead conifguration makes the crashes more frequent. During the five hours I've been testing the new drivers now there has been about a dozen of crashes (X dies unexpectedly) and gdm restarts it). One of the best ways to make it crash is to make e.g. rhythmbox window so wide it reaches from one display to another. Either rhythmbox window goes blank (=black) or the whole X goes down.

                    Comment


                    • For etch you can alway use my script to correctly install the driver:

                      http://kanotix.com/files/install-fglrx-debian.sh

                      As there are 2 watermarks possible you don't have got /etc/ati/control or /etc/ati/signature. If the first is missing you get unsupported hardware, if the second is missing you get ATI testing watermark. Hotfix would be:

                      sh ati-driver-installer-8.42.3-x86.x86_64.run --extract ati
                      cp ati/common/etc/ati/{control,signature} /etc/ati/

                      Then restart X server.

                      Comment


                      • Hi everyone,

                        Many experiences yet as I can see. I am really sad to have discovered this great news only this morning when I can not test it on my Ubuntu 7.10.
                        Hopefully tonight I'll post my experience

                        Jeff

                        Comment


                        • Oops I forgot:

                          I have not found a good how-to for Ubuntu for this driver. Do anyone have a link or a quick step-by-step ?


                          Thanks and regards, Jeff.

                          Comment


                          • Originally posted by jeffjoker View Post
                            Oops I forgot:

                            I have not found a good how-to for Ubuntu for this driver. Do anyone have a link or a quick step-by-step ?


                            Thanks and regards, Jeff.

                            How about this one , it s on Ubuntu forums

                            http://ubuntuforums.org/showthread.php?t=589075

                            Comment


                            • Disable restricted modules and start my script, it works with Debian and Ubuntu:

                              http://kanotix.com/files/install-fglrx-debian.sh

                              Then just change the whitelist to support fglrx.

                              Comment


                              • I'm as happy as a little child at a fair. My X1950Pro has stopped collecting dust in my drawer and is now instead collecting dust within my pc ( which is a better place to collect dust imho )

                                AIGLX works, not really fast, but it's ok. performance has increased.

                                The only strange thing is:
                                I play WoW using Cedega until a few weeks ago. For some reason WoW got terribly slow ( 1 -3 fps ). I hoped the new driver would fix this. The strange thing however is that 8.42 did not really fix this. WoW still runs at 3 fps except when I enable compiz. Then WoW leaps to 80-100 fps. But now I have texture corruption... Disabling compiz removes the texture corruption but also drops the framerate back to 3 fps.

                                Comment

                                Working...
                                X