Announcement

Collapse
No announcement yet.

FC6 + fglrx 8.30.3-1 + composite disabled = blank screen (Radeon 9500)

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • FC6 + fglrx 8.30.3-1 + composite disabled = blank screen (Radeon 9500)

    Hey First of all, I just wanted to say this forum is great

    Anyhow, I was wondering if anyone else experiences this weird behaviour:
    when disabling Composite in xorg.conf (in order to get the 3D acceleration working), X will not start properly, instead displaying a blank screen. It most likely crashes, as it doesn't allow me to switch back to console via ctrl+alt+Fn.

    Enabling composite allows X to start (obviously, as it switches back to the Mesa OpenGL driver) and gives the usual message:
    (II) fglrx(0): Composite extension enabled, disabling direct rendering

    I'm kind of lost here - I don't know what to try next. I've tried numerous things with xorg.conf, but it all seems to depend on the Composite part - if it's enabled, X works, and if it isn't, X doesn't work. The problem is that every time X fails, it's another rescue CD boot for noobs like me

    The drivers are compiled as per the instructions on this site (--buildpkg Fedora/FC6, RPM install and all that) and the board is a Radeon 9500 PRO. Driver version is 8.30.3-1.

    If anyone could help, I'd really appreciate it I'm quite familiar with the console, so if there are any log files you want to see, please ask


    Orioner
    Last edited by Orioner; 12-07-2006, 06:41 PM. Reason: Solved; Changed title.

  • #2
    Can you post the relevant parts of the X log when composite is disabled?
    Michael Larabel
    http://www.michaellarabel.com/

    Comment


    • #3
      More or less relevant

      There were no errors, so I don't really know what one could consider relevant However, here's the last few lines of a failed boot with Composite disabled:

      (II) fglrx(0): Acceleration enabled
      (II) fglrx(0): X context handle = 0x1
      (II) fglrx(0): [DRI] installation complete
      (this is where the log ends)

      With a successful boot, I get a lot more (same starting point):

      (II) fglrx(0): Acceleration enabled
      (II) fglrx(0): Direct rendering disabled
      (==) fglrx(0): Using hardware cursor
      (II) fglrx(0): Largest offscreen area available: 1280 x 7163
      (II) Loading extension FGLRXEXTENSION
      (II) Loading extension ATITVOUT
      (==) RandR enabled
      (II) Initializing built-in extension MIT-SHM
      (II) Initializing built-in extension XInputExtension
      (II) Initializing built-in extension XTEST
      (II) Initializing built-in extension XKEYBOARD
      (II) Initializing built-in extension XC-APPGROUP
      (II) Initializing built-in extension SECURITY
      (II) Initializing built-in extension XINERAMA
      (II) Initializing built-in extension XFIXES
      (II) Initializing built-in extension XFree86-Bigfont
      (II) Initializing built-in extension RENDER
      (II) Initializing built-in extension RANDR
      (II) Initializing built-in extension COMPOSITE
      (II) Initializing built-in extension DAMAGE
      (II) Initializing built-in extension XEVIE
      (EE) AIGLX: Screen 0 is not DRI capable
      (II) Loading local sub module "GLcore"
      (II) LoadModule: "GLcore"
      (II) Loading /usr/lib/xorg/modules/extensions/libGLcore.so
      (II) Module GLcore: vendor="X.Org Foundation"
      compiled for 7.1.1, module version = 1.0.0
      ABI class: X.Org Server Extension, version 0.3
      (II) GLX: Initialized MESA-PROXY GL provider for screen 0
      (**) Option "CoreKeyboard"
      (**) Keyboard0: Core Keyboard
      (**) Option "Protocol" "standard"
      (**) Keyboard0: Protocol: standard
      (**) Option "AutoRepeat" "500 30"
      (**) Option "XkbRules" "xorg"
      (**) Keyboard0: XkbRules: "xorg"
      (**) Option "XkbModel" "pc105"
      (**) Keyboard0: XkbModel: "pc105"
      (**) Option "XkbLayout" "fi"
      (**) Keyboard0: XkbLayout: "fi"
      (**) Option "CustomKeycodes" "off"
      (**) Keyboard0: CustomKeycodes disabled
      (WW) <default pointer>: No Device specified, looking for one...
      (II) <default pointer>: Setting Device option to "/dev/input/mice"
      (--) <default pointer>: Device: "/dev/input/mice"
      (==) <default pointer>: Protocol: "Auto"
      (**) Option "CorePointer"
      (**) <default pointer>: Core Pointer
      (==) <default pointer>: Emulate3Buttons, Emulate3Timeout: 50
      (**) <default pointer>: ZAxisMapping: buttons 4 and 5
      (**) <default pointer>: Buttons: 9
      (II) XINPUT: Adding extended input device "<default pointer>" (type: MOUSE)
      (II) XINPUT: Adding extended input device "Keyboard0" (type: KEYBOARD)
      (--) <default pointer>: PnP-detected protocol: "ExplorerPS/2"
      (II) <default pointer>: ps2EnableDataReporting: succeeded


      Sorry for the long post. Full logs are available at http://www.student.oulu.fi/~taimiant...org-failed.txt (failed boot) and http://www.student.oulu.fi/~taimiant...rg-success.txt (successful boot). There's also my xorg.conf (which should be nothing special) at http://www.student.oulu.fi/~taimiant/temp/xorg.conf


      Orioner

      Comment


      • #4
        Sounds like one of the driver bugs.

        What happens if you run startx manually?
        Michael Larabel
        http://www.michaellarabel.com/

        Comment


        • #5
          Nothing. I get the same blank screen (interestingly enough, the monitor doesn't go into power saving mode even though there's nothing on the screen). Funny that I installed this Radeon 9500 Pro card just a few days ago - I used to have a Radeon 9200 SE, which worked fine with ATI's drivers (except that all those tweaks were needed to compile the driver), 3D acceleration and all.

          I mean, shouldn't the same drivers that worked for 9200 also have worked for 9500 out of the box (i.e. shouldn't the same driver support both cards when it's tweaked as per the instructions in Redblog)? I would've expected so, but this wasn't the case.


          Orioner

          Comment


          • #6
            Orioner, it looks like you are running into one of the known driver bugs. Some users have had similar problems in the past, you may want to try looking at the unofficial BugZilla.
            Michael Larabel
            http://www.michaellarabel.com/

            Comment


            • #7
              Radeon 9200 is not supported by 8.30 driver
              http://www2.ati.com/drivers/linux/li....3.html#173867
              Last edited by jacek; 11-11-2006, 07:29 PM.

              Comment


              • #8
                Correct, but he is now using the Radeon 9500 he says.
                Michael Larabel
                http://www.michaellarabel.com/

                Comment


                • #9
                  Michale: you are right, I didn't read the thread carefully - sorry.

                  Orion: uncomment this in xorg.conf

                  #Section "Extensions"
                  # Option "Composite" "Disable"
                  #EndSection

                  and make monitor part of the xorg.conf the same as you had it for Radeon 9200 (if you didn't change the monitor)

                  Maybe the monitor is not recognized as it should be by the driver,
                  in your log file it seems to be recognized btw?
                  And maybe you should try using 800x600 resolution first?

                  Comment


                  • #10
                    Originally posted by jacek View Post
                    Michale: you are right, I didn't read the thread carefully - sorry.

                    Orion: uncomment this in xorg.conf

                    #Section "Extensions"
                    # Option "Composite" "Disable"
                    #EndSection

                    and make monitor part of the xorg.conf the same as you had it for Radeon 9200 (if you didn't change the monitor)

                    Maybe the monitor is not recognized as it should be by the driver,
                    in your log file it seems to be recognized btw?
                    And maybe you should try using 800x600 resolution first?
                    Uncommenting that section crashes X when it starts (= gives a blank screen, can't switch to console or anything). The monitor is recognized just fine, and changing the resolution doesn't have any effect.

                    Oh, and I'm now using Livna's 8.31.05 drivers. No change - it still does the same.

                    The unofficial BugZilla lists a lot of similar problems. Seems they've never fixed this particular one

                    Thanks anyway!

                    Orioner

                    Comment

                    Working...
                    X