Announcement

Collapse
No announcement yet.

OpenSuSE 10.+fglrx 8.41.7+HD2600XT(ddr3)=black screen.

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • OpenSuSE 10.+fglrx 8.41.7+HD2600XT(ddr3)=black screen.

    Does anybody else have a same problem by using openSUSE 10.3 and some ati hd series card and after installing the driver(8.41.7) using Yast or console and have everything(packages) in your system that you need and after reboot your screen is totally black even if you try to use failsafe or non x.

  • #2
    Originally posted by Mota_boy View Post
    Does anybody else have a same problem by using openSUSE 10.3 and some ati hd series card and after installing the driver(8.41.7) using Yast or console and have everything(packages) in your system that you need and after reboot your screen is totally black even if you try to use failsafe or non x.


    I havn't been able to successfully get the 8.41 driver working with either a x1300, or a Xpress 200M in 10.3 yet. I've been stuck using 10.2 until hopefully 8.42 has 10.3 support.

    Comment


    • #3
      I had apparently the same thing on 10.2. . .

      driver-install bombed, totally, without saying anything about it.

      So, as usual with the ATI drivers, for ME, anyways, I had to do the


      cd /lib/modules/fglrx/build_mod/

      ./make_install.sh

      /bin/cp fglrx.ko \
      /lib/modules/`/bin/uname -r`/kernel/drivers/char/drm/

      /sbin/depmod


      ( that's actually a cut-n-paste from my system's /etc/rc.d/halt.local
      I HAD to do that, or the damn thing would black-screen every time the kernel got updated, and I've got it set so the updates are completely automatic, so the ATI refresh had to become completely automatic, too! )

      Try the sequence, and see if it fixes things. . .

      oh, yeah, it's gotta be done as root, eh?

      and that `uname -r` bit is just to get the current concept of the kernel, is all. . .

      dang, I just realized it'd require a double-reboot to get the system up properly, after a kernel-update:
      once to get into the new kernel, then a shutdown from there to get my graphics-refresh. . . baH!!


      Hmm, maybe I should have it done in boot.local, then?

      ( yeah, it's an ugly hack, but it works. )

      Comment


      • #4
        Yes in root: sh ./install_package i install it, and black screen i mean that when i boot computer on, its stop situation where i have totally black screen and nothing happens even i have waite 10 min.
        And i have gcc, make, kernel source, jne.
        And installation goes correctly aticonfig ..., sax2, but after boot stops on totally black screen, that i mean in this situation.

        Comment


        • #5
          clarifications. . .

          when I installed the fglrx driver for hd2400, the install SEEMED to have worked, but

          on reboot, the graphics of the boot-process zoomed by, then when it TRIED to go into X, the screen went black.

          It didn't matter how long I waited, it didn't matter how many times I re-booted the machine, it was the same again and again:
          BIOS Power-On-Self-Test,
          grub,
          kernel,
          root/system stuff,
          black-screen.

          If you add the boot-paramater of 2

          ( add " 2" to the boot-command line, without the quotes, of course )

          you can probably get the machine to boot into text-mode, no-X, no-network.

          Once you do that, login as root, and type
          lsmod | grep fglrx

          this will list the kernel-modules ( lsmod ), and
          show you any with "fglrx" in their name.

          I bet that there ISN'T one loaded, and that that is the problem.

          That is why the build-script, the copy, and the depmod, I listed above.

          IF there isn't a fglrx kernel-module that matches the current kernel, it can't be loaded, and therefore X will be useless
          ( unless /etc/X11/xorg.conf does *not* reference fglrx. . . -- in which case its non-existence should not matter )

          HTH

          Comment


          • #6
            Yes, i`m using 2.6.22.9.... kernel, but i can`t get log in even in text mode, even do i did clear the bios and it make little flash on the beginning when i boot on, but darm after 5 reboot/boot and ~20-30min wait it stucked on the black screen, hmm well i will try to another 10.3 in wmware and get the xorg-file so i and we or somebody can tell/help more/better

            Comment


            • #7
              Originally posted by Mota_boy View Post
              Does anybody else have a same problem by using openSUSE 10.3 and **SNIP** after reboot your screen is totally black even if you try to use failsafe or non x.
              First off, you can boot up you system by adding this to the end of the options right at the grub boot screen (make sure there is a space before it):
              Code:
              init 3
              What caused the black screen of death for me was this: the installer left the original system file /usr/lib/libGL.so.1.2 and installed it's own as /usr/X11R6/lib/libGL.so.1.2

              IIRC this didn't happen to me on OpenSuSE 10.2, but anyway you should check to see if there are two GL libs.

              If it exists, the one you want to move out of the way is:
              Code:
              391344 2007-09-21 21:34 libGL.so.1.2
              I'm still using 8.40.4, so I don't know if that's the issue in your case with 8.41.x

              Comment


              • #8
                check ur x.org, frequency for the display, its bugged on my CF 2900 XT
                i had to correct it myself, and remove a driver and 1 monitor, it didnt delete the stuff from the vesa driver. so i had 2 configurations in one x.org aswell, stole the display settings from the monitor section from the previous driver, voila, worked for me.

                And i had a issue in 64 bit, strange one, i wrote my username: atkins "enter"
                Password : xxxxxxxxxxxx "enter"
                took 10 seconds, got display, only vesa again >_<

                but got it working again afer lots of tickering, but, couldnt find out what made it work, was to angry to controll myself.

                Comment


                • #9
                  Assuming you use init 3 from the grub boot screen and are able to login, and the problem is you're unable to get the fglrx module to build, you need this patch:
                  Code:
                  --- /usr/src/linux/scripts/mod/modpost.c	2007-10-08 07:31:40.000000000 -0400
                  +++ /usr/src/linux/scripts/mod/modpost.c	2007-10-20 04:12:23.000000000 -0400
                  @@ -1345,8 +1345,8 @@ static void check_exports(struct module 
                   			basename++;
                   		else
                   			basename = mod->name;
                  -		if (!mod->gpl_compatible)
                  -			check_for_gpl_usage(exp->export, basename, exp->name);
                  +/*		if (!mod->gpl_compatible)
                  +			check_for_gpl_usage(exp->export, basename, exp->name);*/
                   		check_for_unused(exp->export, basename, exp->name);
                           }
                   }
                  Edit:[Forgot to state build command]
                  Copy the above code to /tmp/ naming it modpost.c.diff. Following that, you build the new modpost:
                  Code:
                  cd /usr/src
                  cat /tmp/modpost.c.diff | patch -p0
                  cd /usr/src/linux/scripts/mod
                  gcc -o modpost modpost.c file2alias.c sumversion.c
                  Then you would need to copy the new modpost from that location to the modular kernel source, for example:
                  Code:
                  cd /usr/src/linux-2.6.22.9-0.4-obj/i386/default/scripts/mod
                  mv ./modpost ./modpost.old
                  cp /usr/src/linux/scripts/mod/modpost ./
                  That's the patch I used to get 8.40.4 to build. Anyway, it may still be needed for 8.41.7 (I don't recall).
                  Last edited by edged; 10-23-2007, 08:40 AM.

                  Comment


                  • #10
                    thanks, i`ll try that, and thank you all for youre good answers

                    Comment


                    • #11
                      No well, one guestion first, is that new driver usetable for opensuse also because when i try to "compile" it on suse using following command: sh ati-driver-installer-8.36.5-x86.x86_64.run --listpkg, i mean it should give list of suse distros but on me it give`t list of ubuntus,(the driver what i downloaded on this phoronix site).

                      Anyway i installed on yast the 8.41.7.jne driver and use some console and this time it worked,(even do the 3d-acleration does not work yet, but suse regonice the ati 2600 xt and fglrx driver)
                      hmm have to keep working -> to get the 3d work to

                      Ou and sorry about my english it is little bit rust.

                      Comment


                      • #12
                        Hmm, i wonder does anybody have idea would it help to update the xorg 7.2.. -> 7.3 and then try to install fglrx 8.41.7/8.42.3,?
                        and card what i`m using is hd 2600 xt(gddr3).
                        I mean if it would have better succeed.

                        Comment

                        Working...
                        X