No announcement yet.

AMD Radeon HD 6670 and missing OpenCL support

  • Filter
  • Time
  • Show
Clear All
new posts

  • AMD Radeon HD 6670 and missing OpenCL support

    I got a Sapphire 6670 card a couple of days ago for gaming, development, but mostly to replace a geforce card in bitcoin mining. But to my surprise, even when the card reports 90Mhash, it also produces a lot of hardware errors and no mining at all. Switched to Windows, and found that the GPU-Z reports no OpenCL support! I tried with Catalyst 13.4, then with the updated version in Ubuntu 12.04 repos, but nothing. The card does not produces any result. Can somebody give me an idea about whats happening? Should I discard this 6670 and get something else?

  • #2
    For OpenCL you need to install the AMD APP SDK.


    • #3
      As of SDK 2.8, the AMD APP SDK GPU runtime is not supported. To get the
      APP GPU runtime file,
      install the Catalyst driver. The SDK 2.8 runtime supports only CPU hardw
      are; it is installed under
      Am I getting the wrong idea here, or does that means that GPU is no longer supported by APP SDK?


      • #4
        Originally posted by rogerdv View Post
        Am I getting the wrong idea here, or does that means that GPU is no longer supported by APP SDK?
        It means that we moved the OpenCL GPU runtime support from the SDK into the Catalyst driver install, so you only need the SDK for developing OpenCL apps or for (IIRC**) running OpenCL on CPU when you don't have a recent Catalyst driver installed.

        ** My recollection is that the Catalyst driver includes CPU support for OpenCL but I'm not 100% sure about that part.


        • #5
          Just in case I installed the SDK for Linux, same result. Also uninstalled latest driver in Windows, installed the one bundled with CD. In any case, the card is uncapable of using OpenCL.


          • #6
            Got another AMD card, this time anHD 5450, same result. Seems that AMd cant use OpenCL, so it is my PC or the drivers.


            • #7
              This sounds really wierd. You should probably ask in the AMD OpenCL forum -- that's where the Catalyst OpenCL folks usually hang out. Be specific about OS & driver versions.


              The most common problem seems to be leftover bits from other GPU drivers you might have had installed before.
              Last edited by bridgman; 06-05-2013, 01:46 PM.


              • #8

                Will ask there. Also, I will migrate to Ubuntu 13.04 as soon as Catalyst 13.6 is officially released.