Announcement

Collapse
No announcement yet.

AMD Catalyst 13.6 Linux Graphics Driver Beta Released

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #21
    Originally posted by d2kx View Post
    It's a bug in the OpenGL driver. It's on Windows, too.
    Windows isn't anywhere near as bad about it though - I personally find it tolerable in Windows. In Portal with same graphics settings, the mouse doesn't lag so bad, but there are noticeable frame drops. However, I am using Crossfire, which could be the cause of the frame drops (crossfire doesn't work in Portal for linux).

    Comment


    • #22
      Originally posted by schmidtbag View Post
      Windows isn't anywhere near as bad about it though - I personally find it tolerable in Windows. In Portal with same graphics settings, the mouse doesn't lag so bad, but there are noticeable frame drops. However, I am using Crossfire, which could be the cause of the frame drops (crossfire doesn't work in Portal for linux).
      Portal on Windows uses DirectX 9. Although Valve wants to switch to OpenGL eventually there aswell. Try Unigine Heaven (OpenGL) on Windows.

      Comment


      • #23
        And Catalyst-legacy?

        I hope there will be a new version of the catalyst-legacy driver avaiable in june (the legacy driver is released each 6 months)

        Comment


        • #24
          Originally posted by ext73 View Post
          Unfortunately, again the same as the 13.4 ... "slow motion effect" for mouse in 3D applications ... tested on AMD APU E-350 for example on: Xonotic, Couter Strike: Source, etc..
          Sounds like a typical vsync problem, have you made sure it's disabled in-game and in CCC? (also did you delete /etc/ati/amdpcsdb with Xorg shut down before upgrading?)

          No such issue here, although FPS tank in WINE with vsync on.

          (I've also noticed that I can't click on buttons in TF2's menu, actually I can only navigate with the arrow keys, but then again a quick googling points towards a TF2/old code bug.)

          Comment


          • #25
            Originally posted by PsynoKhi0 View Post
            Sounds like a typical vsync problem, have you made sure it's disabled in-game and in CCC? (also did you delete /etc/ati/amdpcsdb with Xorg shut down before upgrading?)

            No such issue here, although FPS tank in WINE with vsync on.

            (I've also noticed that I can't click on buttons in TF2's menu, actually I can only navigate with the arrow keys, but then again a quick googling points towards a TF2/old code bug.)
            I can confirm that doesn't work. If anything, turning on vsync actually reduces the problem. There's still a delay but it's much more bearable. From my experience with portal, the "color correction" and "motion blur" options seem to have the greatest impact on this issue, but turning them off doesn't eliminate it.

            Comment


            • #26
              AMD... please update your Catalyst Legacy driver (for 3000/4000 series) to support latest X.org and Kernel!!\

              Windows is on Catalyst Legacy 13.4, while Linux is still stuck on the old 13.1 version. WHY??
              Last edited by gururise; 05-29-2013, 02:37 PM.

              Comment


              • #27
                simple

                Originally posted by gururise View Post
                AMD... please update your Catalyst Legacy driver (for 3000/4000 series) to support latest X.org and Kernel!!\

                Windows is on Catalyst Legacy 13.4, while Linux is still stuck on the old 13.1 version. WHY??
                no comercial interest from amd ...

                Comment


                • #28
                  Originally posted by gururise View Post
                  Windows is on Catalyst Legacy 13.4, while Linux is still stuck on the old 13.1 version. WHY??
                  That's not quite right: Windows has a beta of 13.4 available, the stable release is 13.1.

                  Comment


                  • #29
                    Originally posted by archibald View Post
                    That's not quite right: Windows has a beta of 13.4 available, the stable release is 13.1.
                    And no FOSS alternative, drivers that incur development and legal team costs despite the lack of "comercial interest from amd"

                    Comment


                    • #30
                      Works Well with Fedora 19 Beta

                      Am I the only one who's happy about this Beta driver?

                      It works pretty well on Fedora 19 Beta with A10-5800K.

                      Haven't tried any 3D games though. But desktop effects in GNOME 3.8 work smoothly as butter.

                      Comment

                      Working...
                      X