Announcement

Collapse
No announcement yet.

T42 + ATI + projector.

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • T42 + ATI + projector.

    Hello Linuxers,

    I am ready to die over this one. I don't seem to be able to connect a projector to my thinkpad T42 (radeon-ATI chipset) and get a decent video resolution in the projector. Some highlights:
    1) The only way to get projector output is if I restart X (log-off and back on).
    2) Doing the previous sets my LCD display automatically to 800x600 and I have video in both now, but with such high resolution it is very hard for me to work.
    3) I know the projector supports higher resolutions. Why? boot up another HDD with XP and beautiful! it works! boot up another HDD with Ubuntu, and beautiful! it works too!
    4) Installing nvidia drivers following the directions here http://www.phoronix.com/redblog/?p=blog&i=NTU1MA gets me a higher resolution, but then my desktop effects stops working, and also the resolution oversizes my projector resolution/display. At this point system-config-display doesn't respond, so I can't change the resolution.

    Everything else I got working in my T42, including wifi, NIC, adapters, bluetooth, ultrabay ejection... everything but this. I am ready to start teaching a class in 3 hrs and unless I find a solution to this, I will have to put back in my XP hard drive and boot up with it.

    Any leads or ideas will be greatly appreciated.

  • #2
    Maybe there's some valueable information for you hidden in the depths of ThinkWiki: http://www.thinkwiki.org/wiki/Category:T42

    Best of luck!

    Comment


    • #3
      Did you try using the dynamic display management options? See aticonfig --help for more details.

      If you enable it through the DDM options it should work right away.
      Michael Larabel
      http://www.michaellarabel.com/

      Comment


      • #4
        Originally posted by Michael View Post
        Did you try using the dynamic display management options? See aticonfig --help for more details.

        If you enable it through the DDM options it should work right away.

        Michael,

        I thank you so much for your prompt response. Pardon for my ignorance but I am very new at Linux and this problem is a littler over my head at this time.

        So after I install the ATI drivers, I should be able to run "aticonfig --help" from a terminal or is there something else I need to install for this?

        Also is there a GUI interface for this or is it all command (cli) based?

        Thanks, (I will inform back how it goes this afternoon).

        Comment


        • #5
          Once you properly install the ATI fglrx drivers, aticonfig should be installed.

          Then from the terminal run aticonfig --help. At this time there is no GUI equivalent to aticonfig (fireglcontrolpanel is in the same field but lacks any real options).

          Well, instead of running help here is the portion of interest...

          Dynamic Display Management Options:
          Following options will not change the config file. They are
          used for querying driver, controller and adaptor information.
          These options will be effective immediately. Other options on
          the same command line will be ignored.
          --enable-monitor=STRING,STRING
          Setting current monitor to be enabled. Only 2 displays
          can be enabled at the same time. Any displays
          that are not on the list will be disabled.
          STRING can be one of the following set, separated
          by commas:
          none
          crt1
          crt2
          lvds
          tv
          tmds1
          tmds2
          auto -- use default policy to enable the displays.
          --query-monitor
          This will return connected and enabled monitor information
          --swap-monitor
          This only works for big desktop setup. This will swap the
          contents on the two monitors.
          So try enabling the monitor through aticonfig. Since you are using a ThinkPad, if you are using atieventsd, you should also be able to do hot-key switching.
          Michael Larabel
          http://www.michaellarabel.com/

          Comment


          • #6
            I am sorry, one other thing that I forgot to ask, will this ati config will let me use the desktop effects too?

            Comment


            • #7
              No. The Fedora desktop effects (AIGLX + Compiz) are not supported in anyway by the current fglrx drivers.
              Michael Larabel
              http://www.michaellarabel.com/

              Comment


              • #8
                I GOT DISPLAY WORKING!!!!! but....

                Hi Michael, things worked! I could chage the display resolution by launching the gnome-display-properties and change the resolution there. Now the problem that I have is that I am unable to move the windows/resize them or anything. Is like the window manager just blew away from so I can't manipulate the windows I open. Please helP! how can I correct this one?

                Thanks,

                Comment


                • #9
                  Were you trying to enable the desktop effects? That describes what you are encountering.

                  Did you try restarting?
                  Michael Larabel
                  http://www.michaellarabel.com/

                  Comment


                  • #10
                    It worked! a flickering problem (solver) and a vmware problem too.

                    Originally posted by Michael View Post
                    Were you trying to enable the desktop effects? That describes what you are encountering.

                    Did you try restarting?
                    Mike,

                    Hats off to you! you know this stuff pretty well. I disabled desktop effects and this worked like a charm.
                    Then two more problems were presented. The first a horrible flickering problem, that didn't get resolved by adjusting the refresh rate. Basically I did ctrl-alt-F1 followed by alt-F7 and that fixed the flickering.

                    The other is a problem pertaining vmware server. I understand this is outside the scope fo the support here, but decided to post in case you know what the problem is and suggest a solution.
                    I am running vmware server in my linux and then a XP virtual machine. After doing all the driver changes, I return to vmware now and try to launch the XP in full screen mode, but I get the following message:

                    --------------------------------------------------
                    Unable to find an appropriate host video mode.
                    Adding the guest mode to the 'display' subsection of the 'screen' section of your /etc/X11/XF86Config and restarting X is likely to help.

                    Failed to switch to full screen SVGA mode.
                    --------------------------------------------------

                    I am not even using XF86Config, and I have looked in nearly 20 different suggestions but I wasn't lucky to resolve.

                    Currently my conf.org looks like follows:
                    # Xorg configuration created by system-config-display

                    Section "ServerLayout"
                    Identifier "single head configuration"
                    Screen 0 "aticonfig-Screen[0]" 0 0
                    InputDevice "Keyboard0" "CoreKeyboard"
                    InputDevice "Synaptics" "CorePointer"
                    EndSection

                    Section "Files"
                    EndSection

                    Section "Module"
                    Load "dri"
                    Load "glx"
                    EndSection

                    Section "InputDevice"
                    Identifier "Keyboard0"
                    Driver "kbd"
                    Option "XkbModel" "pc105"
                    Option "XkbLayout" "us"
                    EndSection

                    Section "InputDevice"
                    Identifier "Synaptics"
                    Driver "synaptics"
                    Option "Device" "/dev/input/mice"
                    Option "Protocol" "auto-dev"
                    Option "Emulate3Buttons" "yes"
                    EndSection

                    Section "Monitor"

                    ### Comment all HorizSync and VertSync values to use DDC:
                    ### Comment all HorizSync and VertSync values to use DDC:
                    ### Comment all HorizSync and VertSync values to use DDC:
                    ### Comment all HorizSync and VertSync values to use DDC:
                    ### Comment all HorizSync and VertSync values to use DDC:
                    ### Comment all HorizSync and VertSync values to use DDC:
                    ### Comment all HorizSync and VertSync values to use DDC:
                    ### Comment all HorizSync and VertSync values to use DDC:
                    Identifier "Monitor1"
                    VendorName "Monitor Vendor"
                    ModelName "Monitor 1024x768"
                    HorizSync 31.5 - 57.0
                    VertRefresh 50.0 - 70.0
                    Option "dpms"
                    EndSection

                    Section "Monitor"
                    Identifier "aticonfig-Monitor[0]"
                    Option "VendorName" "ATI Proprietary Driver"
                    Option "ModelName" "Generic Autodetecting Monitor"
                    Option "DPMS" "true"
                    EndSection

                    Section "Device"
                    Identifier "Videocard0"
                    Driver "radeon"
                    EndSection

                    Section "Device"
                    Identifier "aticonfig-Device[0]"
                    Driver "fglrx"
                    EndSection

                    Section "Screen"
                    Identifier "Screen0"
                    Device "Videocard0"
                    DefaultDepth 24
                    SubSection "Display"
                    Viewport 0 0
                    Depth 24
                    EndSubSection
                    SubSection "Display"
                    Viewport 0 0
                    Depth 16
                    Modes "1280x1024" "1024x768" "800x600" "640x480"
                    EndSubSection
                    EndSection

                    Section "Screen"
                    Identifier "aticonfig-Screen[0]"
                    Device "aticonfig-Device[0]"
                    Monitor "aticonfig-Monitor[0]"
                    DefaultDepth 24
                    SubSection "Display"
                    Viewport 0 0
                    Depth 24
                    EndSubSection
                    EndSection

                    Section "Extensions"
                    Option "Composite" "Disable"
                    EndSection

                    ==================================================


                    Any ideas??????

                    Thanks,

                    Comment


                    • #11
                      Hmmm you could try using QEMU instead of VMWare. That's personally what I use. Other than that, I don't use VMWare much.
                      Michael Larabel
                      http://www.michaellarabel.com/

                      Comment

                      Working...
                      X