Announcement

Collapse
No announcement yet.

AMD Catalyst 13.4 Final

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • AMD Catalyst 13.4 Final

    AMD Catalyst 13.4 Final

    Release Notes: http://support.amd.com/us/kbarticles...easeNotes.aspx
    Download: http://www2.ati.com/drivers/linux/am...x86.x86_64.zip

    This is pretty much the Catalyst 13.3 Beta 3 with a few additional fixes and new hardware support, nothing special. Laptop brightness adjustment is still broken. There should be a Catalyst 13.5 Beta next week with some new stuff.

  • #2
    Bummer. It kills my VTs if i boot with kernels > than 3.7.
    The x server runs just fine, but i cannot change to another VT, i get a blank screen (but the monitor has signal). I have Debian 64 bit with the 3.9 kernel and an A8-5500 APU.

    Same problem as the betas:

    http://phoronix.com/forums/showthrea...2-Linux-Driver

    Comment


    • #3
      Ok, i figured it out.

      To have VTs with kernels 3.8 or 3.9 (if you lost them, that is), you have to set either the deprecated (but still working yet) kernel command:

      "vga=number", where number=resolution code such as 792, see here all of them:

      http://pierre.baudu.in/other/grub.vga.modes.html

      Or use the shiny new (and annoying) gfxpayload command. That doesnt work as simple as the above older one since you have to put it BEFORE the 'linux...' command in the grub entry (as instructed by the boot message). Putting it in GRUB_CMDLINE_LINUX via /etc/default/grub does exactly nothing, it HAS to be BEFORE the 'linux...' command.

      So. How? I personally had to manually mess with /boot/grub/grub.cfg file since i couldnt figure it to do it properly via /etc/default/grub+update-grub.
      So there you have my working entry (see the set gfxpayload entry):

      Code:
      menuentry 'Debian GNU/Linux, with Linux 3.9.0' --class debian --class gnu-linux --class gnu --class os {
      	load_video
      	insmod gzio
      	insmod part_msdos
      	insmod ext2
      	set root='(hd2,msdos1)'
      	search --no-floppy --fs-uuid --set=root 89d577ec-47b9-4aa7-96a1-ad1f5092ead6
      	echo	'Loading Linux 3.9.0 ...'
      	set gfxpayload=1280x1024x24,1280x1024
      	linux	/boot/vmlinuz-3.9.0 root=UUID=89d577ec-47b9-4aa7-96a1-ad1f5092ead6 ro  quiet
      	echo	'Loading initial ramdisk ...'
      	initrd	/boot/initrd.img-3.9.0

      Comment


      • #4
        Originally posted by gradinaruvasile View Post

        Or use the shiny new (and annoying) gfxpayload command. That doesnt work as simple as the above older one since you have to put it BEFORE the 'linux...' command in the grub entry (as instructed by the boot message). Putting it in GRUB_CMDLINE_LINUX via /etc/default/grub does exactly nothing, it HAS to be BEFORE the 'linux...' command.

        So. How? I personally had to manually mess with /boot/grub/grub.cfg file since i couldnt figure it to do it properly via /etc/default/grub+update-grub.
        You should try adding a new variable in your /etc/default/grub :
        Code:
        GRUB_GFXPAYLOAD_LINUX=1280x1024x24,1280x1024
        then update-grub

        Comment


        • #5
          Originally posted by gradinaruvasile View Post
          Bummer. It kills my VTs if i boot with kernels > than 3.7.
          The x server runs just fine, but i cannot change to another VT, i get a blank screen (but the monitor has signal). I have Debian 64 bit with the 3.9 kernel and an A8-5500 APU.

          Same problem as the betas:

          http://phoronix.com/forums/showthrea...2-Linux-Driver
          I'm surprised that is still a problem. I used to get this exact thing with my old x1950pro. Haven't ever used catalyst since then.

          Comment


          • #6
            For the Love of god. FIX CROSSFIRE!!!!!

            How long do I have to wait to get crossfire support for my 2 HD6950s in linux?!? I have it in windows, it works in windows, I HATE windows. I use it about 1 once a month on my desktop. Rest of the time is all linux.

            Bridgeman, can you possibly talk to someone about this issue? I mean, seriously, its 2yr old tech.

            I open amdcccle, set crossfire. It tells me OK reboot. I do. Open amdcccle, shows crossfire is disabled.. WTF?! Try again, still nothing. All 3 monitors are the same monitor, running the same resolution, Both Cards are HD6950s with 2GB of GDDR5.

            I've bought nothing but AMD/ATI stuff for 20 years. I'm getting to the point where I feel betrayed as a loyal fan and customer. Looks like I will not be upgrading to 2 cards next time around. Why bother when crossfire isn't going to work? I've reported the issue to AMD before. Nothing happens. Heck, the Feedback page hasn't been updated to even show any drivers past the 12.X series!
            Last edited by Darksurf; 05-22-2013, 03:54 AM.

            Comment


            • #7
              Originally posted by Darksurf View Post
              How long do I have to wait to get crossfire support for my 2 HD6950s in linux?!? I have it in windows, it works in windows, I HATE windows. I use it about 1 once a month on my desktop. Rest of the time is all linux.

              Bridgeman, can you possibly talk to someone about this issue? I mean, seriously, its 2yr old tech.

              I open amdcccle, set crossfire. It tells me OK reboot. I do. Open amdcccle, shows crossfire is disabled.. WTF?! Try again, still nothing. All 3 monitors are the same monitor, running the same resolution, Both Cards are HD6950s with 2GB of GDDR5.

              I've bought nothing but AMD/ATI stuff for 20 years. I'm getting to the point where I feel betrayed as a loyal fan and customer. Looks like I will not be upgrading to 2 cards next time around. Why bother when crossfire isn't going to work? I've reported the issue to AMD before. Nothing happens. Heck, the Feedback page hasn't been updated to even show any drivers past the 12.X series!
              Offer one of your HD6950 to anyone who introduces crossfire in opensource driver. Thats the right way to go.
              Also, crossfire is pretty advanced tech. Don't feel betrayed, they have working opensource driver with high performance. Feeling betrayed WOULD be correct IMHO for things like Nvidia cutting some of OpenGL extensions (accelerations) because they feel you are not allowed to use them, because you have desktop card. Just compare...
              Last edited by brosis; 05-22-2013, 06:25 PM.

              Comment


              • #8
                Originally posted by gradinaruvasile View Post
                Ok, i figured it out.
                I have a good fix for you - read this thread thoroughly till the end.

                Comment


                • #9
                  Originally posted by vinz View Post
                  You should try adding a new variable in your /etc/default/grub :
                  Code:
                  GRUB_GFXPAYLOAD_LINUX=1280x1024x24,1280x1024
                  then update-grub
                  Yup, that works too. Thanks.

                  Originally posted by brosis
                  I have a good fix for you - read this thread thoroughly till the end.
                  The point is...? I mean why read the whole thing ( i do follow that thread, but i dont see its relevance here). BTW i wont use the OSS driver until it has proper power management for APUs.

                  Comment

                  Working...
                  X