Announcement

Collapse
No announcement yet.

New AMD Catalyst Beta Supports Linux 3.8, TF2 Fixes

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • New AMD Catalyst Beta Supports Linux 3.8, TF2 Fixes

    Phoronix: New AMD Catalyst Beta Supports Linux 3.8, TF2 Fixes

    AMD has released a new Catalyst Linux graphics driver, which supports modern Linux kernel releases while having various other fixes in store too. Some of the OpenGL fixes will help those playing some Linux Steam client games...

    http://www.phoronix.com/vr.php?view=MTM0ODI

  • #2
    Originally posted by phoronix View Post
    Phoronix: New AMD Catalyst Beta Supports Linux 3.8, TF2 Fixes

    AMD has released a new Catalyst Linux graphics driver, which supports modern Linux kernel releases while having various other fixes in store too. Some of the OpenGL fixes will help those playing some Linux Steam client games...

    http://www.phoronix.com/vr.php?view=MTM0ODI
    Go Go Go AMD !

    it can only get better

    but please don't improve too slowly


    nice work

    Comment


    • #3
      There is no problem with kernel 3.9 for fglrx or nvidia. When the drivers support kernel 3.8 then it works with 3.9 too. I only need a fix for ndiswrapper. I don't get why amd changed the file without changeing the name, when i don't know what is different then it is useless to package.

      Comment


      • #4
        Am I right to assume that this one does not support xorg-server 1.14? If so, does that mean we have to wait for Ubuntu 13.10 to get support for that?
        Bridgman, if you read this, do you have access to some kind of roadmap for the Catalyst driver (if such thing even exists)?

        Comment


        • #5
          I really wish AMD would keep up to date on kernel support like NVIDIA does. Seems AMD is always a bit behind, and hesitant to support the latest kernels and xorg version until basically forced to. This is one of the main reasons I switched almost fully to NVIDIA in most of my computers, not to mention the fact they dropped support for anything other than HD5XXX and above.

          Thanks for the info though, I will be trying these drivers out on Ubuntu 13.04 with the Radeon HD 6870 tonight. Nice to see AMD still progressing, even if a bit slow.

          Comment


          • #6
            Sigh... I wish AMD would put out a new fglrx legacy driver too. I don't have the money for a new GPU (besides my HD3850 can run a load of games just fine) and I hate being stuck on an old version of the distro that I use :-(.

            Comment


            • #7
              Anyone know if the HoN freeze/crash is fixed?
              My XServer/display always freezed after I left the game, since the first beta driver.

              Comment


              • #8
                Originally posted by erpe View Post
                Anyone know if the HoN freeze/crash is fixed?
                My XServer/display always freezed after I left the game, since the first beta driver.
                I had'nt any problems with HoN with 13.2/13.3 beta drivers. What graphics card and OS do you use? Mine: Ubuntu 12.10, Radeon HD 6930.

                Comment


                • #9
                  Originally posted by leonmaxx View Post
                  I had'nt any problems with HoN with 13.2/13.3 beta drivers. What graphics card and OS do you use? Mine: Ubuntu 12.10, Radeon HD 6930.
                  ArchLinux, Radeon HD 5770

                  Comment


                  • #10
                    Sight.

                    Kernel support for Catalyst is based around kernel module which is GPL2....

                    Now if only AMD folks where able enough to realize that someone in Arch dev community always have needed changes BEFORE stable kernels are released. Or is Catalys team having NIH syndrome, or superiority syndrome that prevent them from realizing that someone can beat them to the code.

                    (Though no complaints about FLOSS AMD team :P)

                    Comment


                    • #11
                      Originally posted by Cyber Killer View Post
                      Sigh... I wish AMD would put out a new fglrx legacy driver too. I don't have the money for a new GPU (besides my HD3850 can run a load of games just fine) and I hate being stuck on an old version of the distro that I use :-(.
                      You may want to poke around Arch forum. Support for just kernels require GPL2 kernel module, and no changes to fglrx.

                      Now if you also have newer X server...

                      Comment


                      • #12
                        No AMD

                        AMD needs to get faster at getting drivers to support the latest kernel.
                        This is hurting them.

                        I do not buy AMD and can not recommend AMD to anyone.

                        Comment


                        • #13
                          wow, that's kind of a big changelog...if that's how it'll be in the future, I could decide to buy another AMD GPU.

                          Comment


                          • #14
                            Originally posted by Vim_User View Post
                            Am I right to assume that this one does not support xorg-server 1.14? If so, does that mean we have to wait for Ubuntu 13.10 to get support for that?
                            Bridgman, if you read this, do you have access to some kind of roadmap for the Catalyst driver (if such thing even exists)?
                            According to the release notes it supports up to xserver 1.13. So it's almost definite that 1.14 won't be supported.

                            Then again most distros, even the most bleeding edge Fedora 18 is still on xserver 1.13 so I don't see the problem of Catalyst not being able to support 1.14 as of now.


                            Originally posted by uid313
                            AMD needs to get faster at getting drivers to support the latest kernel.
                            And most distros that were released 2 - 3 months ago don't even ship with 3.8 or even 3.7. I don't see the point of supporting an unreleased kernel that is not even deployed yet.
                            Last edited by Sonadow; 04-11-2013, 05:07 AM.

                            Comment


                            • #15
                              Originally posted by Sonadow View Post
                              According to the release notes it supports up to xserver 1.13. So it's almost definite that 1.14 won't be supported.
                              The same release notes also claim that kernels up to 3.5 are supported, despite the note in the changelog that it goes up to 3.5 now, therefore I asked.

                              Then again most distros, even the most bleeding edge Fedora 18 is still on xserver 1.13 so I don't see the problem of Catalyst not being able to support 1.14 as of now.
                              OK, the most bleeding edge distro of all, Slackware, is on 1.14 for about a month now in -current. Seriously, AMD not being able to keep up with Slackware's development? And if they sync their support of kernels/Xorg with Ubuntu, do we have to wait another 6 months for support (when we maybe already have 1.15)?

                              Comment

                              Working...
                              X