Announcement

Collapse
No announcement yet.

fglrx not visible with lsmod

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • fglrx not visible with lsmod

    Hi again,

    After installation 8.30.3 drivers with success (see http://www.phoronix.net/forums/showthread.php?t=325 for details), i encountererd the following trouble.

    # /sbin/lsmod | grep "fglrx"
    => Nothing appears

    # /sbin/lsmod | grep "radeon"
    radeon 109537 0
    drm 72789 1 radeon

    $ fglrxinfo
    display: :0.0 screen: 0
    OpenGL vendor string: Mesa project: www.mesa3d.org
    OpenGL renderer string: Mesa GLX Indirect
    OpenGL version string: 1.2 (1.5 Mesa 6.5.1)

    $ cat /etc/X11/xorg.conf
    # Xorg configuration created by system-config-display

    Section "ServerLayout"
    Identifier "single head configuration"
    Screen 0 "aticonfig-Screen[0]" 0 0
    InputDevice "Keyboard0" "CoreKeyboard"
    InputDevice "Synaptics" "CorePointer"
    EndSection

    Section "Files"
    EndSection

    Section "Module"
    Load "dri"
    Load "glx"
    EndSection

    Section "InputDevice"
    Identifier "Keyboard0"
    Driver "kbd"
    Option "XkbModel" "pc105"
    Option "XkbLayout" "fr"
    EndSection

    Section "InputDevice"
    Identifier "Synaptics"
    Driver "synaptics"
    Option "Device" "/dev/input/mice"
    Option "Protocol" "auto-dev"
    Option "Emulate3Buttons" "yes"
    Option "LeftEdge" "120"
    Option "RightEdge" "830"
    Option "TopEdge" "120"
    Option "BottomEdge" "650"
    Option "FingerLow" "14"
    Option "FingerHigh" "15"
    Option "MaxTapMove" "110"
    Option "VertScrollDelta" "20"
    Option "HorizScrollDelta" "20"
    Option "MinSpeed" "0.3"
    Option "MaxSpeed" "0.75"
    EndSection

    Section "Monitor"

    ### Comment all HorizSync and VertSync values to use DDC:
    Identifier "Monitor0"
    ModelName "LCD Panel 1400x1050"
    HorizSync 31.5 - 90.0
    VertRefresh 59.0 - 75.0
    Option "dpms"
    EndSection

    Section "Monitor"
    Identifier "aticonfig-Monitor[0]"
    Option "VendorName" "ATI Proprietary Driver"
    Option "ModelName" "Generic Autodetecting Monitor"
    Option "DPMS" "true"
    EndSection

    Section "Device"
    Identifier "aticonfig-Device[0]"
    Driver "fglrx"
    EndSection

    Section "Screen"
    Identifier "aticonfig-Screen[0]"
    Device "aticonfig-Device[0]"
    Monitor "aticonfig-Monitor[0]"
    DefaultDepth 24
    SubSection "Display"
    Viewport 0 0
    Depth 24
    EndSubSection
    EndSection

    Section "Extensions"
    Option "Composite" "Disable"
    EndSection

    Any ideas ?

  • #2
    What card are you running?

    What happens when you manually modprobe fglrx?

    Anything of relevance in your X log?
    Michael Larabel
    http://www.michaellarabel.com/

    Comment


    • #3
      Hi,

      My video card is Radeon X300

      $ modprobe fglrx
      FATAL: Error inserting fglrx (/lib/modules/2.6.18-1.2798.fc6/extra/fglrx/fglrx.ko): Invalid module format

      #file /lib/modules/2.6.18-1.2798.fc6/extra/fglrx/fglrx.ko
      /lib/modules/2.6.18-1.2798.fc6/extra/fglrx/fglrx.ko: ELF 32-bit LSB relocatable, Intel 80386, version 1 (SYSV), not stripped


      # uname -a
      Linux dream 2.6.18-1.2798.fc6 #1 SMP Mon Oct 16 14:54:20 EDT 2006 i686 i686 i386 GNU/Linux

      Comment


      • #4
        Oups, my video card is M300 (not X300)

        # lspci | grep ATI
        01:00.0 VGA compatible controller: ATI Technologies Inc M22 [Radeon Mobility M300]

        Comment


        • #5
          Did you try reinstalling all of the RPMs? (or make sure all four were installed)
          Michael Larabel
          http://www.michaellarabel.com/

          Comment


          • #6
            Originally posted by Michael View Post
            Did you try reinstalling all of the RPMs? (or make sure all four were installed)
            Yes, i think the problem came from the version of gcc or architecture problem.
            There error during the modeprod let me think this.

            I just tried to use by hand:
            # modeprod -f fglrx
            and it works

            But i dont understand yet why did i need to add the -f option

            Sh

            Comment


            • #7
              some other trace of the problem.
              # demsg
              ...
              fglrx: version magic '2.6.18-1.2798.fc6 SMP mod_unload 686 REGPARM 4KSTACKS gcc-4.1' should be '2.6.18-1.2798.fc6 SMP mod_unload 586 REGPARM 4KSTACKS gcc-4.1'

              Looks like i586 and i686 conflic!

              Sh

              Comment


              • #8
                After browsing the web, my problem seems to be referenced their: https://bugzilla.redhat.com/bugzilla....cgi?id=211941

                Wrong kernel architecture with FC6 due to anacron bug.
                This is the reason why i've got an i586 kernel instead of a i686.

                Comment


                • #9
                  Thus i've just removed my kernel:

                  # yum remove kernel
                  It removes a i586 version
                  and then (just after):
                  # yum install kernel
                  it install a i686 version
                  Then i've reconfigured grub (do not forget to reconfigure grub!!!)
                  Then i reboot

                  After, reboot, i've removed all ATI package
                  #rpm -e ATI-fglrx-control-panel-8.30.3-1.fc6 ATI-fglrx-8.30.3-1.fc6 kernel-module-ATI-fglrx-2.6.18-1.2798.fc6-8.30.3-1.fc6 ATI-fglrx-devel-8.30.3-1.fc6

                  Then, i rebuild all the package
                  # ./ati-driver-installer-8.30.3.run --buildpkg Fedora/FC6./ati-driver-installer-8.30.3.run --buildpkg Fedora/FC6
                  Creating directory fglrx-installVerifying archive integrity... All good.Uncompressing ATI Proprietary Linux Driver-8.30.3............................................ .................................................. .................................................. .................................................. .................................................. .................................................. .................................................. .................................................. .................................................. ..........................................======== ========================================== ATI Technologies Linux Driver Installer/Packager========================================== ========
                  Generating package: Fedora/FC6Package
                  /home/brothier/tmp/ATI-fglrx-8.30.3-1.fc6.i386.rpm has been successfully generated
                  Package /home/brothier/tmp/ATI-fglrx-control-panel-8.30.3-1.fc6.i386.rpm has been successfully generated
                  Package /home/brothier/tmp/ATI-fglrx-devel-8.30.3-1.fc6.i386.rpm has been successfully generated
                  Package /home/brothier/tmp/kernel-module-ATI-fglrx-2.6.18-1.2798.fc6-8.30.3-1.fc6.i386.rpm has been successfully generated
                  Removing temporary directory: fglrx-install

                  Then i've reinstalled all the fresh package
                  rpm -ivh ATI-fglrx-8.30.3-1.fc6.i386.rpm ATI-fglrx-control-panel-8.30.3-1.fc6.i386.rpm ATI-fglrx-devel-8.30.3-1.fc6.i386.rpm

                  and it works!

                  # lsmod | grep fglrx
                  fglrx 414252 8

                  Comment

                  Working...
                  X