Announcement

Collapse
No announcement yet.

AMD Legacy Catalyst 13.1 for HD2000-4000 is out

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #46
    amd legacy with wine

    I've installed the amd legacy driver from debian experimental on a "debian wheezy + graphic stack from kanotix", and I can confirm native steam/TF2 works like a charm.
    my problem is that fglrx+wine (steam civ5) hang my display after a while... the computer is still alive cause from the console I can kill my wine processes.

    for now, I've the choice between opensource driver that is rock stable but slow, or flgx legacy that is now stable enough...
    that why I still need a crapy dual boot.

    does someone knows if the new fglrx drivers for new cards (hd 7750 for eg) is more stable ? cause I'm looking for changing my old card.

    regards

    Comment


    • #47
      Originally posted by jery View Post
      I've installed the amd legacy driver from debian experimental on a "debian wheezy + graphic stack from kanotix", and I can confirm native steam/TF2 works like a charm.
      my problem is that fglrx+wine (steam civ5) hang my display after a while... the computer is still alive cause from the console I can kill my wine processes.

      for now, I've the choice between opensource driver that is rock stable but slow, or flgx legacy that is now stable enough...
      that why I still need a crapy dual boot.

      does someone knows if the new fglrx drivers for new cards (hd 7750 for eg) is more stable ? cause I'm looking for changing my old card.

      regards
      Well my card is Radeon HD4850 and the performance with kernel 3.8 and mesa 9.2git(from xorg-edgers ubuntu ppa) is a lot better than it ever was with Catalyst. Team fortress 2 runs and most important of all it runs STABLE while resolution being the legendary "full hd" 1920x1080 with high details + 2xMSAA and the whole game just plays very smoothly around 40-60+ fps most of the time. Also I can play skyrim through wine finally with all the high details and yadda yadda... All in all if you can by all means just try mesa 9.1 and up with latest kernel before switching card. You wont regret it! What happened between mesa 9.0 and now is just amazing performance vice, so congrats to devs too! I was kind of giving up hope but this thing just SCREAMS NOW!

      Comment


      • #48
        I'm already running MESA 9.1 (from kanotix repository), and a 3.8.x kernel (from debian experimental)... and my hd4650 with OSS driver is really not as fast as it is with fglrx...

        Comment


        • #49
          AutoApt

          Originally posted by Goodolandy View Post
          I hope this will be incorporated in to the "Additional Drivers" Ubuntu utility because that has always been the only way I have ever gotten the ATI driver installed. I have tried over 20 times over the years and two more times with the latest 13.1 and have had ZERO success.

          If someone has had success in creating the Ubuntu 12.10 installer for this recent driver, I would love to get it from you. The installer always says it was successfull only to say on the next screen that there are errors.
          https://help.ubuntu.com/community/AutoApt

          auto-apt run ./<cmd>...

          I use it to solve dependency/missing problems...

          Comment


          • #50
            it does not work

            I have ati hd Radeon 4250, and I have tried to install it in too many different distros (ubuntu 12.04 with kernel 3.5 and 3.8, ubuntu 12.10, ubuntu 13.04 (following all the tutorials in the web, doing the xorg downgrade to 1.12, etc), chakra, manjaro, opensuse, linux mint 14, elementary os with kernel 3.8, etc) and I cant install it, wen I restart te pc just appear a black screen than make me to reinstall the distro again. Now I am using mesa 9.2, and works good, but not enought for steam linux games

            Comment


            • #51
              Originally posted by edoantonioco View Post
              I have ati hd Radeon 4250, and I have tried to install it in too many different distros (ubuntu 12.04 with kernel 3.5 and 3.8, ubuntu 12.10, ubuntu 13.04 (following all the tutorials in the web, doing the xorg downgrade to 1.12, etc), chakra, manjaro, opensuse, linux mint 14, elementary os with kernel 3.8, etc) and I cant install it, wen I restart te pc just appear a black screen than make me to reinstall the distro again. Now I am using mesa 9.2, and works good, but not enought for steam linux games
              Are you using the SB optimizations ? My recollection is that they make a big difference on low end hardware. The hd4250 has a 40 ALU shader core, so along with hd2400, hd3450 etc... are the smallest r600-family shader cores we made.

              Comment


              • #52
                Originally posted by bridgman View Post
                Are you using the SB optimizations ? My recollection is that they make a big difference on low end hardware. The hd4250 has a 40 ALU shader core, so along with hd2400, hd3450 etc... are the smallest r600-family shader cores we made.
                No, Im not, but now I want to use it
                So, according to this article from phoronix
                http://www.phoronix.com/scan.php?pag...tem&px=MTM2MjA
                it says
                "[...] can be enabled via the R600_DEBUG=sb environment variable"
                So, how can I activate it? Where do I have to put that sentence, inside which file?
                Thanks for the help

                Comment

                Working...
                X