Announcement

Collapse
No announcement yet.

HD2600XT, Ati Linux 8.41.7, Opensuse 10.2

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #21
    hmmm, could you post your xorg.conf please?
    (there's no other config file relative to fglrx, is there..?)
    are all the others using ati 2k series exeriencing this crappy 2d performance?

    Comment


    • #22
      Originally posted by hugues View Post
      3D is enabled and no choppiness when draggin the windows.
      Could you please post the output of gtkperf?

      Comment


      • #23
        That's the article I used to install. Not sure what to say, It won't work for me. I just reformatted and tried again, and I still get errors during the driver installation.

        Comment


        • #24
          Originally posted by theonedgo View Post
          That's the article I used to install. Not sure what to say, It won't work for me. I just reformatted and tried again, and I still get errors during the driver installation.
          What are the errors that you get?
          Michael Larabel
          http://www.michaellarabel.com/

          Comment


          • #25
            Originally posted by Michael View Post
            What are the errors that you get?
            Identical to the ones I posted before:

            Preparing... ########################################### [100%]
            1:fglrx64_7_1_0_SUSE102 ########################################### [100%]
            /usr/src/kernel-modules/fglrx /
            rm: cannot remove `Modules.symvers': No such file or directory
            rm: cannot remove `*.o': No such file or directory
            rm: cannot remove `*.ko': No such file or directory
            rm: cannot remove `*.mod.*': No such file or directory
            make: Entering directory `/usr/src/linux-2.6.18.2-34-obj/x86_64/default'
            make -C ../../../linux-2.6.18.2-34 O=../linux-2.6.18.2-34-obj/x86_64/default
            LD /usr/src/kernel-modules/fglrx/built-in.o
            CC [M] /usr/src/kernel-modules/fglrx/firegl_public.o
            /usr/src/kernel-modules/fglrx/firegl_public.c: In function ‘fglrx_pci_suspend’:
            /usr/src/kernel-modules/fglrx/firegl_public.c:799: warning: passing argument 1 of ‘firegl_pci_save_state’ from incompatible pointer type
            /usr/src/kernel-modules/fglrx/firegl_public.c: In function ‘fglrx_pci_resume’:
            /usr/src/kernel-modules/fglrx/firegl_public.c:838: warning: passing argument 1 of ‘firegl_pci_restore_state’ from incompatible pointer type
            /usr/src/kernel-modules/fglrx/firegl_public.c: In function ‘firegl_put_user_ptr’:
            /usr/src/kernel-modules/fglrx/firegl_public.c:1617: warning: cast from pointer to integer of different size
            /usr/src/kernel-modules/fglrx/firegl_public.c:1617: warning: cast from pointer to integer of different size
            /usr/src/kernel-modules/fglrx/firegl_public.c:1617: warning: cast from pointer to integer of different size
            /usr/src/kernel-modules/fglrx/firegl_public.c:1617: warning: cast from pointer to integer of different size
            /usr/src/kernel-modules/fglrx/firegl_public.c: In function ‘__ke_unregister_ioctl32_conversion’:
            /usr/src/kernel-modules/fglrx/firegl_public.c:2982: warning: ‘return’ with a value, in function returning void
            /usr/src/kernel-modules/fglrx/firegl_public.c: In function ‘KAS_SlabCache_Initialize’:
            /usr/src/kernel-modules/fglrx/firegl_public.c:5477: warning: cast from pointer to integer of different size
            LD [M] /usr/src/kernel-modules/fglrx/fglrx.o
            Building modules, stage 2.
            MODPOST
            WARNING: could not find /usr/src/kernel-modules/fglrx/.libfglrx_ip.a.GCC4.cmd for /usr/src/kernel-modules/fglrx/libfglrx_ip.a.GCC4
            CC /usr/src/kernel-modules/fglrx/fglrx.mod.o
            LD [M] /usr/src/kernel-modules/fglrx/fglrx.ko
            make: Leaving directory `/usr/src/linux-2.6.18.2-34-obj/x86_64/default'
            make: Entering directory `/usr/src/linux-2.6.18.2-34-obj/x86_64/default'
            make -C ../../../linux-2.6.18.2-34 O=../linux-2.6.18.2-34-obj/x86_64/default modules_install
            INSTALL /usr/src/kernel-modules/fglrx/fglrx.ko
            DEPMOD 2.6.18.2-34-default
            make: Leaving directory `/usr/src/linux-2.6.18.2-34-obj/x86_64/default'
            /

            ************************************************** ***********
            Please read "/usr/share/doc/packages/fglrx/README.SuSE" for
            configuration details when using SaX2.
            ************************************************** ***********


            I think I'm just going to wait for Opensuse 10.3 final on October 4th, and the next ati driver mid October hopefully, and try again then. Thanks for the help all.

            Comment


            • #26
              anyone with working 3d and smooth 2d to post their hardware and software config?

              Comment


              • #27
                Originally posted by theonedgo View Post
                Ok, I re-installed, and am still experiencing the same choppiness. Not sure what the issue could be. Hope it's not hardware.
                I hope you got it fixed... otherwise try this!

                You just have to run sax2 as root... best(or easyist) way is to: open a terminal and enter "su" then root password ... type "init 3" to enter terminalmode, run "sax2 -r -m 0=fglrx" ... after that runt "init 5" and i should be ok!... (i hope!).

                Comment


                • #28
                  Please Help Me!!!

                  I was wondering if anyone knew of the Saphire HD2600 XT 256MB DDR4 RAM, video card just being incompatible with Linux. I have been trying now for months since the release of ATI drivers for the HD2000 series, and no luck. I experience a lot of choppiness, and I always get the following errors. Please help me as I really want to use Opensuse 10.3


                  these are the messages I get when tryna install any of the ATI video drivers. I just got it again with the 7.12 driver on Opensuse 10.3 64-bit.

                  Preparing... ########################################### [100%]
                  1:fglrx64_7_1_0_SUSE102 ########################################### [100%]
                  /usr/src/kernel-modules/fglrx /
                  rm: cannot remove `Modules.symvers': No such file or directory
                  rm: cannot remove `*.o': No such file or directory
                  rm: cannot remove `*.ko': No such file or directory
                  rm: cannot remove `*.mod.*': No such file or directory
                  make: Entering directory `/usr/src/linux-2.6.18.2-34-obj/x86_64/default'
                  make -C ../../../linux-2.6.18.2-34 O=../linux-2.6.18.2-34-obj/x86_64/default
                  LD /usr/src/kernel-modules/fglrx/built-in.o
                  CC [M] /usr/src/kernel-modules/fglrx/firegl_public.o
                  /usr/src/kernel-modules/fglrx/firegl_public.c: In function ‘fglrx_pci_suspend’:
                  /usr/src/kernel-modules/fglrx/firegl_public.c:799: warning: passing argument 1 of ‘firegl_pci_save_state’ from incompatible pointer type
                  /usr/src/kernel-modules/fglrx/firegl_public.c: In function ‘fglrx_pci_resume’:
                  /usr/src/kernel-modules/fglrx/firegl_public.c:838: warning: passing argument 1 of ‘firegl_pci_restore_state’ from incompatible pointer type
                  /usr/src/kernel-modules/fglrx/firegl_public.c: In function ‘firegl_put_user_ptr’:
                  /usr/src/kernel-modules/fglrx/firegl_public.c:1617: warning: cast from pointer to integer of different size
                  /usr/src/kernel-modules/fglrx/firegl_public.c:1617: warning: cast from pointer to integer of different size
                  /usr/src/kernel-modules/fglrx/firegl_public.c:1617: warning: cast from pointer to integer of different size
                  /usr/src/kernel-modules/fglrx/firegl_public.c:1617: warning: cast from pointer to integer of different size
                  /usr/src/kernel-modules/fglrx/firegl_public.c: In function ‘__ke_unregister_ioctl32_conversion’:
                  /usr/src/kernel-modules/fglrx/firegl_public.c:2982: warning: ‘return’ with a value, in function returning void
                  /usr/src/kernel-modules/fglrx/firegl_public.c: In function ‘KAS_SlabCache_Initialize’:
                  /usr/src/kernel-modules/fglrx/firegl_public.c:5477: warning: cast from pointer to integer of different size
                  LD [M] /usr/src/kernel-modules/fglrx/fglrx.o
                  Building modules, stage 2.
                  MODPOST
                  WARNING: could not find /usr/src/kernel-modules/fglrx/.libfglrx_ip.a.GCC4.cmd for /usr/src/kernel-modules/fglrx/libfglrx_ip.a.GCC4
                  CC /usr/src/kernel-modules/fglrx/fglrx.mod.o
                  LD [M] /usr/src/kernel-modules/fglrx/fglrx.ko
                  make: Leaving directory `/usr/src/linux-2.6.18.2-34-obj/x86_64/default'
                  make: Entering directory `/usr/src/linux-2.6.18.2-34-obj/x86_64/default'
                  make -C ../../../linux-2.6.18.2-34 O=../linux-2.6.18.2-34-obj/x86_64/default modules_install
                  INSTALL /usr/src/kernel-modules/fglrx/fglrx.ko
                  DEPMOD 2.6.18.2-34-default
                  make: Leaving directory `/usr/src/linux-2.6.18.2-34-obj/x86_64/default'
                  /

                  ************************************************** ***********
                  Please read "/usr/share/doc/packages/fglrx/README.SuSE" for
                  configuration details when using SaX2.
                  ************************************************** ***********

                  Comment


                  • #29
                    for what i've learned the board works flawless with gentoo 2.6.22 xorg7.2 xorg-server-1.3. i have tested it and works pretty well. there are only some minor issues with compiz, but that's normal.
                    the driver used is the 8.433. also the newest one should run well.
                    also for what i know opensuse has a direct ati repository in yast. try that one, or generate a package for the opensuse version.
                    after that add these options:

                    Section "Device"
                    BoardName "Radeon <identified by sax2>"
                    BusID "<identified by sax2>"
                    Driver "fglrx"
                    Identifier "Device[0]"
                    VendorName "<identified by sax2>"
                    Option "AllowGLXWithComposite" "true"
                    Option "BackingStore" "true"
                    Option "BlockSignalsOnLock" "on"
                    Option "Capabilities" "0x00000000"
                    Option "CapabilitiesEx" "0x00000000"
                    Option "CenterMode" "off"
                    Option "DisableOvScaler" "no"
                    Option "DRI" "true"
                    Option "EnableDepthMoves" "yes"
                    Option "EnableHPV" "yes"
                    Option "EnableOpaqueOverlayVisual" "yes"
                    Option "EnablePageFlip" "true"
                    Option "EnablePrivateBackZ" "no"
                    Option "ForceGenericCPU" "no"
                    Option "GammaCorrectionI" "0x06419064"
                    Option "GammaCorrectionII" "0x06419064"
                    Option "HWCursor" "On"
                    Option "KernelModuleParm" "locked-userpages=0"
                    Option "mtrr" "off"
                    Option "no_accel" "no"
                    Option "no_dri" "no"
                    Option "OpenGLOverlay" "off"
                    Option "PseudoColorVisuals" "off"
                    Option "RenderAccel" "true"
                    Option "ScreenOverlap" "0"
                    Option "Stereo" "off"
                    Option "StereoSyncEnable" "1"
                    Option "SubPixelOrder" "none"
                    Option "TexturedXrender" "true"
                    Option "UseFastTLS" "0"
                    Option "UseInternalAGPGART" "no"
                    Option "VideoOverlay" "on"
                    Option "XAANoOffscreenPixmaps" "true"
                    Option "FSAAEnable" "no"
                    Option "FSAACustomizeMSPos" "no"
                    Option "FSAADisableGamma" "no"
                    Option "FSAAMSPosX0" "0.000000"
                    Option "FSAAMSPosX1" "0.000000"
                    Option "FSAAMSPosX2" "0.000000"
                    Option "FSAAMSPosX3" "0.000000"
                    Option "FSAAMSPosX4" "0.000000"
                    Option "FSAAMSPosX5" "0.000000"
                    Option "FSAAMSPosY0" "0.000000"
                    Option "FSAAMSPosY1" "0.000000"
                    Option "FSAAMSPosY2" "0.000000"
                    Option "FSAAMSPosY3" "0.000000"
                    Option "FSAAMSPosY4" "0.000000"
                    Option "FSAAMSPosY5" "0.000000"
                    Option "FSAAScale" "1"
                    EndSection

                    Section "DRI"
                    Group "video"
                    Mode 0660
                    EndSection

                    Section "Extensions"
                    Option "DAMAGE" "true"
                    Option "RENDER" "true"
                    Option "Composite" "Enable"
                    EndSection

                    Section "Module"
                    Load "dbe"
                    Load "type1"
                    Load "freetype"
                    Load "extmod"
                    Load "glx"
                    Load "v4l"
                    Load "dri"
                    EndSection

                    Section "ServerFlags"
                    Option "AllowMouseOpenFail" "on"
                    Option "IgnoreABI" "on"
                    Option "AIGLX" "on"
                    EndSection
                    see the monitor options comments.
                    Section "Monitor"
                    Option "CalcAlgorithm" "XServerPool"
                    DisplaySize 331 207 <this should have been detected by sax2 so use that option>
                    HorizSync 30-62 <also use sax2 option>
                    Identifier "Monitor[0]"
                    ModelName "<put your monitor name here>"
                    Option "DPMS"
                    VendorName "SEC"
                    VertRefresh 43-60 <use sax2 detection>
                    UseModes "Modes[0]"
                    EndSection

                    Section "Modes"
                    Identifier "Modes[0]"
                    EndSection
                    use sax2 modes instead of these. they should look like the following.
                    Section "Screen"
                    DefaultDepth 24
                    SubSection "Display"
                    Depth 15
                    Modes "1280x800" "1280x768" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
                    EndSubSection
                    SubSection "Display"
                    Depth 16
                    Modes "1280x800" "1280x768" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
                    EndSubSection
                    SubSection "Display"
                    Depth 24
                    Modes "1280x800" "1280x768" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
                    EndSubSection
                    SubSection "Display"
                    Depth 8
                    Modes "1280x800" "1280x768" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
                    EndSubSection
                    Device "Device[0]"
                    Identifier "Screen[0]"
                    Monitor "Monitor[0]"
                    EndSection
                    i'm sure that these options work with the board. if you happen to have problems use the packages that i've indicated:
                    fglrx 8.433 (catalyst 7.11)
                    xorg 7.2 (latest present in opensuse repos)
                    xorg-server 1.3 (latest present in opensuse repositories should do)
                    kernel 2.6.22 (use one kernel of your choice from the 2.6.22 ones)
                    libstdc++v3 (this is very important and without the driver should not work)
                    fontconfig (use at least 2.4.2)
                    freetype (use at least the 2.3 version)

                    when you generate the package for opensuse then you won't have to install the also the kernel sources.
                    after generating the rpm do a rpm -iuVh --force <package>.rpm && init 6 and digit startlevel 3 as an option for grub when starting.
                    once in level 3 login as root and start sax2 (after having modified the xorg.conf options) and see if sax2 starts its xvideo server. if so, then hit modify and you should see the 3d enabled. adjust the monitor if you haven't done it manually and test the configuration. it it works exit sax2, open /etc/X11/xorg.conf manually in your favourite text editor and see if the options were mantained. then do a init 5 and you should be able to use at its full your new board.

                    Comment


                    • #30
                      Thank you

                      I really appreciate your response. I will give it a try, and hopefully all goes well. At least there's light at the end of the tunnel.

                      Comment

                      Working...
                      X