Announcement

Collapse
No announcement yet.

AMD Catalyst 12.12 For Linux Released

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • AMD Catalyst 12.12 For Linux Released

    Phoronix: AMD Catalyst 12.12 For Linux Released

    AMD released the Catalyst 12.12 Linux graphics driver for those still reliant upon their binary blob for Radeon/FirePro graphics card support...

    http://www.phoronix.com/vr.php?view=MTI1MDI

  • #2
    and still no sighn of a new legacy driver...

    Comment


    • #3
      Misleading title is misleading.

      Comment


      • #4
        The embedded drivers are usually shit. Better use the Catalyst 12.11 Beta 11.

        Comment


        • #5
          In case of using xvba - don't use anything from the 12.11bX stream. It is broken for Level51@high with 16 Reframes and drops one frame every second for every other H264 Level.

          Stay with 12.10 and if you need xorg 1.13 support choose the 12.9Quantal.

          Comment


          • #6
            Anything about hybrid graphics? From what I heard anything above 12.8 is broken in this regard.

            Comment


            • #7
              I wondering why Michael doesn't mention new AMD forum for bugreports by Steam users: http://devgurus.amd.com/community/steam-linux.
              Last edited by RussianNeuroMancer; 12-12-2012, 06:02 PM.

              Comment


              • #8
                AMD Catalyst in one single post:

                1) you're lucky if you are able to install the driver and make it actually work after first reboot
                2) you don't suffer a kernel panic within 1 day without doing anything special
                3) you don't have issues with WINE
                4) you don't suffer a freeze while watching some bullshit videos with VLC or whatever
                5) get the list continued..

                Comment


                • #9
                  It would be much nicer when fglrx devs would look at public forums to get bug reports instead of ignoring everything written on the net that does not have got a bug ticket in their own system.

                  Comment


                  • #10
                    anyone else having catalyst say that its version 12.9 after installing? I tried the old trick of stopping x and deleting /etc/ati/amdpcsdb and then restarting X, but that didn't work. Tried installing it again, that didn't work either. Its weird since before this I was on 12.11 beta and before that I was on 12.10

                    Comment


                    • #11
                      Originally posted by bulletxt View Post
                      AMD Catalyst in one single post:

                      1) you're lucky if you are able to install the driver and make it actually work after first reboot
                      2) you don't suffer a kernel panic within 1 day without doing anything special
                      3) you don't have issues with WINE
                      4) you don't suffer a freeze while watching some bullshit videos with VLC or whatever
                      5) get the list continued..
                      Dunno but haven't faced any of 1 to 4. Earlier I was on Catalyst 12.4. Now on Catalyst 12.10. Team Fortress 2 also runs fine.

                      WINE doesn't count anyway.

                      Comment


                      • #12
                        Anyone knows if it works OK with Trinity APUs ?

                        I'm on the verge of building my 1st non-Intel rig , a kinda of "gaming HTPC" with a A10-5700 or A10-5800K and i'm wondering if i regret it....


                        TIA,
                        AJSB

                        Comment


                        • #13
                          Originally posted by Bullet500 View Post
                          Dunno but haven't faced any of 1 to 4. Earlier I was on Catalyst 12.4. Now on Catalyst 12.10. Team Fortress 2 also runs fine.

                          WINE doesn't count anyway.
                          Welcome to the Phoronix forums, remember not to feed the trolls ;-)

                          Comment


                          • #14
                            Originally posted by AJSB View Post
                            Anyone knows if it works OK with Trinity APUs ?

                            I'm on the verge of building my 1st non-Intel rig , a kinda of "gaming HTPC" with a A10-5700 or A10-5800K and i'm wondering if i regret it....


                            TIA,
                            AJSB
                            I have A8-3870K (Llano), and I can say Catalyst improved a lot since 12.4 when I bought it. With 12.4, suspend didn't work and I had random kernel panics. Now I'm using 12.10, and it works just fine. Performance in GNOME 3 is not very good, but KDE runs just perfectly smooth with all the effects. Haven't tried 12.12 yet, and remember, Trinity are much faster than Llano.

                            Comment


                            • #15
                              Originally posted by Kano View Post
                              It would be much nicer when fglrx devs would look at public forums
                              Instead of working on bugs that already reported? Remember, resources is limited and time is resource too.

                              Comment

                              Working...
                              X