Announcement

Collapse
No announcement yet.

ATI fglrx 8.30.3 Display Drivers

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #31
    Never used these fandangle upload websites before, but in response, here are the download links.

    http://rapidshare.com/files/2991348/...8-1.fc6.tar.gz
    http://rapidshare.com/files/2990829/...8-1.fc6.tar.gz
    http://rapidshare.com/files/2989366/...Working.tar.gz
    http://rapidshare.com/files/2999655/...Working.tar.gz

    You should be able to install the drivers fine with the file base or use the RPMS.

    Comment


    • #32
      lxgears
      Xlib: extension "XFree86-DRI" missing on display ":0.0".
      2517 frames in 5.1 seconds = 489.644 FPS
      2938 frames in 5.1 seconds = 580.666 FPS
      2938 frames in 5.1 seconds = 580.309 FPS

      damn, doesn't work....
      --------------------------------------------------------
      # Xorg configuration created by system-config-display

      Section "ServerLayout"
      Identifier "single head configuration"
      Screen 0 "Screen0" 0 0
      InputDevice "Keyboard0" "CoreKeyboard"
      EndSection

      Section "InputDevice"
      Identifier "Keyboard0"
      Driver "kbd"
      Option "XkbModel" "pc105"
      Option "XkbLayout" "us"
      EndSection

      Section "Monitor"

      ### Comment all HorizSync and VertSync values to use DDC:
      ### Comment all HorizSync and VertSync values to use DDC:
      Identifier "Monitor0"
      ModelName "Monitor 1600x1200"
      ### Comment all HorizSync and VertSync values to use DDC:
      HorizSync 31.5 - 94.0
      VertRefresh 50.0 - 90.0
      Option "dpms"
      EndSection

      Section "Device"
      Identifier "Videocard0"
      Driver "fglrx"
      EndSection

      Section "Screen"
      Identifier "Screen0"
      Device "Videocard0"
      Monitor "Monitor0"
      DefaultDepth 24
      SubSection "Display"
      Viewport 0 0
      Depth 24
      EndSubSection
      EndSection
      --------------------------------------------------------
      glxinfo:

      name of display: :0.0
      display: :0 screen: 0
      direct rendering: No
      server glx vendor string: SGI
      server glx version string: 1.2


      What is wrong?
      Last edited by liko; 11-12-2006, 12:30 PM.

      Comment


      • #33
        Did you use the RPMS or the Installer? If you used the Installer, did you run "aticonfig --initial" immediatly after the Installer ended? If you used the RPMS, try running "aticonfig --initial". Don't forget to Reboot, rather then just restarting X.
        Last edited by EastonRoyce; 11-12-2006, 05:36 PM.

        Comment


        • #34
          Doesnt work either...Aditionaly:
          [root@kk liko]# init 3
          bash: init: command not found
          WTF??

          Comment


          • #35
            Originally posted by liko View Post
            Doesnt work either...Aditionaly:
            [root@kk liko]# init 3
            bash: init: command not found
            WTF??
            When you switch to root, instead of typing just "su" type "su -" (thats, su<space><hyphen>) You will then find the "init" command available to you.

            Comment


            • #36
              shinytoaster:
              > /lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:89:26: error: linux/config.h: No such file or directory
              Do you have the kernel-headers package installed? Check if you have a /usr/linux folder.

              liko:
              Try adding this in your xorg.conf:
              ~ Section "Extensions"
              ~ Option "Composite" "Disable"
              ~ EndSection
              If you're using FC6, the fglrx-unsupported composite extension is enabled by default, and that's why you don't get DRI. After that, reboot and it should work.
              Last edited by amenzix; 11-17-2006, 10:14 AM. Reason: ( added the last paragraph )

              Comment

              Working...
              X