Announcement

Collapse
No announcement yet.

AMD 8.41.7 PCI ID hack [For Unsupported FireGL Cards]

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • AMD 8.41.7 PCI ID hack [For Unsupported FireGL Cards]

    I just couldn't wait to test the new driver on my Thinkpad T60p, so I made a really ugly hack to make the driver run even on my card (FireGL V5200). To hack it:
    - Extract the driver using "sh ati-driver-installer-8.41.7-x86.x86_64.run --extract"
    - Go inside the fglrx-install.* folder
    - Apply my patch using "patch -p1 < ~/ati-hack.patch" (http://xtruder.homelinux.net/~ambro/ati-hack.patch)
    - Set HACK_PCIID to the PCI ID of YOUR card in common/lib/modules/fglrx/build_mod/firegl_public.c
    - Install the driver using "./ati-installer.sh 8.41.7 --install"
    - After you have set up your xorg.conf, make the driver treat your card as a SIMILAR card with a different PCI ID - add to your Device section: ChipID 0x71c5 (or whatever the ID of the most similar card is)

  • #2
    And now the results: the driver loads properly, however 2D is even slower than previous drivers, windows sometimes freeze for a short time when being resized. 3D basically works, glxgears runs at the same fps as previous drivers. Also, Quake3 runs, however there is a small but noticable latency problem and the brightness slider doesn't work anymore and the image is too dark. Haven't tried anything more complex so far. Also, there is an "Unsupported hardware" watermark. XV works, but I still have diagonal image tearing.

    Comment


    • #3
      Interesting. You might want to replace the /etc/ati/control file by an older one.

      Comment


      • #4
        Thanks for the advice, Kano. That removed the watermark. I would also like to say that 2D was slower becouse I didn't add some options to the driver (previous versions have that problem too):
        Code:
                Option      "XAANoOffscreenPixmaps"
                Option      "VideoOverlay" "on"
                Option      "OpenGLOverlay" "off"

        Comment


        • #5
          Thanks for that. I'm going to give it a go.

          I have a T60 running RHEL5 and find that

          - compiz-fusion/Xgl works quite well on a SINGLE screen as long as you don't expect suspend/resume to work
          - Either a) Dual screens OR b) suspend resume will work in non-Xgl mode --not both

          This was with the .40 driver, so really want the .42, but I'll try .41 for now. Am getting fed up of the suspend hangs.

          Comment


          • #6
            Oh, not good. Suspend is fine. On resume the screen is blank.

            Comment


            • #7
              This actually helped me figure out my slow 2D redraw times using the latest driver, 8.44.3. I'm running openSuSE 10.3 with an ATI FireGL V5200. What seemed to make the difference for me was adding:

              Code:
                      Option      "XAANoOffscreenPixmaps"
              It was very strange, because DRI worked fine from the start. fgl_glxgears and glxgears both produced good frame rates. But moving windows around and resizing them was very slow. That seemed to fix it.

              Here's my entire xorg.conf file:

              Code:
              # /.../
              # SaX generated X11 config file
              # Created on: 2008-01-28T19:40:53-0500.
              #
              # Version: 8.1
              # Contact: Marcus Schaefer <sax@suse.de>, 2005
              # Contact: SaX-User list <https://lists.berlios.de/mailman/listinfo/sax-users>
              #
              # Automatically generated by [ISaX] (8.1)
              # PLEASE DO NOT EDIT THIS FILE!
              #
              
              Section "Files"
                FontPath     "/usr/share/fonts/misc:unscaled"
                FontPath     "/usr/share/fonts/local"
                FontPath     "/usr/share/fonts/75dpi:unscaled"
                FontPath     "/usr/share/fonts/100dpi:unscaled"
                FontPath     "/usr/share/fonts/Type1"
                FontPath     "/usr/share/fonts/URW"
                FontPath     "/usr/share/fonts/Speedo"
                FontPath     "/usr/share/fonts/PEX"
                FontPath     "/usr/share/fonts/cyrillic"
                FontPath     "/usr/share/fonts/latin2/misc:unscaled"
                FontPath     "/usr/share/fonts/latin2/75dpi:unscaled"
                FontPath     "/usr/share/fonts/latin2/100dpi:unscaled"
                FontPath     "/usr/share/fonts/latin2/Type1"
                FontPath     "/usr/share/fonts/latin7/75dpi:unscaled"
                FontPath     "/usr/share/fonts/baekmuk:unscaled"
                FontPath     "/usr/share/fonts/japanese:unscaled"
                FontPath     "/usr/share/fonts/kwintv"
                FontPath     "/usr/share/fonts/truetype"
                FontPath     "/usr/share/fonts/uni:unscaled"
                FontPath     "/usr/share/fonts/CID"
                FontPath     "/usr/share/fonts/ucs/misc:unscaled"
                FontPath     "/usr/share/fonts/ucs/75dpi:unscaled"
                FontPath     "/usr/share/fonts/ucs/100dpi:unscaled"
                FontPath     "/usr/share/fonts/hellas/misc:unscaled"
                FontPath     "/usr/share/fonts/hellas/75dpi:unscaled"
                FontPath     "/usr/share/fonts/hellas/100dpi:unscaled"
                FontPath     "/usr/share/fonts/hellas/Type1"
                FontPath     "/usr/share/fonts/misc/sgi:unscaled"
                FontPath     "/usr/share/fonts/xtest"
                FontPath     "/opt/kde3/share/fonts"
                InputDevices "/dev/gpmdata"
                InputDevices "/dev/input/mice"
              EndSection
              
              Section "ServerFlags"
                Option       "AllowMouseOpenFail" "on"
                Option       "IgnoreABI" "on"
              EndSection
              
              Section "Module"
                Load         "dbe"
                Load         "type1"
                Load         "freetype"
                Load         "extmod"
                Load         "glx"
                Load         "dri"
              EndSection
              
              Section "InputDevice"
                Driver       "kbd"
                Identifier   "Keyboard[0]"
                Option       "Protocol" "Standard"
                Option       "XkbLayout" "us"
                Option       "XkbModel" "microsoftpro"
                Option       "XkbRules" "xfree86"
              EndSection
              
              
              Section "InputDevice"
                Driver       "mouse"
                Identifier   "Mouse[1]"
                Option       "Buttons" "5"
                Option       "Device" "/dev/input/mice"
                Option       "Name" "ImPS/2 Logitech Wheel Mouse"
                Option       "Protocol" "explorerps/2"
                Option       "Vendor" "Sysp"
                Option       "ZAxisMapping" "4 5"
              EndSection
              
              
              Section "Monitor"
                Option       "CalcAlgorithm" "XServerPool"
                DisplaySize  518 324
                HorizSync    30-80
                Identifier   "Monitor[0]"
                ModelName    "ACER AL2416W"
                Option       "DPMS" "true"
                VendorName   "ACR"
                VertRefresh  43-75
                UseModes     "Modes[0]"
              EndSection
              
              
              Section "Modes"
                Identifier   "Modes[0]"
                Modeline 	"1920x1200" 154 1920 1968 2000 2080 1200 1203 1209 1235 -hsync +vsync
              EndSection
              
              
              Section "Screen"
                DefaultDepth 24
                SubSection "Display"
                  Depth      15
                  Modes      "1920x1200" "1280x1024" "1280x960" "1152x864" "1024x768" "800x600" 
                EndSubSection
                SubSection "Display"
                  Depth      16
                  Modes      "1920x1200" "1280x1024" "1280x960" "1152x864" "1024x768" "800x600" 
                EndSubSection
                SubSection "Display"
                  Depth      24
                  Modes      "1920x1200" "1280x1024" "1280x960" "1152x864" "1024x768" "800x600" 
                EndSubSection
                SubSection "Display"
                  Depth      8
                  Modes      "1920x1200" "1280x1024" "1280x960" "1152x864" "1024x768" "800x600" 
                EndSubSection
                Device       "Device[0]"
                Identifier   "Screen[0]"
                Monitor      "Monitor[0]"
              EndSection
              
              
              Section "Device"
                BoardName    "ATI FireGL V5200 (RV530 71DA)"
                BusID        "64:0:0"
                Driver       "fglrx"
                Identifier   "Device[0]"
                Option       "FSAADisableGamma" "no"
                Option       "CapabilitiesEx" "0x00000000"
                Option       "CenterMode" "off"
                Option       "FSAAMSPosX3" "0.000000"
                Option       "FSAAMSPosX4" "0.000000"
                Option       "mtrr" "off"
                Option       "FSAAMSPosY1" "0.000000"
                Option       "FSAAScale" "1"
                Option       "FSAAMSPosY2" "0.000000"
                Option       "FSAAMSPosX5" "0.000000"
                Option       "ForceGenericCPU" "no"
                Option       "GammaCorrectionI" "0x00000000"
                Option       "FSAAMSPosX0" "0.000000"
                Option       "FSAAMSPosY3" "0.000000"
                Option       "FSAAMSPosY4" "0.000000"
                Option       "no_accel" "no"
                Option       "FSAACustomizeMSPos" "no"
                Option       "FSAAMSPosY5" "0.000000"
                Option       "UseFastTLS" "0"
                Option       "GammaCorrectionII" "0x00000000"
                Option       "BlockSignalsOnLock" "on"
                Option       "FSAAEnable" "no"
                Option       "KernelModuleParm" "locked-userpages=0"
                Option       "Capabilities" "0x00000000"
                Option       "VideoOverlay" "on"
                Option       "no_dri" "no"
                Option       "StereoSyncEnable" "1"
                Option       "PseudoColorVisuals" "off"
                Option       "UseInternalAGPGART" "no"
                Option       "FSAAMSPosX1" "0.000000"
                Option       "Stereo" "off"
                Option       "FSAAMSPosX2" "0.000000"
                Option       "OpenGLOverlay" "off"
                Option       "FSAAMSPosY0" "0.000000"
                Option       "ScreenOverlap" "0"
                Option       "XAANoOffscreenPixmaps"
                VendorName   "ATI"
              EndSection
              
              
              
              Section "ServerLayout"
                Identifier   "Layout[all]"
                InputDevice  "Keyboard[0]" "CoreKeyboard"
                InputDevice  "Mouse[1]" "CorePointer"
                Option       "Clone" "off"
                Option       "Xinerama" "off"
                Screen       "Screen[0]"
              EndSection
              
              
              Section "DRI"
                  Group      "video"
                  Mode       0660
              EndSection
              
              Section "Extensions"
                Option       "DAMAGE" "false"
              EndSection
              Last edited by churnd; 01-29-2008, 05:09 PM.

              Comment


              • #8
                Originally posted by ambro814 View Post
                And now the results: the driver loads properly, however 2D is even slower than previous drivers, windows sometimes freeze for a short time when being resized. 3D basically works, glxgears runs at the same fps as previous drivers. Also, Quake3 runs, however there is a small but noticable latency problem and the brightness slider doesn't work anymore and the image is too dark. Haven't tried anything more complex so far. Also, there is an "Unsupported hardware" watermark. XV works, but I still have diagonal image tearing.
                You say the 2D is even slower than previous drivers but i was just wondering how slow Public Liability Insurance for Builder actually is and whether this slower makes it diffcult??

                you say that the 3d basically works which is good but have you tried any of the more complex stuff??
                Last edited by nathan3011; 04-21-2009, 10:45 AM.

                Comment


                • #9
                  you bothered looking at the date when this was posted?

                  Comment

                  Working...
                  X