Announcement

Collapse
No announcement yet.

AMD 8.41.7 Display Driver Released -- The Holy Crap Edition!

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Originally posted by Alistair View Post
    Please add your name to bug 780 on the ati unofficial bugzilla which documents the PCIE chips on AGP cards not enabling AGP modes.

    http://ati.cchtml.com/show_bug.cgi?id=780
    I keep hearing you say that, but Could you give me some pointers to where I can find more info on it?

    Comment


    • Originally posted by d2kx View Post
      tsarig,

      we had that.

      AMD said "don't install it on R500 and under". You didn't hear. AMD said "8.41s focus is R600, 8.42 will focus on older cards". You didn't hear. You are talking about the driver not working. It works.
      d2kx, let's say you bought a new card, spending xxx $ just to find out it's working at 1/8 of it's power, and the manufacturer just don't care about that, for months..

      that's what I've ment to say, I don't care about not getting the latest drivers to work. good for you if you got it working, your're a lucky man.

      besides, I'm not the only one who have troubles with the agp/pcie gate.

      Originally Posted by Alistair:
      Please add your name to bug 780 on the ati unofficial bugzilla which documents the PCIE chips on AGP cards not enabling AGP modes.

      http://ati.cchtml.com/show_bug.cgi?id=780

      and d2kx, people are posting here to help each other, if you rather lecture people than help them so dont post!
      Last edited by tsarig; 09-15-2007, 02:55 PM.

      Comment


      • Originally posted by adamk View Post
        You downloaded and installed a driver that specifically wasn't designed for your video card. Sounds like a jackkerouac failure, to me.

        Adam
        And Adam - I'm afraid you actually misunderstand the following alert :

        Caution: The ATI Catalyst™ Linux software suite 8.41.7 does not support ATI Workstation products. AMD recommends using the AMD Proprietary Linux software driver version 8.40.4.
        This warning is directed at FireGL workstation products which the X1650Pro is not.

        Nor does the X1650Pro AGP fit in the

        Caution: The AMD Proprietary Linux driver version 8.41.7 is not recommended for the ATI Mobility and Integrated Products. Using this driver on any of the following products may result in stability issues. AMD recommends using the AMD Proprietary Linux software driver version 8.40.4.
        Warning -- it is not Mobility nor an Integrated chip


        Final point - the last caveat on ATI's release notes:

        Caution: The AMD Proprietary Linux driver version 8.41.7 is not recommended for use on ATI Radeon X1900 series of products and lower. Using this driver on any of the following products may result in stability issues. AMD recommends using the AMD Proprietary Linux driver version 8.40.4
        Its clear that this is not a "does not support this card" - it is indicating that there are issues - only that.
        Last edited by Alistair; 09-15-2007, 08:50 PM. Reason: Cleanup after being rushed on the last post

        Comment


        • Btw. everybody can try now the driver even in live mode with ease on Kanotix Thorhammer, just add

          fglrx

          as option. To use Xorg's detection for the monitor (usually better than the default), use

          screen=auto

          especially usefull for tft. Of course you can use

          nvidia

          as option too. You just need more time for fglrx as the dl is 50 mb compared to 10 mb... Wine 0.9.45 is included. To test older fglrx use something like:

          fglrx=8.39.4

          btw. it autoselects the correct one for any ati card, even dx8 ones. Nothing hurts your hd installs - of course you could install too...

          Comment


          • Originally posted by jackkerouac View Post
            Mine's an X1650 Pro AGP and X dies after the install. Yet another AMD/ATI failure.
            There are known issues with X1000 series cards, and I've found this card is problematic with ***all*** ati drivers - the issue (black screen on X start requiring a restart of X or on occaision a reboot) is resolved when setting the GART memory size in the BIOS = to or greater than the amount of ram on the video card.

            I have one of these cards, and have gotten it to run X with DRI enabled, and glxgears and fgl_glxgears will run - however AGP mode 0 prevents any real 3d processing and even substantially slows 2d operations.

            Comment


            • Well didn't you know that you have to buy a new board with PCI-E

              Comment


              • When it says _64, does it mean my laptop (32) cannot use it?

                Comment


                • That only means that ATI uses a combined package for both, NV uses two different ones.

                  Comment


                  • Originally posted by Kano View Post
                    Well didn't you know that you have to buy a new board with PCI-E
                    I'll get right on that -- new motherboard, ram, and I'll break out the soldering kit and put that video chip on a PCIe bus

                    Comment


                    • I tried the 8.41.7 driver using Kanotix ThorHammer rc6 developed by Kano, it works fine with my Desktops ATI-1300 pro pcie, this card has 512mb of ram.
                      graphics card.
                      This is the first time that card has worked in Linux with ATI drivers, congratulations to the ATI-AMD team who finally got a driver to work with my card.

                      Comment

                      Working...
                      X