Announcement

Collapse
No announcement yet.

AMD 8.41.7 Display Driver Released -- The Holy Crap Edition!

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • No joy here with my X1950XTX and Ubuntu Gutsy (7.10 - Tribe 5). Install runs to completion, but on reboot the screen refresh is not correct and resists resetting. I either get a skewed presentation and the images are all repeated about four times across the width of the display or Gutsy dumps me into the failsafe settings screen, but that wont let me correct the monitor config nor will it allow selection of the FGLRX driver.

    You say there is a problem with Xorg 7.3?

    Comment


    • Working here on Mandriva 2007.1 32 bit Mandriva's rpm script is broken but the ati installer worked fine.glxgears went from 3k to over 8k fgl_glxgears went from 1300 to 1800.

      Fonts look much crisper, UT2K4 i is smoother faster and looks great... haven't had a chance to do much else tonite.

      Nice job ATI.. Congrats M Tippet and co !
      Those who would give up Essential Liberty to purchase a little Temporary Safety,deserve neither Liberty nor Safety.
      Ben Franklin 1755

      Comment


      • Can someone post an xorg.conf that actually works? I'm still stuck at a black screen when I let aticonfig --initial set up my xorg.conf.

        I wish it were as simple as envy -g :'(

        Comment


        • Originally posted by mjordan View Post
          Can someone post an xorg.conf that actually works? I'm still stuck at a black screen when I let aticonfig --initial set up my xorg.conf.

          I wish it were as simple as envy -g :'(
          Here's mine. It might not be the best one, but it works (for me, I assume it depends on your xorg version).

          Code:
          # Xorg configuration created by system-config-display
          
          Section "ServerLayout"
          	Identifier     "single head configuration"
          	Screen      0  "aticonfig-Screen[0]" 0 0
          	InputDevice    "Keyboard0" "CoreKeyboard"
          EndSection
          
          Section "Files"
          EndSection
          
          Section "Module"
          	Load  "dbe"
          	Load  "fbdevhw"
          	Load  "record"
          	Load  "freetype"
          	Load  "type1"
          	Load  "dri"
          	Load  "glx"
          	Load  "extmod"
          EndSection
          
          Section "InputDevice"
          	Identifier  "Keyboard0"
          	Driver      "kbd"
          	Option	    "XkbModel" "pc105"
          	Option	    "XkbLayout" "fi"
          EndSection
          
          Section "Monitor"
          	Identifier   "aticonfig-Monitor[0]"
          	Option	    "VendorName" "ATI Proprietary Driver"
          	Option	    "ModelName" "Generic Autodetecting Monitor"
          	Option	    "DPMS" "true"
          EndSection
          
          Section "Device"
          	Identifier  "aticonfig-Device[0]"
          	Driver      "fglrx"
          	Option	    "XAANoOffscreenPixmaps"
          	Option	    "UseInternalAGPGART" "yes"
          	Option	    "VideoOverlay" "on"
          EndSection
          
          Section "Screen"
          	Identifier "aticonfig-Screen[0]"
          	Device     "aticonfig-Device[0]"
          	Monitor    "aticonfig-Monitor[0]"
          	DefaultDepth     24
          	SubSection "Display"
          		Viewport   0 0
          		Depth     24
          		Modes    "1024x768" "800x600" "640x480"
          	EndSubSection
          EndSection
          
          Section "DRI"
          	Group        0
          	Mode         0666
          EndSection
          
          Section "Extensions"
          	Option	    "Composite" "Disable"
          EndSection

          Comment


          • Hmm, well I give up.. I'm running Xorg 7.2 so that's not the issue... just can't get past the black screen..... guess I'll go back to VESA for now.

            Comment


            • Tried the new driver on Kubuntu 7.04 (Xorg 7.2) with the X1950XTX. Install proceeded to completion, X started, initial impression is quite good.

              The KDE control panel lists the loaded driver as ATI Radeon fbdev. There is an entry for ATI Radeon fglrx, but selecting that results in the blinking cursor of indecision when I restart X. Correcting that required the ritual "dpkg-reconfigure xserver-xorg" dance, and that got me back to the ATI Radeon fbdev driver. The ATI Catylist Control Center, OTHO, says driver version 8.41.7. Is fbdev in fact the correct driver?

              Checking the configuration with fglrxinfo returned the following error:

              fglrxinfo: error while loading shared libraries: libGL.so.1: cannot open shared object file: No such file or directory
              In fact, trying any GL related action returned that error. There is a /usr/lib/libGL.so.1.2 on the system and making a symlink with that to the missing file takes care of that.

              Fglrxinfo says:
              display: :0.0 screen: 0
              OpenGL vendor string: ATI Technologies Inc.
              OpenGL renderer string: Radeon X1950 Series
              OpenGL version string: 2.0.6849 Release
              The not-a-benchmark glxgears looses about 1000 fps from the 8.37 drivers (from 11500 to 10500), but I haven't restarted X, yet. What's the routine with the gears inside the spinning cube?
              Last edited by rbmorse; 09-13-2007, 12:55 AM.

              Comment


              • *Sigh*

                I haven't even downloaded and already the tomato throwing has started. I'll probably try it soon though the drive to test it isn't as it was.

                Comment


                • Originally posted by rbmorse View Post
                  Tried the new driver on Kubuntu 7.04 (Xorg 7.2) with the X1950XTX. Install proceeded to completion, X started, initial impression is quite good.

                  The KDE control panel lists the loaded driver as ATI Radeon fbdev. There is an entry for ATI Radeon fglrx, but selecting that results in the blinking cursor of indecision when I restart X. Correcting that required the ritual "dpkg-reconfigure xserver-xorg" dance, and that got me back to the ATI Radeon fbdev driver. The ATI Catylist Control Center, OTHO, says driver version 8.41.7. Is fbdev in fact the correct driver?

                  Checking the configuration with fglrxinfo returned the following error:



                  In fact, trying any GL related action returned that error. There is a /usr/lib/libGL.so.1.2 on the system and making a symlink with that to the missing file takes care of that.

                  Fglrxinfo says:

                  The not-a-benchmark glxgears looses about 1000 fps from the 8.37 drivers (from 11500 to 10500), but I haven't restarted X, yet. What's the routine with the gears inside the spinning cube?
                  Hmmm... Does your xorg.conf actually have the driver listed as fbdev? Thats interesting.

                  Comment


                  • xorg.conf says "fglrx" like it should. Yes, this is interesting. The problem could be KDE's though.

                    A couple of days ago I posted a note indicating that if AMD/ATI was smart they would release this driver as a "beta" version. It sure feels like one.

                    The other problem I noted is one someone else reported...closing an openGL window leaves an artifact...the window. Switching to term and back clears the error.

                    Comment


                    • Yeah and if anyone wants to try and help me figure out my issue, which I doubt, I'll probably have to wait until 8.42, check out my Xorg.0.log:

                      My Xorg log

                      If you have any ideas, feel free to suggest.

                      Just so you know, 8.40 does work.
                      Last edited by Malikith; 09-13-2007, 01:54 AM.

                      Comment

                      Working...
                      X