Announcement

Collapse
No announcement yet.

AMD 8.41.7 Display Driver Released -- The Holy Crap Edition!

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • it seems that the previous post i posted with a link to screenshots is awaiting moderation. well, gl2, x11, gl and xv video outputs work just fine. just set the environment LIBXCB_ALLOW_SLOPPY_LOCK=1, like

    export LIBXCB_ALLOW_SLOPPY_LOCK=1 in .bash_profile, then restart X.

    Comment


    • Just want to let whoever cares know, I have both a X1950GT (256MB) and a X1950Pro (512MB) on AGP and both don't work

      I'm only posting the results here cause some have gotten it to work, whilst others (me) have not. Here is what I get:

      Pro: Blank Image, hardlock nothing works anymore.
      GT: Segfault, as mentioned earlier by someone, output below.

      The Pro actually has only worked with 2 drivers for me so far, and I don't know if that is conciderd to be called 'working'. I'll post a new thread on it however, see what happens.

      (II) LoadModule: "GLcore"
      (II) Loading /usr/lib/xorg/modules/extensions//libGLcore.so
      (II) Module GLcore: vendor="X.Org Foundation"
      compiled for 7.2.0, module version = 1.0.0
      ABI class: X.Org Server Extension, version 0.3
      (II) GLX: Initialized MESA-PROXY GL provider for screen 0

      Backtrace:
      0: /usr/X11R6/bin/X(xf86SigHandler+0x81) [0x80c5d91]
      1: [0xffffe420]
      2: /usr/lib/xorg/modules//glesx.so [0xb5c6ea24]
      3: /usr/lib/xorg/modules//glesx.so [0xb5c6809c]
      4: /usr/lib/xorg/modules//glesx.so [0xb5bfb3fb]
      5: /usr/lib/xorg/modules//glesx.so [0xb5c0d196]
      6: /usr/lib/xorg/modules//glesx.so [0xb5bfa3d9]
      7: /usr/lib/xorg/modules//glesx.so [0xb5c23c12]
      8: /usr/lib/xorg/modules//glesx.so [0xb5c11ebd]
      9: /usr/lib/xorg/modules//glesx.so [0xb5c13469]
      10: /usr/lib/xorg/modules//glesx.so [0xb5b9a6e3]
      11: /usr/lib/xorg/modules//glesx.so [0xb5b8ff88]
      12: /usr/lib/xorg/modules//glesx.so [0xb5b90670]
      13: /usr/lib/xorg/modules//glesx.so(esutInit+0x74) [0xb5b8f484]
      14: /usr/lib/xorg/modules//glesx.so [0xb5b8b17b]
      15: /usr/lib/xorg/modules//glesx.so(GlesxExtensionInit+0x9b) [0xb5b8a3fb]
      16: /usr/X11R6/bin/X(InitExtensions+0xa2) [0x80f4412]
      17: /usr/X11R6/bin/X(main+0x2af) [0x807459f]
      18: /lib/tls/i686/cmov/libc.so.6(__libc_start_main+0xdc) [0xb7d94ebc]
      19: /usr/X11R6/bin/X(FontFileCompleteXLFD+0x1e1) [0x8073ab1]

      Fatal server error:
      Caught signal 11. Server aborting

      Comment


      • Originally posted by zittergie View Post
        Maybe that's why i'm using 8.37

        I heard 8.40 had some issues with googleearth, and that's such a great timekiller.

        Well, If video works fine, planetpinguinracer works fine and googleearth works fine, I'm quite happy.

        I've read something about muped64 along the forums, long time that i used that emu. Will give that a try to see how 3d works out.

        Anyway, this Ati X700 is way much better than my previous laptop that was a SIS760
        There is a fix for the google earth problem. Go to this link and check it out. It fixed my problem.

        Comment


        • Exactly

          Same here:

          Code:
          Backtrace:
          0: /usr/bin/X(xf86SigHandler+0x81) [0x80c8631]
          1: [0xb7f5a420]
          2: /usr/lib/xorg/modules/drivers//fglrx_drv.so(atiddxScreenInit+0x505) [0xb791f725]
          3: /usr/bin/X(AddScreen+0x1ee) [0x80764be]
          4: /usr/bin/X(InitOutput+0x21e) [0x80a7c0e]
          5: /usr/bin/X(main+0x27b) [0x8076c6b]
          6: /lib/libc.so.6(__libc_start_main+0xe0) [0xb7d59050]
          7: /usr/bin/X(FontFileCompleteXLFD+0x1ed) [0x80761c1]
          
          Fatal server error:
          Caught signal 11.  Server aborting

          Comment


          • Originally posted by carpman View Post
            Read this:



            15fps from a driver, yes, thats phenomenal.
            A 42% increase is pretty phenomenal, at least to some people.

            Adam

            Comment


            • Originally posted by zkyez View Post
              well watch the following print screens:

              http://florin.sitnet.ro/ati/

              so you guys that can`t google for 15 seconds, please shut up. opengl output, x11 and xv output, all 3 work without any problems.
              Not for me. XV has the video squeezed to the upper half of the screen, OpenGL fails in MPlayer and in Xine, the video is displayed in the upper left corner of the primary screen.

              Did you really try this on a TV in dual head mode?

              Comment


              • HOWTO: get screen corruption (and fix it)

                1) open firefox
                2) go to a big page (ex: set "show 40 posts per page" in your profile)
                3) scroll up& down all the way really fast
                <corruption>
                4) switch to tty1 (CTRL+ATL+F1) and back (CTRL+ALT+F7) to fix it

                Can anyone else try this and confirm? (especially those who complained about the problem before)

                Comment


                • Just to report that the 8.41.7 works on X1400 Mobility (Ubuntu Feisty). glxgears fps goes up from 2500 to 4800, and I found fps in Sauerbraten improved from 30 to 58.

                  Just one question: fglrxinfo returns a different opengl version number:
                  display: :0.0 screen: 0
                  OpenGL vendor string: ATI Technologies Inc.
                  OpenGL renderer string: ATI Mobility Radeon X1400
                  OpenGL version string: 2.0.6849 Release <--------------- ???
                  Shouldn't it be something like 8.41.7?

                  Comment


                  • 13% better in glxgears in normal mode er.....

                    in GLX-compiz it sucks a lot more than 8.40

                    don't worry, we have an entire mont to think about it.


                    Comment


                    • Originally posted by dickeywang View Post


                      Shouldn't it be something like 8.41.7?
                      It's reporting the OpenGL version, not the Radeon driver version.

                      Comment


                      • But it says 8.40.4 some lines later.

                        Originally posted by Xipeos View Post
                        Am I the only one getting Ultra-Crappy visual quality* with Quake 4?

                        * = almost as good as MDK's

                        EDIT: am I the only one playing quake4?
                        I can confirm these issues. Michael told me he can't, so I thought it's me. It very likely gets fixed with 8.42.

                        Comment


                        • Originally posted by zkyez View Post
                          HINT: GOOGLE FOR

                          export LIBXCB_ALLOW_SLOPPY_LOCK=1
                          --offtopic--

                          That envvar only works if you've applied the proper patch (most likely your distro did). It's better to compile xcb with -DNDEBUG, so you won't have to worry about exporting a var every time.

                          --ontopic--

                          Originally posted by d2kx
                          I can confirm these issues. Michael told me he can't, so I thought it's me. It very likely gets fixed with 8.42.
                          Thanks.

                          Comment


                          • This driver may EVENTUALLY become the bee's knees, but all I'm saying is that I no longer trust this website to give me the straight goods on whether or not it IS right now.

                            This site hyped up this driver like nobody's business and it's really not that great. For some people it works well, for others it works poorly and for the rest it doesn't work at all.

                            I happen to be in the latter category, so my opinion is probably biased. But then again, I'm not complaining so much about this crappy drivers, I'm more complaining about the hype Phoronix generated about the driver, a hype it simply did not (or could not?) live up to.

                            I guess I just expected more from this site. More dispassionate analysis, I guess. And maybe something telling people that unless they were running a 2000 series card, they were going to be screwed this month by ATI.

                            Comment


                            • All those people who get seg faults, have you tried quiting X, then going to a terminal, stoping X, /etc/init.d/x11-common stop, unloading the previous fglrx kernel module, rmmod fglrx, then restarting X?

                              My 8.41 didn't unload the previous driver automatically and seg faulted the first time I switched as well. Some xorg.conf setting will also result in a black screen/ falling back to a terminal. Usually ATI driver updates will screw up on the kernel module, but this just results in 3D being disabled until X is restarted, not X seg faulting.

                              Also, I might have an idea why I didn't see such a big performance increase while many forum members did. I have tweaked my xorg.conf file to have many of the fglrx performance features enabled. Possibly 8.41 has a more liberal default policy? Here is the relevant excerpt:

                              Code:
                              #       ChipID      0x4E44
                                      Option      "AGPMode" "4"
                                      Option      "BusID" "PCI:1:0:0" #vendor=1002,device=4e44
                                      Option      "AGPFastWrite" "True"
                                      Option      "EnablePageFlip" "True"
                                      Option      "FSAAEnable" "on"
                                      Option      "FSAAScale" "4"
                                      Option      "DDCMode" "True"
                                      Option      "DMAForXv" "True"
                                      Option      "VideoOverlay" "on"
                                      Option      "OpenGLOverlay" "off"
                                      Option      "TexturedVideoSync" "off"

                              Comment


                              • Originally posted by opera View Post
                                OMG how much you and people like you disgust me. You nullify peoples issues because they "should have known" that ATI sucks? So then it's Ok to suck, and people should stop complaining?
                                No, whatever history a company has, doesn't make it Ok to give complete crap support to their customers, whatever they say "Linux is small" yada yada.

                                Fuck that BS. Linux is amazingly big for its enormously powerful enemies who actively make things impossible for open communities by locking in specs from hw providers, and ATI et al keep playing these major sw corps' game. And all you can come up with is "Your laptop was sold with Windows" yada yada...

                                Eat sh*t.
                                I could answer and argue... But why bother? Is not like you are going to listen, anyway *yawn*

                                Comment

                                Working...
                                X