Announcement

Collapse
No announcement yet.

fireglcontrolpanel + FC6

Collapse
This topic is closed.
X
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • fireglcontrolpanel + FC6

    If you are encountering an issue when generating Fedora FC6 RPMs with the fglrx 8.29.6 drivers, read this thread.

    Prior to posting make sure kernel-devel, kernel-headers, qt-devel, and all of the standard development libraries and tools are installed and working.

    File not found: /tmp/ATI-fglrx-8.28.8-1-32131-root/tmp/ATI-fglrx-8.28.8-1.fc6-root-root/usr/bin/fireglcontrolpanel
    This problem has appeared to pop up with some users. Nothing with fireglcontrolpanel had changed from the 8.28.8 to 8.29.6 drivers when it comes to the Fedora packaging scripts, and no users had reported problems with FC5. So far I have installed well over a dozen Fedora 6 ATI machines and haven't run into this problem (I came across it once or twice a few weeks ago on Rawhide).

    If you are one of these users with build troubles, try building fireglcontrolpanel from source to see if it works or what errors are outputted.

    To grab the source, pass the argument of --extract to the 8.29.6 driver installer. It will then make the fglrx-install folder. From there, grab fglrx-install/common/usr/src/fglrx/fglrx_panel_sources.tgz and extract the contents.

    Run make in the extracted folder from fglrx_panel_sources.tgz. If the compilation errors out, post the output. Thanks.
    Michael Larabel
    http://www.michaellarabel.com/

  • #2
    http://linpaste.efnet-linux.com:7000/179
    Last edited by semi; 10-30-2006, 08:48 AM.

    Comment


    • #3
      You have qt-devel and libraries installed, correct? For Qt 3.3 (not Qt4).
      Michael Larabel
      http://www.michaellarabel.com/

      Comment


      • #4
        qt-3.3.4-15.5.i386.rpm
        says a newer version is installed.

        Comment


        • #5
          Originally posted by semi View Post
          qt-3.3.4-15.5.i386.rpm
          says a newer version is installed.
          If I recall, Qt 3.3.7 is the latest in the 3.3 branch, which is probably the "newer version". So do you also have qt-devel-3.3* installed?
          Michael Larabel
          http://www.michaellarabel.com/

          Comment


          • #6
            yes.
            qt-devel-3.3.7-0.1.fc6.i386.rpm is already installed

            thanks again for your patience.

            Comment


            • #7
              Hey all, I figured out how to fix it. I extracted the package and examined the makefile for the control panel, and it seems to be assuming that the qt libraries are always in /usr/lib64/qt-3.3/lib64 (/usr/{LIB_DIR}/{MK_QTDIR}/{LIB_DIR}) when it should be /usr/lib64/qt-3.3/lib64. I got the package to generate properly by creating a symbolic link lib64 to lib/. Everything worked fine after that.

              Comment


              • #8
                Erm, I meant to say that it should be looking for qt libs in /usr/lib64/qt-3.3/lib. Sorry for any confusion.

                Comment


                • #9
                  that did it. fixed my problem. It all works perfectly now.
                  thanks alot for that Shinigami2057 and thanks very much for all you help michael.

                  Comment


                  • #10
                    Originally posted by semi View Post
                    that did it. fixed my problem. It all works perfectly now.
                    thanks alot for that Shinigami2057 and thanks very much for all you help michael.
                    Does it work out with 8.30.3?
                    Michael Larabel
                    http://www.michaellarabel.com/

                    Comment

                    Working...
                    X