No announcement yet.

AMD Catalyst 12.9 Beta Linux Driver Released

  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    It figures that Catalyst has just started to behave right after I decided to go with Nvidia this time. The last two years with Catalyst has been a complete disaster and their open source driver is not fit to run anything much past desktop effects.

    I give up.

    I know that my Nvidia card is never guaranteed to have a credible open source alternative to Forceware (or whatever they are calling that now, my last Nvidia card with from the 9000 series), but it doesn't appear that AMD will either.

    I went to test out a Kubuntu 12.10 image today, excited that this Catalyst 12.9 beta might #%#$ing work, like, you know, their release notes said it would, but AMD has jacked me around again.

    I see the open source driver has inched forwards again, but it still has no fan control and my computer sounds like it is about to take off and fly around the room.

    I'm counting the hours left until I can rip this Radeon card out and replace it with something that supports the new distributions well before they are officially released. Among other things, like, not interfering with Wine.

    I also understand that Nvidia supported direct rendering under kwin before that was officially released too.

    The Catalyst team is a day late and a dollar short every time. If it was just one thing they were doing with their Linux driver that was incompetent, I might not have to come down as hard on them, but it's just so messed up in so many ways.

    Oh yeah, Nvidia has public betas quite frequently, and I never remembered them painting a FOR TESTING USE ONLY thing on my desktop that I had to figure out how to remove.


    • #17
      This version doesn't look good for me. I have intel+amd switchable graphics in my laptop. So fglrx not only doesn't support x-server 1.13 but also doesn't work with newest intel drivers (>=2.20.3). Also I noticed that fglrx requires relatively old versions of Mesa (8.0.4).

      By the way, does anybody know about news of the seamless support of switchable graphics in fglrx? It would be great to have something like bumblebee for amd cards.


      • #18
        It seems the guys from Ubuntu already solved the issue for xorg-server 1.13:

        Can anybody else try and confirm it?


        • #19
          Yes, that's true. fglrx driver for Xserver 1.13 support is already available in Ubuntu 12.10 repository.


          • #20
            I made deb package for Ubuntu quantal, it compiles good, install OK but nothing more, unity crash at launch, no 3D acceleration.


            • #21
              I believed that my pc was overheating by free drivers, but the other day it clean with compressed air and my pc has a very low temperature,

              Adapter: Virtual device
              temp1: +67.0C

              Adapter: PCI adapter
              temp1: +66.1C (high = +70.0C)
              (crit = +115.5C, hyst = +110.5C)

              After I had 90 degrees, but now my pc is fresh , Thank you amd for drop my card, Now I use a decent driver. No tearing on opengl output for videos, good opengl perfomance, good desktop effects performance, good native games performance, I play every day amnesia with this drivers and I don't have any problem .

              My pc is a hp pavilion dv6 2120 with radeon 4650


              • #22
                xserver 1.13

                Got some question to non-ubuntu (maybe non-debian) users:
                are you able to use this driver with xorg-server 1.13?

                As an Arch user i'm not able to start X, still getting Xorg.log' error:
                (EE) Failed to load /usr/lib/xorg/modules/drivers/ /usr/lib/xorg/modules/drivers/ undefined symbol: noXFree86DRIExtension
                I can see that also Mageia user is getting same error.

                I did some quick research but don't see anything special in ubuntu's fglrx...
                Although ubuntu's xserver 1.13 is patched with "tons" of patches.
                Question: is it possible that 12.9 beta supports only ubuntu's xserver?


                • #23
                  No ubuntu got as usual a "special" driver, something that i absolutely hate.


                  • #24
                    Originally posted by Kano View Post
                    No ubuntu got as usual a "special" driver, something that i absolutely hate.
                    indeed! darn it, i thought they are the same! What a disinformation! It's like third 9.00 within a month...

                    Anyhow still no success in starting Xserver 1.13 even with ubuntu's driver (still on Arch Linux) - got no error in Xorg.log, just black screen. Xorg.log said it's far farther, last lines:
                    [     4.415] (**) fglrx(0): AMD 2D Acceleration Architecture enabled
                    [     4.415] (--) fglrx(0): Chipset: "AMD Radeon HD 7800 Series " (Chipset = 0x6819)
                    [     4.415] (--) fglrx(0): (PciSubVendor = 0x174b, PciSubDevice = 0xe218)
                    [     4.415] (==) fglrx(0): board vendor info: third party graphics adapter - NOT original AMD
                    [     4.415] (--) fglrx(0): Linear framebuffer (phys) at 0xd0000000
                    [     4.415] (--) fglrx(0): MMIO registers at 0xfe8c0000
                    [     4.415] (--) fglrx(0): I/O port at 0x0000c000
                    [     4.415] (==) fglrx(0): ROM-BIOS at 0x000c0000
                    [     4.416] (II) fglrx(0): AC Adapter is used
                    So no success atm, but closer, works fine with xserv 1.12 though so it's built fine

                    Anyway thanks Kano!


                    • #25
                      Finally Ubuntu Quantal put them fglrx drivers version. I just installed them, they work but it a little bit too slow, they need optimization.

                      #apt-cache show fglrx
                      Package: fglrx
                      Priority: extra
                      Section: restricted/misc
                      Installed-Size: 236703
                      Maintainer: Ubuntu Core Developers <>
                      Architecture: amd64
                      Source: fglrx-installer
                      Version: 2:9.000-0ubuntu1


                      • #26
                        Ubuntu Quantal:
                        [20592.361784] [fglrx] module loaded - fglrx 9.0.2 [Sep 20 2012] with 1 minors

                        12.9 Beta (same as Embedded Driver with different control file):
                        [ 5.229425] [fglrx] module loaded - fglrx 9.0.2 [Aug 15 2012] with 1 minors

                        So there is one month difference between quantal and the other one. Meaning Quantal versionis one month newer.


                        • #27
                          Originally posted by legluondunet View Post
                          Finally Ubuntu Quantal put them fglrx drivers version. I just installed them, they work but it a little bit too slow, they need optimization.
                          What do you mean slow?
                          Is it something you can quatify with a benchmark?
                          Are they slow only with xorg 1.13 or even with 1.12?
                          Other people reported to be faster than previous releases.
                          What DE are you running?

                          I'm interested as I have a Radeon too, and I'm waiting good drivers to install Quantal


                          • #28
                            Well they are not slower for me with Ubuntu Quantal. I noticed some bugs with Google Chrome hardware acceleration but that's it.


                            • #29
                              windows 3D games with wine = very slower than on precise.


                              • #30
                                A whine about wine in regards to fglrx.