No announcement yet.

*Real* AMD Catalyst 12.9 Beta out now

  • Filter
  • Time
  • Show
Clear All
new posts

  • *Real* AMD Catalyst 12.9 Beta out now

    Much newer than the embedded driver from few weeks ago. Look out for improved 2D performance and possible Xserver 1.13 support.

  • #2
    My first impressions:

    + No beta/hardware watermark
    + Great 2D performance (for a Catalyst driver)
    + Overscaling/Underscaling options in AMDCCCLE (new?)
    + supports Hardware acceleration in Google Chrome 22

    I also did not find any new bugs so far. If you are using Ubuntu 12.04 LTS, please also update your system. Unity 5.16 is now avaible, fixing some performance issues with OpenGL and multi monitor usage.
    Last edited by d2kx; 09-26-2012, 01:47 PM.


    • #3
      Originally posted by AMD
      Feature Highlights of AMD Catalyst 12.9 Beta Linux® Driver: New OS Support

      This release of AMD Catalyst Linux introduces support for the following new operating systems.

      Ubuntu 12.10 early look support
      RHEL 6.3 production support
      So this should support Xserver 1.13.


      • #4
        $  sudo lspci -vvv | grep -A 35 02:00.0
        02:00.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI Madison [Radeon HD 5000M Series] (prog-if 00 [VGA controller])
                Subsystem: Acer Incorporated [ALI] Device 0517
                Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR+ FastB2B- DisINTx+
                Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR+ <PERR- INTx-
                Latency: 0, Cache Line Size: 64 bytes
                Interrupt: pin A routed to IRQ 46
                Region 0: Memory at d0000000 (64-bit, prefetchable) [size=256M]
                Region 2: Memory at cfee0000 (64-bit, non-prefetchable) [size=128K]
                Region 4: I/O ports at 2000 [size=256]
                [virtual] Expansion ROM at cfe00000 [disabled] [size=128K]
                Capabilities: [50] Power Management version 3
                        Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
                        Status: D0 NoSoftRst- PME-Enable- DSel=0 DScale=0 PME-
                Capabilities: [58] Express (v2) Legacy Endpoint, MSI 00
                        DevCap: MaxPayload 256 bytes, PhantFunc 0, Latency L0s <4us, L1 unlimited
                                ExtTag+ AttnBtn- AttnInd- PwrInd- RBE+ FLReset-
                        DevCtl: Report errors: Correctable- Non-Fatal- Fatal- Unsupported-
                                RlxdOrd+ ExtTag+ PhantFunc- AuxPwr- NoSnoop+
                                MaxPayload 128 bytes, MaxReadReq 512 bytes
                        DevSta: CorrErr- UncorrErr- FatalErr- UnsuppReq- AuxPwr- TransPend-
                        LnkCap: Port #0, Speed 5GT/s, Width x16, ASPM L0s L1, Latency L0 <64ns, L1 <1us
                                ClockPM- Surprise- LLActRep- BwNot-
                        LnkCtl: ASPM L1 Enabled; RCB 64 bytes Disabled- Retrain- CommClk+
                                ExtSynch- ClockPM- AutWidDis- BWInt- AutBWInt-
                        LnkSta: Speed 2.5GT/s, Width x16, TrErr- Train- SlotClk+ DLActive- BWMgmt- ABWMgmt-
                        DevCap2: Completion Timeout: Not Supported, TimeoutDis-, LTR-, OBFF Not Supported
                        DevCtl2: Completion Timeout: 50us to 50ms, TimeoutDis-, LTR-, OBFF Disabled
                        LnkCtl2: Target Link Speed: 5GT/s, EnterCompliance- SpeedDis-
                                 Transmit Margin: Normal Operating Range, EnterModifiedCompliance- ComplianceSOS-
                                 Compliance De-emphasis: -6dB
                        LnkSta2: Current De-emphasis Level: -3.5dB, EqualizationComplete-, EqualizationPhase1-
                                 EqualizationPhase2-, EqualizationPhase3-, LinkEqualizationRequest-
                Capabilities: [a0] MSI: Enable+ Count=1/1 Maskable- 64bit+
                        Address: 00000000fee0f00c  Data: 4152
                Capabilities: [100 v1] Vendor Specific Information: ID=0001 Rev=1 Len=010 <?>
                Kernel driver in use: fglrx_pci
        $ aticonfig
        aticonfig: No supported adapters detected
        With xorg git master:
        [     2.379] (EE) Failed to load /usr/lib/xorg/modules/drivers/ /usr/lib/xorg/modules/drivers/ undefined symbol: noXFree86DRIExtension
        Last edited by ChrisXY; 09-26-2012, 04:01 PM.


        • #5
          I just test this beta driver with my AMD radeon 7850 on Ubuntu 12.10, nothing work, Unity did not launch.
          I go back to radeon open source drivers.


          • #6
            Originally posted by legluondunet View Post
            I just test this beta driver with my AMD radeon 7850 on Ubuntu 12.10, nothing work, Unity did not launch.
            I go back to radeon open source drivers.
            Similar case here, but with 6470M. Installation seems normal, but no 3d acceleration or anything after reboot .. Hmm .. :/


            • #7
              Did You installed a drivers from generated deb packages? If You install from binary an installer doesn't check some important dependencies, so acceleration doesn't work (I had similar situation ~1 year ago, but now I install drivers from deb packages and works like a charm; I didn't check it with 12.10).


              • #8
                @nadro If you are talking to me, I did make the deb packages and installed them and made sure to have the dependencies installed in advance...


                • #9
                  I installed the beta drivers with generated deb packages method. In the log file, there was no errors messages.


                  • #10
                    On Ubuntu 12.10 install available fglrx package from repository.


                    • #11
                      Originally posted by RussianNeuroMancer View Post
                      On Ubuntu 12.10 install available fglrx package from repository.
                      I noticed ..! It works now ..


                      • #12
                        yes, fglrx drivers are now avalaible for quantal, but with poor performance compared to same config with precise


                        • #13
                          Much Better Performance

                          I installed the driver on my Asus 1215b which has one of the lower end Fusion chips in it that sports a Radeon 6310. It is MUCH smoother running this driver. Scrolling in Chrome is fluid and, as was said earlier in the thread, it seems overall 2D rendering is much better as the whole desktop seems more fluid. XVBA works in XBMC for video decoding and suspend has been working since I installed the 12.9 embedded driver.

                          I hope this is an indicator of where things are going with the driver. My only concern is I see that the early release driver in Quantal is being reported as very slow. Hopefully, they get that sorted out before the final release.


                          • #14
                            compiz perhaps?

                            legluondune, what DE are you using? Is it Unity by any chance? Compiz 0.9.8 introduced a few new options in the OpenGL plugin, namely "Framebuffer object", "Vertex buffer object" and "Always use buffer swapping", which, in my experience, made moving windows around feel slow and sluggish and caused somewhat higher CPU usage. So I disabled said options (as well as Sync To VBlank and enabled the Tear-Free option in CCC) and my desktop feels snappy again.


                            • #15
                              Working fine in Ubuntu 12.04 with HD7750

                              I have just installed the driver in Ubuntu 12.04 (64-bit) and it works fine! This time I tried the "generate packages" method, which should make it easier to uninstall/upgrade. Beware though that the installer requires some dependencies to be preinstalled. Here is my recipe (for 64-bit version!):

                              # Dependencies for generating .deb packages
                              sudo apt-get install debhelper devscripts dh-modaliases execstack
                              # Dependencies for installing .deb packages
                              sudo apt-get install lib32gcc1 libc6-i386 dkms

                              # Get driver
                              mkdir ~/AMD;cd ~/AMD

                              # Run installer
                              sudo sh
                              # Select "Generate Distribution Specific Driver Package"
                              # Select "Build package for detected OS: Ubuntu/precise"
                              # Installer should now run to completion without errors

                              # Install driver
                              sudo dpkg -i fglrx_9.000-0ubuntu1_amd64.deb fglrx-amdcccle_9.000-0ubuntu1_amd64.deb fglrx-dev_9.000-0ubuntu1_amd64.deb

                              # Make an xorg.conf file
                              sudo aticonfig --initial
                              # And reboot....
                              Last edited by Veto; 09-29-2012, 03:17 PM. Reason: Clarified to work for 64-bit..