Announcement

Collapse
No announcement yet.

AMD Catalyst 12.9 For Linux Brings Few Good Changes

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #31
    Originally posted by djdoo View Post
    Following Kano's workaround I finally installed it. Works nice, I see amdcccle reports 2D driver version 9.0.2, openGL 4.2.11903. No new options at amdcccle.
    OpenSUSE 12.2 here with stock Kernel 3.4.6, stock Xserver 1.12.3 and stock(updated) KDE 4.8.5.
    I think openGL ES 2.0 is disabled by blacklisting fglrx at kwin for KDE version prior 4.9... Does anyone know how to force the procedure??

    XVBA works via VAAPI mod through VLC output:
    Code:
    libva: VA-API version 0.33.0
    libva: User requested driver 'fglrx'
    libva: Trying to open /usr/lib64/dri/fglrx_drv_video.so
    libva: Found init function __vaDriverInit_0_32
    libva: va_openDriver() returns 0
    xvba_video: XVBA_GetSurface(): status 2
    [0x7f8d38c6dba8] avcodec decoder: Using VA API version 0.33 for hardware decoding.
    [h264 @ 0x7f8d38002a60] Cannot parallelize deblocking type 1, decoding such frames in sequential order
    Let's see if it works under Xserver 1.13...


    For reference I have Shadow Primary enabled with no problems. KDE runs smooth for now.
    Create a file in ~/.kde4/env with a name ending in '.sh'.

    The file should contain:
    Code:
    #!/bin/sh
    export KWIN_DIRECT_GL=1
    That will get you OpenGL 2 support. It works with KDE 4.9 in openSUSE but I didn't try it with the default 4.8.5.

    Comment


    • #32
      I don't see any performance improvement with KWIN_DIRECT_GL=1 and radeon hd 5670 (KDE 4.9 and fglrx-updates in ubuntu 12.04... I know it's not the newest driver but it will be always the same)

      Comment


      • #33
        fglrx-updates != 12.9

        In precise it is still version 12.4 - so it is ofc that you don't see any speedup.

        Comment


        • #34
          Originally posted by kirý View Post
          I don't see any performance improvement with KWIN_DIRECT_GL=1 and radeon hd 5670 (KDE 4.9 and fglrx-updates in ubuntu 12.04... I know it's not the newest driver but it will be always the same)
          I don't know if you should expect a performance improvement but it does allow you to enable the OpenGL 2 effects such as Invert. I don't know what driver version you are using in Ubuntu but OpenGL 2 works with 12.8 or 12.9 for me.

          Comment


          • #35
            Catalyst 12.9 Beta (at least for Windows) is going to be released *next* week. So this is nowhere near final.

            Comment


            • #36
              Originally posted by foxfire View Post
              I don't know if you should expect a performance improvement but it does allow you to enable the OpenGL 2 effects such as Invert. I don't know what driver version you are using in Ubuntu but OpenGL 2 works with 12.8 or 12.9 for me.
              I'm quite sure I had the "use opengl 2 shaders" option checked since kubuntu 11.10. Isn't this OpenGL 2 working since much time?

              Comment


              • #37
                Guys first of all it does NOT work with xserver 1.13. I installed the whole stack of packages with the latest code from X11:Xorg repository for openSUSE 12.2(I did all the needed stuff first, like uninstalled catalyst via amdconfig --uninstall command, rebooted, then I did the package updates, logout-login, installed catalyst 12.9, reboot) and I couldn't login at all!
                I reinstalled the old packages from the standard repo, reinstalled catalyst 12.9 with Kano's mod and all is working now again.

                @foxifire: I did what you said but I created the folder ~./kde4/env cause it didn't exist and put inside the file as you described with the code you gave me.
                Can I find out somehow if openGL ES 2.0 really works??
                Last edited by djdoo; 09-17-2012, 06:19 PM.

                Comment


                • #38
                  Originally posted by kirý View Post
                  I'm quite sure I had the "use opengl 2 shaders" option checked since kubuntu 11.10. Isn't this OpenGL 2 working since much time?
                  In openSUSE it is reported to be working but it does not. My guess is Ubuntu does the same thing. Try to enable the Invert effect and see if it throws an error. That one only works if OpenGL 2 is being used.

                  Comment


                  • #39
                    I'm sorry that I can't test this effect anymore as I'have nomore kde on my system. However if you find some performance improvement with opengl 2 let us know as I'm very interested about this.

                    Comment


                    • #40
                      Originally posted by foxfire View Post
                      In openSUSE it is reported to be working but it does not. My guess is Ubuntu does the same thing. Try to enable the Invert effect and see if it throws an error. That one only works if OpenGL 2 is being used.
                      Works here!

                      Comment

                      Working...
                      X