Announcement

Collapse
No announcement yet.

People incorrectly assume that AMD drivers suck. They don't.

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Originally posted by hoohoo View Post
    The pope-mobile runs on Jesus's Love!
    not on the tears of abused alter boys then....

    Comment


    • Originally posted by D0pamine View Post
      not on the tears of abused alter boys then....
      No - the altar boy's tears lubricate the axles.

      Comment


      • Originally posted by ruinairas View Post
        Despite the fact that AMD drivers might not suck....I cannot get it to work correctly on any type of AMD APU without serious issues. A good example is video corruption, slowness, and it freezes a lot. If I leave my laptop with a AMD APu 3400m on the table for more than 5 minutes idle it completely locks up. Whereas my desktop which is using a NVIDIA Geforce GTX 550 TI has NEVER had this issue. I can leave it on for days on end. It just "works" I'm not exactly sure whats going wrong..but all I know is with my own experience the APU's just don't "work" the way they should..on Both 12.04 and 12.10 (current). I'd sure like someone to prove me wrong though. Is there some kind of fix? I do after all want to see ALL graphics cards work properly..not just one individual.
        I too have a laptop with an AMD APU. Very similar one, in fact, a 3500M.
        In contrast to your experiences, this has got to be THE most stable device I've ever had the pleasure of owning. I have battery life that blows the "specs" out of the water, smooth stable performance, boot time under 5 seconds, suspend/resume work 100%, EVERY component working perfectly with a straight-out-of-the-box Fedora 17 install with updates as they come.

        What interests me about your post is your reference to time. 5 minutes. I wonder if you might be experiencing a HEAT related issue? Have you checked if it is running high temperature when it locks up or shuts down? Do you have dual graphics? If you do, have you disabled the discrete chip or is it running? The discrete chip in mine has the ability to raise the temperature by over 25 degrees C when it is switched on and set to high. Does your cooling fan run fast when its about to shut down? Does your cooling fan run AT ALL EVER? Mine idles at 39-41 degrees C, fan comes on occasionally, but mostly off.

        As others have explained, you could be experiencing an issue that is NOT related to the graphics or CPU. There is a lot of different hardware that could be responsible. BIOS as well. You could also be experiencing a bug in your distro.

        AMD APU's are EXTREMELY stable in Linux.

        Comment


        • Not sure what fixed it, whether it was a kernel upgrade, AMD blob upgrade or the fact I just switched it to systemd, but my AMD C-50 APU netbook running Arch now suspends perfectly!

          Before I couldn't get it to wake from suspend no matter what I tried. Then the other day I did a system update and also decided to finally switch it to systemd (already had my desktop running it, just not my netbook) since Arch is going that way.

          Sometime afterwards, funnily enough I accidently hit the sleep button. I groaned thinking I'd have to do a manual poweroff and reboot but nup, she came right back up and has been suspending ever since.

          I'd love to know which component actually fixed it, but I aint complaining.

          Comment


          • they do suck, i'm really quite annoyed by them, frustrated that i don't have onboard video, and don't really want to have to stick in a secondary pci-e video card for linux use.

            the binary drivers don't work on recent linux versions properly - they go into this weird mode where the top of the screen flickers a lot, disabling acceleration, and being difficult even for casual desktop use. the non-binary drivers don't work with hd 7000 series cards, and the drivers won't work at all if you use recent xorg version.

            Comment


            • The binary AMD drivers work perfectly for me. Fast boot, flawless video playback, low power consumption, excellent gaming performance, no crashes or glitches at all (not a single kernel panic or lockup in almost two years!). I used to have a lot of problems on both Ubuntu and Fedora with AMD's drivers, and I was even considering buying an NVIDIA GPU, but then I figured out a much easier solution: I switched to Windows 7.
              </trololololol>

              Comment


              • Originally posted by droidhacker View Post
                I too have a laptop with an AMD APU. Very similar one, in fact, a 3500M.
                In contrast to your experiences, this has got to be THE most stable device I've ever had the pleasure of owning. I have battery life that blows the "specs" out of the water, smooth stable performance, boot time under 5 seconds, suspend/resume work 100%, EVERY component working perfectly with a straight-out-of-the-box Fedora 17 install with updates as they come.

                What interests me about your post is your reference to time. 5 minutes. I wonder if you might be experiencing a HEAT related issue? Have you checked if it is running high temperature when it locks up or shuts down? Do you have dual graphics? If you do, have you disabled the discrete chip or is it running? The discrete chip in mine has the ability to raise the temperature by over 25 degrees C when it is switched on and set to high. Does your cooling fan run fast when its about to shut down? Does your cooling fan run AT ALL EVER? Mine idles at 39-41 degrees C, fan comes on occasionally, but mostly off.

                As others have explained, you could be experiencing an issue that is NOT related to the graphics or CPU. There is a lot of different hardware that could be responsible. BIOS as well. You could also be experiencing a bug in your distro.

                AMD APU's are EXTREMELY stable in Linux.
                Well, God must love you, buddy!

                As for me, sold my Asus 1215B (E-350 APU), and bought Asus A43E (i3 2350M). The former never give a good result on Arch (but with radeon, not AMD blob). It felt so sloooooow it's counterproductive.

                Comment

                Working...
                X