Announcement

Collapse
No announcement yet.

Radeon HD 7800 on Debian sid

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Radeon HD 7800 on Debian sid

    Hi,

    is there a chance to see this card working in Debian sid?

    01:00.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI PITCAIRN [Radeon HD 7800]

    My system looks like:

    X version:

    Code:
    X.Org X Server 1.12.1.902 (1.12.2 RC 2)
    Release Date: 2012-05-19
    X Protocol Version 11, Revision 0
    Build Operating System: Linux 3.2.0-2-amd64 x86_64 Debian
    Current Operating System: Linux debian 3.2.0-3-amd64 #1 SMP Thu Jun 28 09:07:26 UTC 2012 x86_64
    Kernel command line: BOOT_IMAGE=/boot/vmlinuz-3.2.0-3-amd64 root=UUID=d5c4aafe-4c17-4e46-92b3-99d55f733cdb ro quiet acpi=off
    Build Date: 20 May 2012  08:57:17AM
    xorg-server 2:1.12.1.902-1 (Cyril Brulebois <kibi@debian.org>) 
    Current version of pixman: 0.26.0
    	Before reporting problems, check http://wiki.x.org
    	to make sure that you have the latest version.
    Driver version: amd-driver-installer-12-6-x86.x86_64.run

    Problem: the installation of driver goes fine, but when X try starting, it does not start and a blanking cursor appears in the top left corner.

    Thank you.
    Last edited by rizpho; 07-01-2012, 10:44 AM.

  • #2
    Originally posted by rizpho View Post
    is there a chance to see this card working in Debian sid?
    Until next Catalyst release, the only option for sid - downgrade X server.

    Comment


    • #3
      Originally posted by RussianNeuroMancer View Post
      Until next Catalyst release, the only option for sid - downgrade X server.
      I supposed it, but personally I don't want downgrade X server packages.
      Any ETA about next Catalyst release?

      Thanks.

      Comment


      • #4
        Originally posted by rizpho View Post
        Any ETA about next Catalyst release?
        As usually: someday in this month.

        Comment


        • #5
          Originally posted by RussianNeuroMancer View Post
          As usually: someday in this month.
          Or sometime after. The monthly schedule is gone.

          You could try a 12.7 beta, if there is one for linux.

          Comment


          • #6
            Just tested that hack:

            http://ati.cchtml.com/show_bug.cgi?id=522#c5

            It really worked, use dch -lhotfix or so to increase version.

            Comment


            • #7
              Originally posted by Kano View Post
              Just tested that hack:

              http://ati.cchtml.com/show_bug.cgi?id=522#c5

              It really worked, use dch -lhotfix or so to increase version.
              Great news!
              Seems to be a libpciaccess problem on amd-64 arch.
              Now I can't try the patch, but if you have already applied it, I'm confident
              Thank you!

              Comment


              • #8
                Ok, works

                Thanks guys, with this patch X running finally right!
                Unfortunately, now the monitors flicks and when you drag the windows they are very very slow!

                ( https://www.youtube.com/watch?v=XbouKm8QSTU see the url chrome bar, there is a blanking black line over it )

                I'm trying with amdcccle utility to change some settings to the monitor, but nothing changes.
                Some programs, like evolution, does not start

                Code:
                (evolution:4511): Gdk-WARNING **: The program 'evolution' received an X Window System error.
                This probably reflects a bug in the program.
                The error was 'BadRequest (invalid request code or no such operation)'.
                  (Details: serial 154 error_code 1 request_code 139 minor_code 66)
                  (Note to programmers: normally, X errors are reported asynchronously;
                   that is, you will receive the error a while after causing it.
                   To debug your program, run it with the GDK_SYNCHRONIZE environment
                   variable to change this behavior. You can then get a meaningful
                   backtrace from your debugger if you break on the gdk_x_error() function.)
                My /etc/X11/xorg.conf looks like

                Code:
                Section "ServerLayout"
                	Identifier     "aticonfig Layout"
                	Screen      0  "aticonfig-Screen[0]-0" 0 0
                EndSection
                
                Section "Module"
                EndSection
                
                Section "Monitor"
                	Identifier   "aticonfig-Monitor[0]-0"
                	Option	    "VendorName" "ATI Proprietary Driver"
                	Option	    "ModelName" "Generic Autodetecting Monitor"
                	Option	    "DPMS" "true"
                EndSection
                
                Section "Monitor"
                	Identifier   "0-CRT1"
                	Option	    "VendorName" "ATI Proprietary Driver"
                	Option	    "ModelName" "Generic Autodetecting Monitor"
                	Option	    "DPMS" "true"
                	Option	    "PreferredMode" "1680x1050"
                	Option	    "TargetRefresh" "60"
                	Option	    "Position" "0 0"
                	Option	    "Rotate" "normal"
                	Option	    "Disable" "false"
                EndSection
                
                Section "Device"
                	Identifier  "aticonfig-Device[0]-0"
                	Driver      "fglrx"
                	Option	    "Monitor-CRT1" "0-CRT1"
                	BusID       "PCI:1:0:0"
                EndSection
                
                Section "Screen"
                	Identifier "aticonfig-Screen[0]-0"
                	Device     "aticonfig-Device[0]-0"
                	DefaultDepth     24
                	SubSection "Display"
                		Viewport   0 0
                		Depth     24
                	EndSubSection
                EndSection
                Any ideas??

                Thanks again.

                Comment


                • #9
                  Originally posted by rizpho View Post
                  Any ideas??
                  Maybe downgrade X server would give better result than libpciaccess hack?

                  Comment


                  • #10
                    Looks like the kernel module is not working or set to wrong glx Check
                    Code:
                    lsmod|grep fglrx
                    modinfo -F filename fglrx
                    dmesg
                    cat /var/log/Xorg.0.log
                    update-alternatives --config glx
                    Do NOT run the amd-installer directly, if you did so:
                    Code:
                    /usr/share/ati/fglrx-uninstall.sh
                    the correct debian way is:
                    Code:
                    apt-get --yes install fglrx-driver fglrx-modules-dkms xvba-va-driver fglrx-atieventsd fglrx-control
                    test `uname -m`! = x86_64! && apt-get --yes install fglrx-glx-ia32
                    update-initramfs -ut
                    aticonfig --initial --nobackup
                    Best is to have got only 1 kernel installed.
                    Last edited by Kano; 07-03-2012, 03:53 AM.

                    Comment

                    Working...
                    X