Announcement

Collapse
No announcement yet.

ATI-fglrx 8.29.6 and FC6

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #51
    If you installed Fedora Core 6, the Radeon drivers should be with X.Org 7.1. Did you try simply updating your xorg.conf?
    Michael Larabel
    http://www.michaellarabel.com/

    Comment


    • #52
      Hi, Semi:

      I just encountered the same problem as you on my desktop. If you installed the virtualization packages, you more than likely have a Xen kernel, which has its own devel package. Try installing kernel-xen-devel; Michael, could you update your script to specify that you might need the xen devel package? Thanks :]

      EDIT Grrr. Apparently fglrx does not work with kernel-xen at ALL. The driver won't load because of missing symbols in the kernel. I guess you'll have to fall back to the regular kernel. ATI's drivers are so damn broken.
      Last edited by Shinigami2057; 11-02-2006, 01:19 AM.

      Comment


      • #53
        Originally posted by Michael View Post
        If you installed Fedora Core 6, the Radeon drivers should be with X.Org 7.1. Did you try simply updating your xorg.conf?
        Hi Micheal,
        Good catch. I didn't realize that, and found r300_dri.so in /usr/lib/dri/ after your comment. I can give that a shot. Do I need to move it? I will likely need to change my xorg.conf file as well. Now it looks like:

        Section "Device"
        Identifier "aticonfig-Device[0]"
        Driver "fglrx"
        EndSection


        Should I change Driver "fglrx" to Driver "radeon" or "r300"? I want to make sure that X loads that driver (r300_dri.so) instead of some other one. When I update my xorg.conf to Driver "radeon" it loads the mesa stuff for 3d indirect rendering, and I get other errors with compiz. Also when I do that glxgears runs really slowly. So I'm not sure if I'm using r300_dri.so properly when I do that. I am on a x86_64 machine, should I put a soft link to it in /usr/lib64/ ?

        Thanks yet again!
        ndavis

        Comment


        • #54
          It should be Device "radeon". What Compiz errors do you run into? I have a few systems using the R300 drivers, so if you run into any other problems with that just post.
          Michael Larabel
          http://www.michaellarabel.com/

          Comment


          • #55
            Originally posted by Michael View Post
            It should be Device "radeon". What Compiz errors do you run into? I have a few systems using the R300 drivers, so if you run into any other problems with that just post.
            Hi Michael,
            I uninstalled my fglxr driver (just to avoid confusion), and beleive to have set things almost in order.
            My xorg.conf file looks like this:

            # Xorg configuration created by system-config-display

            Section "ServerLayout"
            Identifier "single head configuration"
            Screen 0 "Screen0" 0 0
            InputDevice "Keyboard0" "CoreKeyboard"
            EndSection

            Section "InputDevice"
            Identifier "Keyboard0"
            Driver "kbd"
            Option "XkbModel" "pc105"
            Option "XkbLayout" "us"
            EndSection

            Section "Module"
            Load "glx"
            Load "dri"
            EndSection

            Section "Monitor"

            ### Comment all HorizSync and VertSync values to use DDC:
            ### Comment all HorizSync and VertSync values to use DDC:
            ### Comment all HorizSync and VertSync values to use DDC:
            ### Comment all HorizSync and VertSync values to use DDC:
            Identifier "Monitor0"
            ModelName "Monitor 1280x1024"
            ### Comment all HorizSync and VertSync values to use DDC:
            HorizSync 31.5 - 79.0
            VertRefresh 50.0 - 90.0
            Option "dpms"
            EndSection

            Section "Device"
            Identifier "Videocard0"
            Driver "radeon"
            EndSection

            Section "Screen"
            Identifier "Screen0"
            Device "Videocard0"
            Monitor "Monitor0"
            DefaultDepth 24
            SubSection "Display"
            Viewport 0 0
            Depth 24
            Modes "1280x1024" "1280x960" "1280x800" "1152x864" "1152x768" "1024x768" "800x600" "640x480"
            EndSubSection
            EndSection


            I think that this is using the r300_dri.so driver, but I didn't see it anywhere in my /var/log/Xorg.0.log, (an excerpt is shown below):

            (II) LoadModule: "glx"
            (II) Loading /usr/lib64/xorg/modules/extensions/libglx.so
            (II) Module glx: vendor="X.Org Foundation"
            compiled for 7.1.1, module version = 1.0.0
            ABI class: X.Org Server Extension, version 0.3
            (==) AIGLX enabled
            (II) Loading extension GLX
            (II) LoadModule: "dri"
            (II) Loading /usr/lib64/xorg/modules/extensions/libdri.so
            (II) Module dri: vendor="X.Org Foundation"
            compiled for 7.1.1, module version = 1.0.0
            ABI class: X.Org Server Extension, version 0.3
            (II) Loading sub module "drm"
            (II) LoadModule: "drm"
            (II) Loading /usr/lib64/xorg/modules/linux/libdrm.so
            (II) Module drm: vendor="X.Org Foundation"
            compiled for 7.1.1, module version = 1.0.0
            ABI class: X.Org Server Extension, version 0.3
            (II) Loading extension XFree86-DRI
            (II) LoadModule: "radeon"
            (II) Loading /usr/lib64/xorg/modules/drivers/radeon_drv.so
            (II) Module radeon: vendor="X.Org Foundation"
            compiled for 7.1.1, module version = 4.2.0
            Module class: X.Org Video Driver
            ABI class: X.Org Video Driver, version 1.0
            (II) LoadModule: "ati"
            (II) Loading /usr/lib64/xorg/modules/drivers/ati_drv.so
            (II) Module ati: vendor="X.Org Foundation"
            compiled for 7.1.1, module version = 6.6.2
            Module class: X.Org Video Driver
            ABI class: X.Org Video Driver, version 1.0


            Now, when I try and run compiz, or glxgears, or even glxinfo, my screen goes black and I get logged out. I reinstalled the mesa-libGL and mesa-libGLU libraries as I thought some problem might exist there, but still get the black screen + logout. Any ideas? Thanks again!

            ndavis

            Comment


            • #56
              Did you uninstall fglrx? Though it shouldn't be causing a direct conflict since it shouldn't be loaded.

              Below is a xorg.conf on a R300 machine where I am running all the Zod eye candy. No problems. Pardon the fact that the input device is from a laptop.

              Section "ServerLayout"
              Identifier "Default Layout"
              Screen 0 "Screen0" 0 0
              InputDevice "Keyboard0" "CoreKeyboard"
              InputDevice "Synaptics" "CorePointer"
              EndSection

              Section "InputDevice"
              Identifier "Keyboard0"
              Driver "kbd"
              Option "XkbModel" "pc105"
              Option "XkbLayout" "us"
              EndSection

              Section "InputDevice"
              Identifier "Synaptics"
              Driver "synaptics"
              Option "Device" "/dev/input/mice"
              Option "Protocol" "auto-dev"
              Option "Emulate3Buttons" "yes"
              EndSection

              Section "Device"
              Identifier "Videocard0"
              Driver "radeon"
              EndSection

              Section "Screen"
              Identifier "Screen0"
              Device "Videocard0"
              DefaultDepth 24
              SubSection "Display"
              Viewport 0 0
              Depth 24
              EndSubSection
              EndSection
              Michael Larabel
              http://www.michaellarabel.com/

              Comment


              • #57
                Originally posted by Michael View Post
                Did you uninstall fglrx? Though it shouldn't be causing a direct conflict since it shouldn't be loaded.

                Below is a xorg.conf on a R300 machine where I am running all the Zod eye candy. No problems. Pardon the fact that the input device is from a laptop.

                Section "ServerLayout"
                .
                .
                .
                etc.
                Hi Michael,
                I decided to do a fresh test of an FC6 install on a test machine. Right after the install completes, I modify my xorg.conf file to load the radeon driver. However, I think I found the problem. Looking through my xorg log, I see:

                $ grep "Direct" /var/log/Xorg.0.log
                (II) RADEON(0): Direct rendering broken on XPRESS 200 and 200M
                (WW) RADEON(0): Direct rendering disabled


                Sad, yes. I'm still not sure if it is using the r300_dri.so lib, but I presume it is if it can detect that I do indeed have an ATI Xpress 200. Hmmm... not sure what to try next. You have been a great help, though, thanks! Any info regarding this error message would be very appreciated.

                Thanks again!
                ndavis

                Comment


                • #58
                  Hmm only thing I could think of off hand would be to grab the latest code from git to see if it fixes your broken support.
                  Michael Larabel
                  http://www.michaellarabel.com/

                  Comment


                  • #59
                    linux/autoconf.h not found.

                    Hi, I am having the same problem with linux/autoconf.h not found. I installed kernel-devel and kernel-headers and rebooted, but the problem persists. Thanks, Brett


                    Quote:
                    Originally Posted by _den View Post
                    Hi!

                    I am having problems with fglrx-fc6-8296-generator.sh script. when i run it become message:

                    linux/autoconf.h not found. Install kernel-devel first

                    kernel-devel package is alredy insatlled.


                    Originally posted by Michael View Post
                    Do you have kernel-headers installed?

                    Comment


                    • #60
                      Did you grab the 8.30.3 drivers? If not, grab them, they are newer and have the new scripts integrated.
                      Michael Larabel
                      http://www.michaellarabel.com/

                      Comment

                      Working...
                      X