Announcement

Collapse
No announcement yet.

ATI-fglrx 8.29.6 and FC6

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #31
    You need to use yum as root and when you are installing your RPMs. The script itself should work as user.
    Michael Larabel
    http://www.michaellarabel.com/

    Comment


    • #32
      Hi!

      I am having problems with fglrx-fc6-8296-generator.sh script. when i run it become message:

      linux/autoconf.h not found. Install kernel-devel first

      kernel-devel package is alredy insatlled.

      Comment


      • #33
        Originally posted by _den View Post
        Hi!

        I am having problems with fglrx-fc6-8296-generator.sh script. when i run it become message:

        linux/autoconf.h not found. Install kernel-devel first

        kernel-devel package is alredy insatlled.
        Do you have kernel-headers installed?
        Michael Larabel
        http://www.michaellarabel.com/

        Comment


        • #34
          Michael, thanks for the instructions on getting ATI drivers to work on FC6. However I'm running into a problem enabling the desktop effects. One of the instructions seems counter-intuitive (at least from the error messages). I was able to get the fglrx module loaded.

          # fglrxinfo
          display: :0.0 screen: 0
          OpenGL vendor string: ATI Technologies Inc.
          OpenGL renderer string: MOBILITY RADEON X300 Generic
          OpenGL version string: 2.0.6065 (8.29.6)


          But the problem comes when I try to enable the desktop effects.

          # desktop-effects
          gnome-window-decorator: Screen 0 on display ":0.0" already has a decoration manager; try using the --replace option to replace the current decoration manager.
          compiz: No composite extension
          Xlib: extension "SHAPE" missing on display ":0.0".


          It seems the instructions to add Option "Composite" "Disable" to xorg.conf, disables the ability to load compiz. Am I missing something?

          Comment


          • #35
            Matthew Davis,

            The fglrx drivers presently do not support the Composite extension. With Fedora Core 6 composite is enabled by default, which is why that X option needs to be specified.

            For experiencing the benefits of the FC6 desktop effects at this time you would need to use the open-source Radeon drivers (your GPU is supported with the Mobility X300). Or wait for appropriate fglrx support.

            If you have any additional questions or comments feel free to post.
            Michael Larabel
            http://www.michaellarabel.com/

            Comment


            • #36
              Ah, that works. I was under the impression that getting those ATI extensions loaded would let me use xgl with it. Thanks for the clarification.

              Comment


              • #37
                Little problem here! When I run the script, everything is going fine, there are absolutely no error messages, but once the script finishes, there are no RPMs at all.


                I ran into the firegl error, I think that clearing the /tmp/ directory and disabling SELinux solved the problem. (It was trying to find a file in /tmp/ati*/usr/bin/... )

                I'm not in front of the computer in question right now, I'll be able to tell you what the problem is tomorrow.

                Comment


                • #38
                  hey thanks a lot for writing the script Micheal.
                  I'm also having some problems with it .
                  I'm not really sure what's happening or what the problem is. maybe you can make sense of the errors:
                  http://linpaste.efnet-linux.com:7000/174
                  i'm running a 9800pro and would like to get dual monitors working without the refresh rates being terrible.
                  thanks.
                  Last edited by semi; 10-28-2006, 06:27 PM.

                  Comment


                  • #39
                    semi,

                    You seem to be running into the problem mentioned on the previous pages of this thread and other threads. Still investigating why some seem to run into fireglcontrolpanel problems. What packages do you have installed?
                    Michael Larabel
                    http://www.michaellarabel.com/

                    Comment


                    • #40
                      I have installed libstdc++.so.5, qt-devel wget and the standard development tools and libraries. kerenel devel says it's already installed.

                      Comment

                      Working...
                      X