Announcement

Collapse
No announcement yet.

ATI-fglrx 8.29.6 and FC6

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    I can't remember exactly wich packages i selected during installation but I think I didn't select any development packages or only a few maybe there is where my problem lies, just a guess, if I have the time during this week I'l try to make a fresh install and select some more packages and give it a go again and pray for better luck.

    Comment


    • #17
      I still haven't been able to reproduce the fireglcontrolpanel problem in this environment. The only things I can think of off hand is not having all of the development packages installed.

      Here was a working config file: http://www.phoronix.com/redblog/down...c6-sample.conf

      I'll continue to try things out through the final release on Tuesday.
      Michael Larabel
      http://www.michaellarabel.com/

      Comment


      • #18
        For those new to Fedora 6 and ATI, I have constructed a short how-to guide and updated scripts over @ http://www.phoronix.com/redblog/?p=blog&i=NTU1MA
        Michael Larabel
        http://www.michaellarabel.com/

        Comment


        • #19
          Hi again,

          Installed some more development packages, "Development Libraries, Development tools, Gnome Software Development, Legacy Software Development and X Software Development" but still could not manage to build the driver. Tomorrow FC6 hits the market for real and I will make a clean install and see if i get any better luck this time around. and try to be more carefull whene deselecting packages during the installation.

          Comment


          • #20
            Do you by chance have SELinux enabled? I had to disable it to get the thing to build...haven't looked into the dirty details yet though.

            Comment


            • #21
              No I'm quiet sure I disabled it during the install, caus I herd it's easier to enable than to disable, and I don't realy need it.

              Comment


              • #22
                Originally posted by Patrik Lavén View Post
                No I'm quiet sure I disabled it during the install, caus I herd it's easier to enable than to disable, and I don't realy need it.
                Hmm. I don't know what crazy confluence of things could have happened, but when I disabled SEL the RPM built successfully. I did have to get rid of the fireglcontrolpanel bit in the RPM build process tho, since it won't compile (and thus isn't "found" during install or RPM build)

                I did some digging last night through the source for the control panel. When I try to build it on it's own, I get many dependency errors, both related to QT and system files. I then read in the comments from RH regarding the FDC6 delay that they had problems with files being placed properly during install..

                Comment


                • #23
                  how did you get rid of the fireglcontrolpanel for the build process? I started fiddeling with various files to try to remove the stupid controlpanel but didn't digg in to it that much. Would be nice to know how to prevent it to build so I can get the drivers to build and upp and runing.

                  Cheers

                  Comment


                  • #24
                    Patrik:

                    To eliminate the need for fireglcontrolpanel you would need to modify ati-packager.sh and ATI-fglrx.spec-tmpl.

                    In the packaging script there should be the following segment of code:

                    Code:
                         if [ ! -x ${TMP_RPM_BUILD_DIR}/usr/bin/fireglcontrolpanel ]; then
                           mkdir ${TMP_RPM_BUILD_DIR}/usr/src/ati/fglrx_panel_sources
                           pushd ${TMP_RPM_BUILD_DIR}/usr/src/ati/fglrx_panel_sources &> /dev/null
                           tar xzf ${TMP_RPM_BUILD_DIR}/usr/src/ati/fglrx_panel_sources.tgz
                           sed -i 's|^LIBQT_DYN = qt$|LIBQT_DYN = qt-mt|' Makefile
                           sed -i 's|STRIP = strip|STRIP = @echo strip is disabled for:|' Makefile
                           sed -i 's|BASENAME =  fireglcontrol|BASENAME =  fireglcontrolpanel|' Makefile
                           [ -n "$QTDIR" ] || . /etc/profile.d/qt.sh && make &> /dev/null
                           install -p -m 0755 fireglcontrolpanel ${TMP_RPM_BUILD_DIR}/usr/bin/fireglcontrolpanel
                           popd &> /dev/null
                         fi
                    Delete or comment out all of that. Then in the RPM spec file you can remove references to fireglcontrolpanel.

                    I haven't tried it out myself, but that should allow the packaging scripts to run without building (or requiring) fireglcontrolpanel.

                    Also, if you have never modify the packaging scripts before, here is a brief explanation how to do it:

                    1. With the ATI driver installer file, pass it the --extract argument. This will extract the driver contents to fglrx-install.
                    2. In fglrx-install/packages/Fedora are the scripts that can be modified.
                    3. To build with these scripts, from the fglrx-install directly do: ./ati-installer.sh 8.29.6 --buildpkg Fedora/FC6

                    That should do it.... you could alternatively copy the folder outside the fglrx-install and then simply pass the custom-package location, etc... but the above steps should work out fine for your needs.
                    Michael Larabel
                    http://www.michaellarabel.com/

                    Comment


                    • #25
                      Hi again,

                      Made a fresh install of FC6 from the rescue cd, and now, no problem building the driver with the script Michael maid. It muste have been something I deselected in the previous installation. Added all the packages that Michael said he had used and it all worked excelent.

                      Thanks for all the help,but for now the drivers work and I'm happy untill something else will turn upp that make me go on another google hunt fore solutions.

                      Comment


                      • #26
                        I finally ran into that fireglcontrolpanel problem on an install this morning. Though interestingly enough I installed all the same packages that I had done on previous installs... I'll let you know once I figure the issue out.
                        Michael Larabel
                        http://www.michaellarabel.com/

                        Comment


                        • #27
                          Patrik,

                          I am now on Fedora Core 6 final. The guide / script is still working appropriately.

                          At http://www.phoronix.com/redblog/down...6-packages.txt is my install.log that shows all the packages I installed (had no fireglcontrolpanel problems).
                          Michael Larabel
                          http://www.michaellarabel.com/

                          Comment


                          • #28
                            Help!!!

                            I'm having a terrible time with this. I ran yum install kernel-devel and everything downloaded and installed. However, when I run sh ./fglrx-fc6-8296-generator.sh, I get the following error:

                            linux/autoconf.h not found. Install kernel-devel first

                            If I run sh ./ati-driver-installer-8.29.6.run --buildpkg Fedora/FC6, it begins to install, then at the end I get the following error:

                            Generating package: Fedora/FC6
                            Please install an appropriate Linux kernel module build package.
                            Probably kernel-devel in this case.
                            If you've compiled a custom kernel, make sure /usr/src/linux exists
                            and the source tree matches the currently running kernel.
                            Removing temporary directory: fglrx-install

                            What am I doing wrong? I've disabled the firewall and the SELinux.

                            Comment


                            • #29
                              tmanops,

                              Did you reboot after installing the new kernel and kernel-devel? If not, make sure you do. You may also want to install kernel-headers.
                              Michael Larabel
                              http://www.michaellarabel.com/

                              Comment


                              • #30
                                Originally posted by Michael View Post
                                tmanops,

                                Did you reboot after installing the new kernel and kernel-devel? If not, make sure you do. You may also want to install kernel-headers.
                                Michael, thanks for the quick reply. I did reboot, but I didn't install the headers piece you mentioned. I'll do that, and retry...

                                Should I do this as root? I'm a newbie to Linux, so thanks for the patience.

                                Comment

                                Working...
                                X