Announcement

Collapse
No announcement yet.

AMD 8.40.4 Driver -- One Bug A Day Keeps AIGLX Away

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #11
    Xv is working fine as always for me.

    Comment


    • #12
      Manage to install.

      However, I can't run amdcccle. It just hanged on start. Anyone facing this problem?

      Comment


      • #13
        Works for me. I had this problem with some older versions... what distribution are you using and how did you install it?

        Btw. this driver is still not official.

        Comment


        • #14
          heh i won!
          ...
          now, where's the food? ;-)

          i'm not even touching this one. this will be one fglrx release i won't even bother to download.

          i'm happy with opensource x300 driver right now. and judging how the things are - that won't change anytime soon.

          personally i believe ati should time their linux driver cycle to kernel/x.org releases (or mostly x.org, since there are usually minor patches needed to make kernel part work between new versions) and keep working on the driver in the meantime, releasing just bugfixes. early and often.

          i think we would greatly benefit from this. linux is not a stable-api-land like windows is.

          Comment


          • #15
            All the fglrx flaming is ok and to be honest I love reading your posts yoshi314, because I am always laughing about them and always imagine a poor driver developer at AMD that likes his work, but that has found and read your posts :P Keep 'em coming!

            But: since 8.30, fglrx' stability has been improving for me. I had many crashes when playing games for 5 minutes, shutdown crashes, Xserver restart crashes, idle crashes, VT console switch crashes, crashes, crashes, video playback issues, crashes and colour problems, AMDCCCLE didn't start up, ... all that has been fixed in the latest versions for me, so I only get poor performance, poor wine game support and no AIGLX, but the driver itself is really getting better.

            Comment


            • #16
              The release notes are up now @ https://a248.e.akamai.net/f/674/9206...ux_8.40.4.html
              Michael Larabel
              http://www.michaellarabel.com/

              Comment


              • #17
                Originally posted by d2kx View Post
                Works for me. I had this problem with some older versions... what distribution are you using and how did you install it?
                It use to work, but failed after I upgraded my system from Slack11 to Slack12.

                I use the standard installer from ATI.

                Comment


                • #18
                  When I tried Slackware 12, I found that you really should do

                  sh ./ati...run --buildpkg Slackware/All

                  That will not only create the driver packages, but also build the kernel module for you. You shouldn't use the official installer unless you use RedHat/Fedora (or OpenSuSE I guess).

                  Comment


                  • #19
                    Originally posted by d2kx View Post
                    When I tried Slackware 12, I found that you really should do

                    sh ./ati...run --buildpkg Slackware/All

                    That will not only create the driver packages, but also build the kernel module for you. You shouldn't use the official installer unless you use RedHat/Fedora (or OpenSuSE I guess).
                    The GUI installer only supports Red Hat and SuSE/OpenSuSE since they are the only two officially supported distributions. For all others use -llistpkg and then --buildpkg
                    Michael Larabel
                    http://www.michaellarabel.com/

                    Comment


                    • #20
                      Originally posted by Michael View Post
                      The GUI installer only supports Red Hat and SuSE/OpenSuSE since they are the only two officially supported distributions. For all others use -llistpkg and then --buildpkg
                      With Slackware 12, I used the gui install and it worked fine, and this is the way most slackers are using to install the recent fglrx drivers.

                      Since Slackware 10 I always used the gui installer,
                      Last edited by glussier; 08-13-2007, 04:59 PM.

                      Comment

                      Working...
                      X