No announcement yet.

AMD Catalyst Linux 12.6 Beta Has Arrived

  • Filter
  • Time
  • Show
Clear All
new posts

  • #46
    Hmmm... for me this driver still doesn't work with kernel 3.4. I have a dual intel/ati 6770 HP laptop. With kernel 3.3 I get:
    [     8.432] (II) Loading PCS database from /etc/ati/amdpcsdb
    [     8.434] ukiDynamicMajor: found major device number 253
    [     8.434] ukiDynamicMajor: found major device number 253
    [     8.434] ukiOpenByBusid: Searching for BusID PCI:1:0:0
    [     8.434] ukiOpenDevice: node name is /dev/ati/card0
    [     8.434] ukiOpenDevice: open result is 8, (OK)
    [     8.434] ukiOpenByBusid: ukiOpenMinor returns 8
    [     8.434] ukiOpenByBusid: ukiGetBusid reports PCI:1:0:0
    [     8.696] (II) Turned on the discrete card
    and X starts. But with 3.4:
    [    10.576] (II) Loading PCS database from /etc/ati/amdpcsdb
    [    10.587] ukiDynamicMajor: failed to open /proc/ati/major
    [    10.588] ukiDynamicMajor: failed to open /proc/ati/major
    [    10.588] (EE) Fail to open device PCI:1:0:0
    I'm using xf86-video-intel-2.19 and xorg-server-1.12. The ati driver was compiled with the 3.4 patch.
    Any ideas?


    • #47
      Duh, my module was not loading. The same error I had some time ago:

      fglrx: Unknown symbol old_rsp (err 0)
      old_rsp is introduced in the patch. So I don't know how to solve it.

      (edit) And now I know. I had to disable CONFIG_X86_X32 (x32 ABI). I tried removing that kernel option and it worked. At last, I have a 3.4 kernel with 1.12 xorg-server and fglrx.
      Last edited by zequav; 06-06-2012, 04:16 AM.