Announcement

Collapse
No announcement yet.

AMD Catalyst 12.6 Beta improvements?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #11
    AMD took down 12.6 beta from the website.

    Is there anyone here that could provide us a link to it?

    Thanks

    Comment


    • #12
      Originally posted by the-me View Post
      Hey guys,

      we (Debian) just wanted to upload the fixed xserver 1.12 driver to Debian, but yeah the x 1.12 support is....:

      Backtrace:
      0: /usr/bin/X (xorg_backtrace+0x34) [0x7fbbe05283c4]
      1: /usr/bin/X (0x7fbbe03a0000+0x18bf99) [0x7fbbe052bf99]
      2: /lib/x86_64-linux-gnu/libpthread.so.0 (0x7fbbdf6c8000+0xf030)
      [0x7fbbdf6d7030]
      3: /usr/lib/x86_64-linux-gnu/libpciaccess.so.0 (0x7fbbdf8e4000+0x5394)
      [0x7fbbdf8e9394]
      4: /usr/lib/xorg/modules/drivers/fglrx_drv.so (0x7fbbdb7bb000+0x8032c9)
      [0x7fbbdbfbe2c9]
      5: /usr/lib/xorg/modules/drivers/fglrx_drv.so
      (amd_xs112_int10_xf86ExtendedInitInt10+0xdd) [0x7fbbdbfbe05d]
      6: /usr/lib/xorg/modules/drivers/fglrx_drv.so
      (amd_xs112_int10_xf86InitInt10+0xb) [0x7fbbdbfbd8fb]
      7: /usr/lib/xorg/modules/drivers/fglrx_drv.so (xf86InitInt10+0xd)
      [0x7fbbdbb0397d]
      8: /usr/lib/xorg/modules/drivers/fglrx_drv.so (0x7fbbdb7bb000+0x48405c)
      [0x7fbbdbc3f05c]
      9: /usr/lib/xorg/modules/drivers/fglrx_drv.so
      (xdl_xs112_PreInitAdapter+0x274) [0x7fbbdbc3ec34]
      10: /usr/lib/xorg/modules/drivers/fglrx_drv.so
      (xdl_xs112_atiddxPreInit+0x12ad) [0x7fbbdbc4031d]
      11: /usr/bin/X (InitOutput+0x83c) [0x7fbbe043287c]
      12: /usr/bin/X (0x7fbbe03a0000+0x4181d) [0x7fbbe03e181d]
      13: /lib/x86_64-linux-gnu/libc.so.6 (__libc_start_main+0xfd)
      [0x7fbbde3f1ead]
      14: /usr/bin/X (0x7fbbe03a0000+0x41cdd) [0x7fbbe03e1cdd]
      Segmentation fault at address 0xffffffffe18c7332

      ... simply not working at all (on amd64 only maybe?)..............
      Having the same issue. posted a bug report here

      Comment


      • #13
        So, they fix the 2d problem and leave hd4xxx users in the dust? nice.

        Comment


        • #14
          It looks like AMD drop support for HD2k-4k in the same time, when he released the best drivers since last years...

          Comment


          • #15
            Originally posted by RussianNeuroMancer View Post
            Replace control file: http://wiki.cchtml.com/index.php/Ubu...ware_Watermark
            And put valid signature to signature file: http://wiki.cchtml.com/index.php/Amd_watermark
            Didn't work. I can't remove the watermark saying "AMD Testing use only".
            It seems that there is no signature inside the driver install script.

            Anybody managed to remove/hide it?

            Thanks

            Comment


            • #16
              Originally posted by RussianNeuroMancer View Post
              Replace control file: http://wiki.cchtml.com/index.php/Ubu...ware_Watermark
              And put valid signature to signature file: http://wiki.cchtml.com/index.php/Amd_watermark
              It doesn't work. The signature is "Undefined" in the signature file.

              Comment


              • #17
                Originally posted by mikejuni View Post
                It doesn't work. The signature is "Undefined" in the signature file.
                That why you need to put valid signature follow instruction.
                Last edited by RussianNeuroMancer; 06-02-2012, 12:47 AM.

                Comment


                • #18
                  Originally posted by RussianNeuroMancer View Post
                  That why you need to put valid signature follow instruction.
                  Further checked the signature from the grep command returns unsigned and the control file from install archive is the same as the installed one.

                  Comment


                  • #19
                    Originally posted by mikejuni View Post
                    Further checked the signature from the grep command returns unsigned and the control file from install archive is the same as the installed one.
                    Take control file and signature from stable build, not beta.

                    Comment


                    • #20
                      can confirm works well with Xserver 1.12 on Archlinux

                      Originally posted by rechapit View Post
                      Having the same issue. posted a bug report here
                      here is my xorg.0.log... i just updated the packages after installing Catalyst 12.6 from the AUR....looks like debian specific issue to me

                      Comment

                      Working...
                      X