Announcement

Collapse
No announcement yet.

Catalyst 12-1 released

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #31
    Where is Catalyst 12.2?
    Is AMD ashamed of it..?

    Comment


    • #32
      Basically they could delay it because of linux 3.2.8, but nobody would believe that

      Comment


      • #33
        The 12.2 is supposed to carry the xv video fix, maybe they are making sure it works...

        Comment


        • #34
          This might be the wrong thread to ask, but do we know if/when fglrx will be usable for laptops with intel/amd muxless ?

          Comment


          • #35
            if u look at https://twitter.com/#!/CatalystCreator u will see that he tweeted that the official 12.2 driver isn't released until early next week.....correct me if im wrong, but I don't think that it being a leap year works as an excuse here .......judging from his other recent tweets it sounds like the delay is most likely due to having to rush out a windows driver that supports windows 8. Whatever, at this point I have come to realize that the next catalyst release will never be that magical one that fixes all the stupid issues my 5770 has had, which have been ignored for months, and in some cases years.....what xv video issue is supposed to be fixed btw? I have had issues with jittery fullscreen video playback, but I was under the impression it was a compiz thing

            Comment


            • #36
              Originally posted by Dr. Tyrell View Post
              This might be the wrong thread to ask, but do we know if/when fglrx will be usable for laptops with intel/amd muxless ?
              It has already been working on muxless hybrid graphics for quite some time. It works on my Sony Vaio S 13 for example. See a howto I wrote at Gentoo Forums (http://forums.gentoo.org/viewtopic-t-909802.html) for getting fglrx to work (and other options). Long story short, you just additionally need to add the PCI ID information of your graphics card in the xorg.conf. Also, the driver works in conjunction with the Intel graphics, and for now the xf86-video-intel driver package should be compiled with the "sna" model disabled.

              I would also warn that on my notebook, the discrete graphics seems to be slightly laggy (perhaps just me), and overall I am happy with the performance of Intel graphics, both in terms of performance and power consumption. On the upside, this is one of the first setups where KMS works with discrete graphics .

              Comment


              • #37
                ...if/when fglrx will be usable for laptops with intel/amd muxless ?
                in the ubuntu forum is also a guide: AMD/Intel Hybrid Graphics works ! (it's based on the guide from the gentoo forums)
                Last edited by Fenrin; 02-29-2012, 06:28 PM.

                Comment


                • #38
                  Originally posted by Fenrin View Post
                  in the ubuntu forum is also a guide: AMD/Intel Hybrid Graphics works ! (it's based on the guide from the gentoo forums)
                  That is interesting, since on Gentoo, I need to have USE="-sna" for xf86-video-intel, which presumably disables sna, to get the hybrid graphics working. Regardless, good that it works - I would have preferred to have things working with sna, since apparently it helps with the power consumption and performance of the Intel graphics a lot.

                  Comment


                  • #39
                    Thanks all for the replies. I'm re-visiting this based on your advice.

                    The Doctor

                    Comment


                    • #40
                      Originally posted by chronniff View Post
                      if u look at https://twitter.com/#!/CatalystCreator u will see that he tweeted that the official 12.2 driver isn't released until early next week.....correct me if im wrong, but I don't think that it being a leap year works as an excuse here .......judging from his other recent tweets it sounds like the delay is most likely due to having to rush out a windows driver that supports windows 8. Whatever, at this point I have come to realize that the next catalyst release will never be that magical one that fixes all the stupid issues my 5770 has had, which have been ignored for months, and in some cases years.....what xv video issue is supposed to be fixed btw? I have had issues with jittery fullscreen video playback, but I was under the impression it was a compiz thing
                      The fglrx driver crash xorg when playing movies with the latests xorg's. Debian bugs: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=649346

                      Originally posted by Andreas
                      Subject: Re: Bug#649346: fglrx-driver: using xv extension crashes Xorg
                      Date: Sat, 18 Feb 2012 21:26:23 +0100

                      On 2012-02-18 21:18, Tamas Marki wrote:
                      > Well, turning off xvideo prevents some programs from running, most
                      > notably tvtime, for which I haven't found a suitable replacement...

                      A bugfix for the XV problem is expected for the 12-2 upstream release.


                      Andreas

                      Comment


                      • #41
                        I have installed packages from xorg-edgers, sarvatt.
                        Installed fglrx 8.950 from edgers
                        Followed instructions at links above.
                        Haven't yet rebooted, but here's results of 'aticonfig' commands:

                        laptop usr # aticonfig --initial -f
                        aticonfig: No supported adapters detected
                        laptop usr # aticonfig --initial -f --adapter=all
                        aticonfig: No supported adapters detected
                        laptop usr # aticonfig --pxl
                        aticonfig: No supported adapters detected

                        Comment


                        • #42
                          Regarding my prev post, I forgot to "echo ON > /sys/kernel/debug/vgaswitcheroo/switch"
                          After reboot all is well, using Catalyst for first time on this HP dv7-6178us .
                          THANKS ALL!

                          Comment

                          Working...
                          X