Announcement

Collapse
No announcement yet.

Catalyst 12-1 released

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #21
    Originally posted by Forage View Post
    I'm having the same issues ever since Ubuntu 11.10 with Gnome-Shell, not just with the latest drivers. I too have the latest updates from the Gnome 3 ppa, but that should not be the cause. The packages only received minor updates compared to Ubuntu's default.

    Have you tried disabling all your plugins?
    If that doesn't work open a VT and sign in. Then run "pkill gnome-shell && gnome-shell --replace -d :0"
    Then you can see what the errors were if it fails again.
    What version of GS are you running, BTW?

    Comment


    • #22
      Originally posted by liam View Post
      Have you tried disabling all your plugins?
      If by plugins you mean Gnome extensions then yes. The problems occurred right after a complete clean install (not even preserving the home folder) without any extensions installed. I installed 3 non-intrusive ones much later so those aren't the cause.

      Originally posted by liam View Post
      If that doesn't work open a VT and sign in. Then run "pkill gnome-shell && gnome-shell --replace -d :0"
      Good one. Will try that.

      Originally posted by liam View Post
      What version of GS are you running, BTW?
      The latest from the Gnome 3 ppa, 3.2.2.1.

      Comment


      • #23
        whats about vlc? Do the system still crash on new drivers when you want to play the movie?

        Comment


        • #24
          Originally posted by liam View Post
          If that doesn't work open a VT and sign in. Then run "pkill gnome-shell && gnome-shell --replace -d :0"
          It is difficult to distinguish in the output, as well as in ~/.xsession-errors, what exactly is outputted when the crash occurs and what is outputted because of other issues.

          The following is roughly what always pops up when the crash occurs.
          Code:
          Clutter-WARNING **: Unable to compile the GLSL shader: Fragment shader failed to compile with the following errors:
          ERROR: 1:1: error(#105) #version must occur before any other statement in the program
          ERROR: error(#273) 1 compilation errors.  No code generated
          
          
          ** Message: applet now removed from the notification area
          gnome-shell-calendar-server[5420]: Got HUP on stdin - exiting
          gnome-session[3867]: WARNING: Application 'gnome-shell.desktop' killed by signal
          folks-DEBUG: individual-aggregator.vala:310: Setting primary store IDs to defaults.
          folks-DEBUG: individual-aggregator.vala:338: Primary store IDs are 'eds' and 'system'.
              JS ERROR: !!!   WARNING: 'assignment to undeclared variable owner'
              JS ERROR: !!!   WARNING: file '/home/forage/.local/share/gnome-shell/extensions/music-integration@brianrobles204/extension.js' line 1432 exception 0 number 156
                JS LOG: GNOME Shell started at Sat Jan 28 2012 01:05:52 GMT+0100 (CET)
          ** Message: applet now embedded in the notification area
          The Clutter warning, followed by the two errors, also appear in the log without it being followed by a crash. So I expect that that isn't the cause.

          I can remove the music-integration extension, but as mentioned before, the issue also occurred before installing it and the warning does not show up until after the crash.

          Comment


          • #25
            Originally posted by Forage View Post
            If by plugins you mean Gnome extensions then yes. The problems occurred right after a complete clean install (not even preserving the home folder) without any extensions installed. I installed 3 non-intrusive ones much later so those aren't the cause.


            Good one. Will try that.


            The latest from the Gnome 3 ppa, 3.2.2.1.
            Since you've disabled plugins and are running the latest version I don't know what to tell you without more some kind of error output, or some commonality of the crashes (I'm assuming you have checked the logs already and didn't see anything?).

            Sorry.

            Comment


            • #26
              Originally posted by Forage View Post
              It is difficult to distinguish in the output, as well as in ~/.xsession-errors, what exactly is outputted when the crash occurs and what is outputted because of other issues.

              The following is roughly what always pops up when the crash occurs.
              Code:
              Clutter-WARNING **: Unable to compile the GLSL shader: Fragment shader failed to compile with the following errors:
              ERROR: 1:1: error(#105) #version must occur before any other statement in the program
              ERROR: error(#273) 1 compilation errors.  No code generated
              
              
              ** Message: applet now removed from the notification area
              gnome-shell-calendar-server[5420]: Got HUP on stdin - exiting
              gnome-session[3867]: WARNING: Application 'gnome-shell.desktop' killed by signal
              folks-DEBUG: individual-aggregator.vala:310: Setting primary store IDs to defaults.
              folks-DEBUG: individual-aggregator.vala:338: Primary store IDs are 'eds' and 'system'.
                  JS ERROR: !!!   WARNING: 'assignment to undeclared variable owner'
                  JS ERROR: !!!   WARNING: file '/home/forage/.local/share/gnome-shell/extensions/music-integration@brianrobles204/extension.js' line 1432 exception 0 number 156
                    JS LOG: GNOME Shell started at Sat Jan 28 2012 01:05:52 GMT+0100 (CET)
              ** Message: applet now embedded in the notification area
              The Clutter warning, followed by the two errors, also appear in the log without it being followed by a crash. So I expect that that isn't the cause.

              I can remove the music-integration extension, but as mentioned before, the issue also occurred before installing it and the warning does not show up until after the crash.
              I suppose I should've finished reading the thread before I responded before

              Is all of that what is spewed out immediately after the crash or simply all the output from the VT?
              None of those errors look fatal to me. The GLSL error might cause problems if you hit that particular code path (did the crash happen to occur after you some interaction with the shell? like going to overview/looking at the calender/alt-tab/etc).
              To get the errors in a more useful order we could try passing the "--sync" option to the gnome-shell command. If that doesn't help, have you tried installing the open drivers just as a check to see if something is wrong your installlation?

              Comment


              • #27
                TV

                Originally posted by rockmanz View Post
                Have you tried:
                sudo aticonfig --set-pcs-val=MCIL,DigitalHDTVDefaultUnderscan,0
                Yes. I tried that and it didn't seem to have any effect. The picture still didn't fill the entire screen. It didn't throw an error at me so I assume it took the command and just didn't do anything with it.

                Comment


                • #28
                  Originally posted by liam View Post
                  I suppose I should've finished reading the thread before I responded before
                  The reason I didn't post the log sooner is because I can't reproduce the error on request. Sometimes it happens 2 times an hour, sometimes 4 time a day.

                  Originally posted by liam View Post
                  Is all of that what is spewed out immediately after the crash or simply all the output from the VT?
                  This is what's spewed out around the crash. It's difficult to determine what comes out exactly at the moment the crash occurs. This is basically an average of what comes back each time.
                  It was copied from ~/xsession-errors, because I did not manage to get a copy of the VT output. The content is the same nevertheless.

                  Originally posted by liam View Post
                  did the crash happen to occur after you some interaction with the shell? like going to overview/looking at the calender/alt-tab/etc
                  Sometimes it takes an interaction like going to the overview, sometimes it happens while doing nothing like you just closed an application and stopped doing absolutely anything for 10 seconds, not even moving the mouse, because you're still reading something on the screen.

                  Originally posted by liam View Post
                  To get the errors in a more useful order we could try passing the "--sync" option to the gnome-shell command.
                  OK, will try that as well.
                  Using a VT to restart gnome-shell and continue to work normally is, however, a bit of a pain since other applications stop functioning properly if I do. E.g. Empathy can't login any more (telepathy errors) and Synaptic won't start, etc.

                  Originally posted by liam View Post
                  If that doesn't help, have you tried installing the open drivers just as a check to see if something is wrong your installlation?
                  This is why I suspect the ATI drivers. In the beginning I was forced to use just the opensource drivers and the issue did not occur. It wasn't until I switched to the ATI driver that it did.
                  Just to be sure I could try the opensource drivers again for a day and see what happens. Seeing the "gnome-shell-calendar-server" in the log makes me question if it really can be related.

                  Comment


                  • #29
                    @lakerssuperman

                    It is most likely not your error. AMD drivers have got those stupid defaults even on Win. The drivers are a mess there too, i wanted to use it on a Philips TV, could fix the overscan, but got bad colors after some time. I did not google to search for a possible workaround that day, it seems there should be a config option, but by default it is wrong. When you however use a nvidia card, then you dont need to do anything, it is just correct by default... AMD hardware is most likely not that bad, but drivers are complete crap. Even the defaults are more painful than helpful.

                    Comment


                    • #30
                      The driver is not part of the kernel, user space. This is why 64 of the installation image is a huge amount of more than 32 large.

                      Comment

                      Working...
                      X