Announcement

Collapse
No announcement yet.

Is there any guide on xorg.conf for ATI?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Is there any guide on xorg.conf for ATI?

    Is there any guide on how to configure xorg.conf for ATI proprietary drivers? I'm losing my mind on this.

  • #2
    Use as close to a vanilla xorg.conf as possible and configure with aticonfig, not by editing xorg.conf.

    The Catalyst / fglrx driver uses xorg.conf primarily for configuring the X server, and uses a separate mechanism for driver configuration. The info is stored in the amdpcsdb file (or maybe atipcsdb, I forget) where pcsdb is short for something like Persistent Configuration Store DataBase. I believe aticonfig changes both xorg.conf and amdpcsdb as needed.

    The aticonfig --initial command syncs up the pcsdb and xorg.conf files if the xorg.conf is pretty much vanilla -- if more changes are required the -f option lets aticonfig --initial make more significant changes to xorg.conf. From that point you use the aticonfig command to configure driver options -- try something like aticonfig --help to get the options.

    The names are in the process of changing from ati... to amd..., not sure what current status is.
    Last edited by bridgman; 01-20-2012, 10:55 PM.

    Comment


    • #3
      Maybe you can help me then. I use an ATI Mobility Radeon HD 6370 with proprietary drivers v11.8 in Ubuntu 11.10 64 bit and I can't get it to detect an external monitor through HDMI. Not with the Catalyst software nor with the "Displays" utility. I just want to set up a simple and straight forward clone display configuration to see my laptop output on my HD TV monitor. I can do this without any trouble in Windows 7 (same machine, dual boot) so I know there's nothing wrong with my hardware (laptop, cable or TV monitor).

      I thought it had to do with my xorg.conf, but I don't really know how that works. I recently discovered that if I run xrandr i get:

      Code:
      Screen 0: minimum 320 x 200, current 1600 x 900, maximum 1600 x 1600
      LVDS connected 1600x900+0+0 (normal left inverted right x axis y axis) 382mm x 215mm
         1600x900       60.0*+
         1440x900       60.0 +
         1280x800       60.0 +
         1152x864       60.0 +
         1280x768       60.0 +
         1280x720       60.0 +
         1024x768       60.0 +
         1280x600       60.0 +
         1024x600       60.0 +
         800x600        60.0 +
         800x480        60.0 +
         640x480        60.0 +
      CRT1 disconnected (normal left inverted right x axis y axis)
      And as far as I can tell, the card has got an HDMI and a VGA port which should be at least listed as "disconnected", shouldn't they?

      Or maybe It is just completely unrelated and I have no idea what's going on.

      Any help appreciated

      Comment


      • #4
        I think CRT1 may be the VGA port, FWIW

        Comment


        • #5
          Can you pastebin your xorg log ?

          Comment


          • #6
            Im not sure which log will help, I'm absolutely new to this. This is my Xorg.0.log which is the one that was most recently modified.

            http://openpaste.org/D5f8136b

            Comment


            • #7
              Im not sure which log will help, I'm absolutely new to this. This is my Xorg.0.log which is the one that was most recently modified.

              openpaste.org/D5f8136b

              Comment


              • #8
                Thanks.

                You seem to have two GPUs in there -- one is the HD4250 IGP and the other is the HD6370M discrete.

                I don't remember current status of RandR support for multiple GPUs but my guess is that you are getting results from the first GPU, which is probably the HD4250 with the LVDS display and VGA connectors attached, and the HDMI is probably connected to the HD6370.

                I imagine you'll need to use the Catalyst control panel to see all the displays; xrandr will only cover a single GPU.

                Comment


                • #9
                  Yes, I already kind of went through this

                  Code:
                  aticonfig --lsa
                  gives me

                  Code:
                  * 0. 01:05.0 ATI Mobility Radeon HD 4200 Series
                    1. 02:00.0 AMD Radeon HD 6300M Series
                  The information section in the Catalyst GUI confirms this, however, the display manager only lists the 4200 adapter.

                  I thought I could sort this out with a new xorg.conf file generated by aticonfig --initial -f --adapter=all but that only resulted in X server failing to load at startup. I only got it working again by restoring the previous configuration.

                  But I really don't know what I am supposed to do

                  Comment


                  • #10
                    Try this

                    Originally posted by rocky_raccoon View Post
                    Yes, I already kind of went through this

                    Code:
                    aticonfig --lsa
                    gives me

                    Code:
                    * 0. 01:05.0 ATI Mobility Radeon HD 4200 Series
                      1. 02:00.0 AMD Radeon HD 6300M Series
                    The information section in the Catalyst GUI confirms this, however, the display manager only lists the 4200 adapter.

                    I thought I could sort this out with a new xorg.conf file generated by aticonfig --initial -f --adapter=all but that only resulted in X server failing to load at startup. I only got it working again by restoring the previous configuration.

                    But I really don't know what I am supposed to do
                    Here's what I would try.

                    Code:
                    cd /etc/X11
                    mv xorg.conf xorg.conf.bak
                    aticonfig --adapter=1,0 --initial
                    That should put the discreet card first in the xorg.conf as well as the Monitor/Screen also the HDMI is a DFPx (x being the port number not sure what you're setup looks like) and sofar all my experience with ATI cards the HDMI are numbered first when there are DVI ports as well.
                    On my 5970 there is 3 ports one mini display (mine hdmi) which is DFP1 and the the two DVI ports DFP2 and DFP3
                    On my 5870 there is x2 HDMI x2 DVI and yet again my HDMI ports are DPF1 DPF2 then DVI ports are DFP3 and DFP4

                    Now I have a tower and you're using a laptop so I don't know what they or how you have things sticking out and where lol, in my case If I'm leaning over from the front of my tower looking down at the Display ports from left to right on both cards would start the order 5970 DPF2 DVI, DPF1 HDMI ,DPF3 DVI (Even though they stuck the HDMI in the Middle it's still DPF1 and it's still left to right with the DVI's) Then my 5870 DPF1 HDMI, DPF2 HDMI, DPF3 DVI, DPF4 DVI.

                    So with that said you if you only have one HDMI port it should be DPF1 for the spefic card the HDMI port is for. then you need something like this in your xorg.conf:

                    I made this via the aticonfig command real quick(just for you =) for a pure basic config and edited out the extra displays to lessen your confusion to be used as an example. As I backed up my custom setup first like above.
                    I'm using my 5970 as the first card connected via a DVI the port is DPF2 (I'm using DVI because I need a Dual Link DVI(which basically means more pins) to obtain the 120Hz).

                    Code:
                    Section "ServerLayout"                                                                                                                                                                                                                                                         
                            Identifier     "aticonfig Layout"                                                                                                                                                                                                                                      
                            Screen      0  "aticonfig-Screen[0]-0" 0 0                                                                                                                                                                                                                             
                    EndSection                                                                                                                                                                                                                                                                     
                                                                                                                                                                                                                                                                                                   
                    Section "Module"                                                                                                                                                                                                                                                               
                    EndSection
                    
                     Section "Monitor"
                            Identifier   "0-DFP2"
                            Option      "VendorName" "ATI Proprietary Driver"
                            Option      "ModelName" "Generic Autodetecting Monitor"
                            Option      "DPMS" "true"
                            Option      "PreferredMode" "1920x1080"
                            Option      "TargetRefresh" "120"
                            Option      "Position" "0 0"
                            Option      "Rotate" "normal"
                            Option      "Disable" "false"
                    EndSection
                    
                    Section "Device"
                            Identifier  "aticonfig-Device[0]-0"
                            Driver      "fglrx"
                            Option      "Monitor-DFP2" "0-DFP2"
                            BusID       "PCI:3:0:0"
                    EndSection
                    
                    Section "Screen"
                            Identifier "aticonfig-Screen[0]-0"
                            Device     "aticonfig-Device[0]-0"
                            DefaultDepth     24
                            SubSection "Display"
                                    Viewport   0 0
                                    Depth     24
                            EndSubSection
                    EndSection
                    Hope this sheds more light then confuses you lol.
                    Just one more thing you should be able to setup your BIOS to your desired Display Adapter just another resort you can try as well then just need too run the --initial that should straighten things out as well.

                    Comment


                    • #11
                      Here's what I would try.

                      Code:

                      cd /etc/X11
                      mv xorg.conf xorg.conf.bak
                      aticonfig --adapter=1,0 --initial
                      That makes sense, but it results in X failing to load at startup. I had actually already tried something very similar.

                      I had a look at the BIOS and I couldn't find any option relating to the graphic card.

                      It seems that I am only able to use the 4200 GPU, it is listed as the default adapter and it bears all the load:

                      Code:
                      amdconfig --lsa
                      * 0. 01:05.0 ATI Mobility Radeon HD 4200 Series
                        1. 02:00.0 AMD Radeon HD 6300M Series
                      
                      * - Default adapter
                      Code:
                      aticonfig --odgc --adapter=all
                      
                      Adapter 0 - ATI Mobility Radeon HD 4200 Series
                                                  Core (MHz)    Memory (MHz)
                                 Current Clocks :    203           400
                                   Current Peak :    500           400
                        Configurable Peak Range : [200-500]     [400-400]
                                       GPU load :    18%
                      
                      Adapter 1 - AMD Radeon HD 6300M Series
                                                  Core (MHz)    Memory (MHz)
                                 Current Clocks :    750           800
                                   Current Peak :    750           800
                        Configurable Peak Range : [400-750]     [500-800]
                                       GPU load :    0%
                      I couldn't find a command to change the default adapter. Any other ideas?

                      Thanks for all the help

                      Comment


                      • #12
                        BTW what is your hardware -- is it a desktop system with integrated graphics and a PCIE card plugged in (in which case we're talking about two simultaneously active GPUs) or a hybrid graphics laptop where only one GPU is usually active at a time, or a "two GPU" laptop without hybrid graphics ?

                        Comment


                        • #13
                          Looks like a muxless hybrid laptop (called powerXpress) with the VGA and LVDS attached to the integrated GPU and the HDMI port attached to the discrete GPU. The X server currently doesn't handle these types of configurations, although there is work happening to better support them at least for open source drivers. I'm not sure to what extent fglrx supports these. I think you use aticonfig to select the discrete gpu if you want to use it. Something like aticonfig --px-dgpu might work.

                          Comment


                          • #14
                            Give this a whirl too.

                            Originally posted by agd5f View Post
                            Looks like a muxless hybrid laptop (called powerXpress) with the VGA and LVDS attached to the integrated GPU and the HDMI port attached to the discrete GPU. The X server currently doesn't handle these types of configurations, although there is work happening to better support them at least for open source drivers. I'm not sure to what extent fglrx supports these. I think you use aticonfig to select the discrete gpu if you want to use it. Something like aticonfig --px-dgpu might work.
                            Yes I was going say that originally about xorg-server , I was going to tell him to run (if he still wants too for kicks and giggles):

                            Code:
                            Xorg -configure
                            Mind you X server should not be running at all when you do this or you will get an error straight away.. I would run that command with the HDMI plugged in may get lucky
                            and see something we've missed.

                            He needs to have the Radeon drivers "x11-drivers/xf86-video-ati" installed to do this and mesa configured/built with video_cards_radeon (Should be already if you're using Ubuntu , I'm a Gentoo user so I only build use flags I need into my packages)
                            That will make Xorg scan hardware and all connected devices then parse a default xorg.conf in /root as xorg.conf.new then he can:

                            Code:
                            nano /root/xorg.conf.new or nano ~/xorg.conf.new  (if you're logged in as root)
                            You can use vi vim or whatever text editor you like and see how Xorg is detecting is things and or just use "cat" like so.
                            Code:
                            cat /root/xorg.conf.new  | less
                            My guess though after looking through the Xorg.0.Log it will only see the VGA(CRT) and LVDS as it did in the log file.

                            I would go with agd5f suggestion first as that seems the easiest to start with and being he's Dev always helps lol.
                            Code:
                            aticonfig --px-dgpu
                            I'm curious you mind? using a paste bin of the output of both:

                            Code:
                            lspci -v
                            and

                            Code:
                            aticonfig --adapter=all --initial
                            Again with the HDMI plugged in( (which I'm sure you've been doing anyway) I'd like to see the xorg.conf in it's entirety

                            Comment


                            • #15
                              BTW what is your hardware -- is it a desktop system with integrated graphics and a PCIE card plugged in (in which case we're talking about two simultaneously active GPUs) or a hybrid graphics laptop where only one GPU is usually active at a time, or a "two GPU" laptop without hybrid graphics ?
                              My hardware is a laptop (HP Pavilion dv7-4270us, AMD Phenom II Quad-Core Mobile Processor P960). As far as I know, it has got 1 graphic card labelled ATI Mobility Radeon HD 6370 s, but, yes, there's another GPU wandering about in there (the one identified as Mobility Radeon HD 4200) so it is probably one of those powerXpress hybrid things.

                              The problem seems to be that I can only start x with the 4200 GPU. I'm not sure if I'm going the right way here, but I tried an xorg.conf generated with sudo aticonfig --initial --adapter=1 -f. (since the 6300 adapter is listed as 1) and, as I expected Xserver failed to load at startup, but this time I was dumped into a prompt and I managed to get the Xorg log of this error. These are its last lines:

                              Code:
                              [    79.795] 0: /usr/bin/X (xorg_backtrace+0x26) [0x460566]
                              [    79.795] 1: /usr/bin/X (0x400000+0x64b7a) [0x464b7a]
                              [    79.795] 2: /lib/x86_64-linux-gnu/libpthread.so.0 (0x7ffeaa2c4000+0x10060) [0x7ffeaa2d4060]
                              [    79.796] 3: /usr/lib/x86_64-linux-gnu/xorg/extra-modules/extra-modules.dpkg-tmp/modules/drivers/fglrx_drv.so (xdl_xs110_atiddxPxPreInit+0x87) [0x7ffea6c00247]
                              [    79.796] 4: /usr/lib/x86_64-linux-gnu/xorg/extra-modules/extra-modules.dpkg-tmp/modules/drivers/fglrx_drv.so (xdl_xs110_atiddxPreInit+0x205b) [0x7ffea6bd688b]
                              [    79.796] 5: /usr/bin/X (InitOutput+0x834) [0x474134]
                              [    79.796] 6: /usr/bin/X (0x400000+0x23143) [0x423143]
                              [    79.796] 7: /lib/x86_64-linux-gnu/libc.so.6 (__libc_start_main+0xed) [0x7ffea920030d]
                              [    79.796] 8: /usr/bin/X (0x400000+0x235ed) [0x4235ed]
                              [    79.796] Segmentation fault at address (nil)
                              [    79.796] 
                              Caught signal 11 (Segmentation fault). Server aborting
                              [    79.796] 
                              Please consult the The X.Org Foundation support 
                              	 at http://wiki.x.org
                               for help. 
                              [    79.796] Please also check the log file at "/var/log/Xorg.0.log" for additional information.
                              [    79.796] 
                              [    79.805]  ddxSigGiveUp: Closing log
                              The full log is available at paste.kde.org/194630/

                              BTW, when I was dumped into this prompt I ran sudo aticonfig --lsa and the output was the opposite of before, now the 6300 GPU is listed as 0 and as default. No idea how this works.

                              I hope this info is of relevance, maybe I'm just messing things up. I haven't tried Acidphase's last suggestion, I will shortly.

                              Comment

                              Working...
                              X