No announcement yet.

Radeon HD 7970 -- driver?

  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    Originally posted by Hamish Wilson View Post
    warci, I suggest you try some of the steps outlined here:

    Specifically pay attention to this:
    yum install kernel-devel kernel-headers gcc gcc-c++
    The installation of Catalyst on Fedora can be a bit tricky, but I have never had too much trouble once I had completed it.

    Says the man writing quite happily from his main computer running R600g, but anyway...

    thx for the info! the good news is that ati FINALLY has a driver up for download on it's site, but i still get the same result! Tried the whole step by step thing but still no luck. I'm booting from a usb stick and then chroot into my system, so maybe that's giving me problems. I'll give it another go later this evening


    • #17
      My HD 7950 comes in tomorrow. I'll let you guys know if this 11.12+ driver works with it.


      • #18
        My understanding is that 8.921 (aka 11.12+) is the launch driver for both HD 7970 and HD 7950.


        • #19
          Originally posted by bridgman View Post
          My understanding is that 8.921 (aka 11.12+) is the launch driver for both HD 7970 and HD 7950.
          Got my card in and tried that driver. I ran into a bunch of problems, but it turns out that the driver just doesn't support kernel 3.2. I rolled back to kernel 3.0, and it loaded correctly. Mind you I'm on an eyefinity setup, so I first went in to AMDCCCLE and tried to get the screens configured correctly. Worked pretty well! For me, prior to 11.11, catalyst was crap for eyefinity, but this worked pleasantly. I tried out Unigine Heaven 2.5 at 4800x900 normal tesslelation x64, and I got an avg fps of 38.6 (min: 9.3, max 73.4) with this card and a Phenom II x6 @ 3.6ghz. Pretty sweet.

          BTW, when I open XBMC Eden beta, it defaults to full screen, and for some reason sets itself cloned across three monitors (overriding my eyefinity settings, grrrr). Then, when I hit backslash to go to windowed mode, the desktop just kind of hangs; I can still move the mouse pointer, but I can't control xbmc, or do anything, and have to ctrl+alt+f1 to reboot. Is this an XBMC issue with multi-monitors, or an issue with fglrx? It works fine in Windows.


          • #20
            Are you really sure about the kernel support? I only had to patch nvidia to support 3.3rc1+ recently. But that was just the script. For fglrx you definitely did not need to patch anything for some time. Maybe try 3.2.4 kernel, thats the first that actually works on my netbook. Most likely 3.2.3 got the real patches, but 3.2.4 was out with 2 reverted just a little bit later.