Announcement

Collapse
No announcement yet.

AMD proprietary driver? Ugh, what a piece of CRAP.

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #11
    @Wbx4

    I forced 11-11 driver in my script lately, do you use 11-12 driver? 11-12 has definitely bugs with hd 5670, most likely with other cards from the hd 5 series as well.

    Comment


    • #12
      Originally posted by Kano View Post
      @Wbx4
      I forced 11-11 driver in my script lately, do you use 11-12 driver? 11-12 has definitely bugs with hd 5670, most likely with other cards from the hd 5 series as well.
      Yes, I've downloaded 11.12 driver (since I downloaded latest available driver). Though I can remember that default Ubuntu packages from repo seems be older than that. Which is not helps anyhow in the regard of GPUs detected by OpenCL. Maybe I should try 12.1 but I suspect it is not anyhow better in this regard.

      For me it appears that there are 2 steady states: when OpenCL detects 2 GPUs and when it can only see 1 GPU. Since I do not know how OpenCL part of driver enumerates GPUs, I can't easily guess why it misses one of GPUs at the moment in OpenCL while can see it in ADL, etc.

      Technically, it is OpenCL calls who lie about number of GPUs available. So it looks like if this issue is buried somewhere in AMD's binary-only stuff and I have a very little idea how can I troubleshoot this.
      Last edited by Wbx4; 01-26-2012, 09:04 AM.

      Comment

      Working...
      X