Announcement

Collapse
No announcement yet.

AMD Catalyst 11.10 is out.

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #61
    When you install deb packages you dont get an uninstall script.

    Comment


    • #62
      Originally posted by Kano View Post
      When you install deb packages you dont get an uninstall script.
      It is good or bad

      it is safe remove here is anyone tested it maybe safe then rm or purge

      Comment


      • #63
        Originally posted by AozRoon View Post
        Hi,
        I am running a HD5850 card on a kubuntu 11.10 64bits OS.

        After installing the catalyst drivers (11.9 or 11.10) I can no more log in. Actually, after installation & reboot, I reach the login screen and if I fill the user/password and press return, I see quickly a black screen and then go back to the login screen.

        Notice that juste after installation, I get the following message if I try a :
        Code:
        $sudo aticonfig --initial -f
        aticonfig: error while loading shared libraries: libGL.so.1: cannot open shared object file: No such file or directory
        Even :
        Code:
        $amdcccle: error while loading shared libraries: libGL.so.1: cannot open shared object file: No such file or directory
        Any idea to fix that ? Thanks !
        Have you installed all the necessary packages? Especially the 32 bit ones?
        http://wiki.cchtml.com/index.php/Ubu...fore_you_start

        Comment


        • #64
          Have you installed all the necessary packages? Especially the 32 bit ones?
          http://wiki.cchtml.com/index.php/Ubu...fore_you_start
          Yes, the 32bit package is installed.

          I did not generate the .deb but did an automated installation (as I am always doing since kubuntu 8.04...). Could it come from this ?

          Comment


          • #65
            @Margus

            You dont need the script as you can simply uninstall the packages.

            Comment


            • #66
              Originally posted by chronniff View Post
              I'm just curious as to whether we do have the same problem, because I agree if its not just happening on my system then something could be wrong with the build scripts, and u would be second person to confirm this issue besides myself
              After removing of directly installed driver I can not install Catalyst 11.10 anymore - nor DEB-packages installation nor direct installation doesn't work for me anymore. Then there is probably something broken not only in package generation script but also in uninstall script. No one version of Catalyst before doesn't make so many troubles for me.

              Comment


              • #67
                Do you used this to make deb files. Working fine here in 32bit and x64 clean install. It maybe safe remove old debs from software center or from synaptic.
                http://wiki.cchtml.com/index.php/Ubu...fore_you_start
                Create .deb packages.


                $ sudo sh ./ati-driver-installer-11-10-x86.x86_64.run --buildpkg Ubuntu/oneiric

                You maybe have broken packages try to fix them, unfinished intstall. Is card detected $ fglrxinfo

                Comment


                • #68
                  didn't work for me either

                  The best way to install fglrx script is with Kano's script, IMO. So, I downloaded last script to install fglrx from Kano's site, then executing the script. The result is out of sync for my monitor.

                  Then grabbing the driver directly from amd site, and installing it directly (sh ati...) with the same result.

                  A pity, cause driver prior to this one is work for me.

                  Anyone can help? Kano? Bridgman? Anyone?

                  Comment


                  • #69
                    after installing from amd website with sh atiblabla.run

                    before reboot
                    try also sudo aticonfig --initial or amdconfig --initial
                    so it will write new xorg.conf

                    worked for me perfectly that way when i used amd cards
                    alltho every time kernel update happens u will have to install driver again.
                    in that case deb packages are better imo, tho i didnt have success with deb packages somehow.

                    Comment


                    • #70
                      if you guys have problems Ubuntu 11.10 with login screen unable to log in because no screen simply go to restart pc in then in crub edit GFX simply RENAME plaplaGFX and force to boot F10 key. It helps to go login screen with picture and uninstall or reinstall drivers when needed.

                      Dont forget aticonfig --initial -f

                      Comment


                      • #71
                        @xpander: Well, if you don't know, kano's script does the magic for you (make ke deb packages, running aticonfig, among others).
                        @Margus: debian testing 64bit on KDE 4.6.5 here.

                        Comment


                        • #72
                          @t.s.
                          yeah i know. but i cant test anymore. got free from the ati's curse.
                          grass is greener on other side.

                          Comment


                          • #73
                            Finally, I have installed successfully the drivers by generating then installing the deb packages.
                            Now everything is fine !
                            Happy :-)

                            Comment


                            • #74
                              This is the best driver since 11.06. OpenCL is still broken (read: OpenCL apps still busywait on a CPU, doesn't find both hardware devices like 11.6) but the performance in Windows games under Wine -- WOW! I'm not lying when I say I was blown away. A very visible difference in previously unplayable games like X3 TC and Champions Online. A 5830 with 11.10 is probably on par with an 8800GT running Windows games. This is amazing progress.

                              Comment


                              • #75
                                problems with 11.10 - suspend broken

                                Hello everyone,
                                I have an Asus K53TA laptop with A6-3400M APU and Radeon HD6650M discrete graphics card. I am using Ubuntu 11.04 64 bit.

                                Was using Catalyst 11.4 earlier since Ubuntu's restricted drivers installs that by default. Used only the integrated card and did not recognise the discrete card but it worked fine and was stable.

                                Used Fedora 15 64 bit with Catalyst 11.8 and it worked fine too Gnome 3.

                                However, Catalyst 11.9 caused many problems especially with KDE where it used to crash many times.

                                I didn't know it was a Catalyst issue until I read the release notes in the article about the Catalyst 11.10 release. Installed 11.10 and found general 2D slowness in Unity and Gnome. Also suspend is faulty. After resuming from suspend, blank screen. Does not work at all even if I suspend/resume many times. Have to shut it down forcefully by pressing and holding the power button.

                                Also, since the past few days using Gnome/Unity pressing Alt+Spacebar always causes window manager to crash. DE is fine, but no titlebars on windows anymore. This seems to happen on both Catalyst 11.9 and Catalyst 11.10. Right now I'm using Unity 2D which is fast,snappy and stable.

                                Any suggestions?

                                Comment

                                Working...
                                X