Announcement

Collapse
No announcement yet.

catalyst 11.9 is online ?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #41
    Bodhi 1.2, HD5750, fglrx 11.9

    Segfault on X startup when "composting" profile is selected.

    Comment


    • #42
      It is amusing that the only driver that works is the one they don't "officially support".

      Maybe with releases like this, we should be glad they almost never release "betas".

      What kind of a crappy QA process churns out a driver that crashes like this? If anyone from AMD reads this, you do actually _load_ the driver and kick it around for 10 minutes, right? I mean, that's all it would take for it to crash the system hard.

      Comment


      • #43
        Doesn't even start for me....

        Code:
        [    63.199] (II) ATI Proprietary Linux Driver Build Date: Sep 14 2011 10:36:30
        [    63.199] (++) using VT number 7
        
        [    63.363] (WW) Falling back to old probe method for fglrx
        [    63.442] (II) Loading PCS database from /etc/ati/amdpcsdb
        [    63.458] (--) Chipset Supported AMD Graphics Processor (0x68E0) found
        [    63.477] (WW) fglrx: No matching Device section for instance (BusID PCI:0@1:0:1) found
        [    63.477] (II) fglrx: intel VGA device detected, load intel driver.
        [    63.477] (II) LoadModule: "intel"
        [    63.477] (II) Loading /usr/lib64/xorg/modules/drivers/intel_drv.so
        [    63.590] (II) Module intel: vendor="X.Org Foundation"
        [    63.590]    compiled for 1.10.4, module version = 2.15.0
        [    63.590]    Module class: X.Org Video Driver
        [    63.590]    ABI class: X.Org Video Driver, version 10.0
        [    63.592] ukiDynamicMajor: found major device number 245
        [    63.592] ukiDynamicMajor: found major device number 245
        [    63.592] ukiOpenByBusid: Searching for BusID PCI:1:0:0
        [    63.592] ukiOpenDevice: node name is /dev/ati/card0
        [    63.592] ukiOpenDevice: open result is 7, (OK)
        [    63.592] ukiOpenByBusid: ukiOpenMinor returns 7
        [    63.593] ukiOpenByBusid: ukiGetBusid reports PCI:1:0:0
        [    63.611] (WW) PowerXpress feature is not supported on A+I Mux platform. Please uninstall fglrx driver.
        [    63.611] (EE) No devices detected.
        WTF?! Worked in 11.6

        Comment


        • #44
          Enough has already been said about this release. I'm back on the OSS drivers for now, and wishing they had just a bit better 3D support. Really good 3D performance is pretty much the only thing the blob has going for it.

          Comment


          • #45
            Originally posted by benmoran View Post
            Enough has already been said about this release. I'm back on the OSS drivers for now, and wishing they had just a bit better 3D support. Really good 3D performance is pretty much the only thing the blob has going for it.
            And very good power management, which is the only reason I use Fglrx instead of the oss drivers.

            Comment


            • #46
              Originally posted by admiral0 View Post
              WTF?! Worked in 11.6
              Blocking Intel+AMD hybrid systems when they worked before seems like an anti-feature. What a load of BS... Actually, the whole hybrid GPU concept is dumb. A modern GPU should be able to shut off unnecessary hardware and undervolt/clock at idle.

              Comment


              • #47
                I have the same problem with FC14. I use Catalyst to avoid overheating on my laptop. It was agonizingly difficult to downgrade from 11.9 to 11.7. Details here:

                http://www.fedoraforum.org/forum/sho...54#post1519254

                Version 11.9 reports:
                ukiOpenByBusid: ukiGetBusid reports PCI:1:0:0
                (WW) PowerXpress feature is not supported on A+I Mux platform. Please uninstall fglrx driver.

                At which point X gives up, finding no devices. With Catalyst 11.7, it instead says:
                ukiOpenByBusid: ukiGetBusid reports PCI:1:0:0
                (II) AMD Video driver is running on a device belonging to a group targeted for this release

                Comment


                • #48
                  Originally posted by xpander View Post
                  why is there no changelog, what changed since 11.8 ?
                  It could be like this:
                  Code:
                  We dont testing our code for linux at all
                  we just releasing this version to synchronize it with Windows version.
                  Whatever.

                  Comment


                  • #49
                    For new hardware, you're stuck, though?

                    So many complaining about this release, either bugs or regressions, or both...

                    http://inebium.com/post/catalyst-11-...e-shell-broken

                    http://www.fedoraforum.org/forum/sho...d.php?t=270357

                    https://bbs.archlinux.org/viewtopic.php?pid=1000812

                    http://lxnay.wordpress.com/2011/09/2...lete-disaster/

                    This is an ongoing trend with AMD/ATI and Linux support. So, either go through this motion or wait for FOSS support (and features limitations).... that's basically the attitude of AMD towards Linux. Doesn't look like it's changing anytime soon.... it's been like that, seems forever.

                    Comment


                    • #50
                      Originally posted by quptj7196lasjdf
                      rc7 kernel - fglrx doesn't need a patch to work with it (just like 11.8), and radeon hd 4850;
                      - i don't see rainbow bar in GNOME3 although other bad things stayed, like slow window moving or strange flickering/garbages rendered whenever i will run kde app with systray icon
                      - i've also tested it on xorg-server
                      Copy & paste spambot!

                      Originally posted by elizabeth4126
                      I m really interested to see the name of the forum. !!
                      Very nice Posts..
                      Another spambot

                      Originally posted by Edi8th99
                      We actually don't need to "believe" in anything, here's url:
                      https://launchpad.net/ubuntu/oneiric....10.4-1ubuntu2

                      latest x-server for ubuntu 11.10 is in 1.10.4 version, and it was commited on 2011-09-19
                      And another.

                      Three spambots in this thread alone. Hey Michael how about some cleaning? I've reported several copy&paste spambots, but I see they're still here. So do you want us to report spammers or not?

                      Copy&paste spambot = Copies some text from the first page in the thread to hide from bot filters.

                      Comment

                      Working...
                      X